Lightroom Classic: Do not collapse working folders after moving

  • 2
  • Idea
  • Updated 6 months ago
  • (Edited)
I ran the update to Lightroom Classic CC today. Currently running 8.4. There is new behavior today that is repeatable, and annoying. 

I have 2 drives that I work from. One is on my C: drive, and is my pictures folder. I have a secondary drive as well, which is the archive for photos after I'm done working. My workflow is:
  1. Import photos into Lightroom. This copies to my pictures folder, creating a Year/YYYY-MM-DD folder. This works great.
  2. I work on the photos while local. Export, etc.
  3. Finally, I drag the folder to the archive folder on my secondary drive. This process involves expanding several levels of folders to find the location where I store. (t:\photographs\2019, for instance.
The move works successfully, but after the move Lightroom collapses the folder structure for my C: drive, and collapses the folder structure for my T: drive. I'm left as if I hadn't expanded any folders at all.

I work with a lot of people training on Lightroom in my camera club. Many are confused about file structure, and file handling. Rolling up and putting away the folder structure is annoying to me, but would be very confusing to the less technical. This behavior is brand new in this version.

Photo of Geoff Faulkner

Geoff Faulkner

  • 46 Posts
  • 11 Reply Likes

Posted 11 months ago

  • 2
Photo of Sunil Bhaskaran

Sunil Bhaskaran, Official Rep

  • 486 Posts
  • 178 Reply Likes
Does the problem persist, even after a system restart? I tried to reproduce on a Win 10.
But couldn't.

Photo of Platt Johnson

Platt Johnson

  • 6 Posts
  • 7 Reply Likes
There are a lot of things like this. Generally speaking the user interface should never automatically change. It should always take user input to change.
I have Win 10 but there appear to be so many issues with this upgrade that I am not doing it yet.
Photo of Geoff Faulkner

Geoff Faulkner

  • 46 Posts
  • 11 Reply Likes
Yes, it is still a problem, even after rebooting. I setup a recording and it didn't roll up the C: drive this time, but it did roll up the T: drive. The behavior is inconsistent.

Here is the recording:!AogPqZ6mJBkXzYUl1uCeCsymGM2CNg?e=hjHHQG

Photo of Andrew Vaughan

Andrew Vaughan

  • 1 Post
  • 0 Reply Likes
I second this.  I have the exact same workflow, and I see the exact same behavior, and it's annoying.