Lightroom Classic CC: Vertical scroll bar in Develop disappears when using Adjustment Brush

  • 9
  • Problem
  • Updated 1 year ago
  • Solved
Vertical scroll bar on the right side in the Develop module disappears when using tools with larger panels, like the adjustment brush.  When this happens, you can't scroll down to access all the options/sliders in the current tool panel or access the standard Basic, Tone Curve, etc. panels below.  Changing the size of the filmstrip resets/fixes the problem, in some cases.

See video here for an example.

Troubleshooting steps already tried & failed -
- Turned the GPU on/off.
- Updated graphics drivers to the latest versions.
- Forced Lr to use OpenGL instead of DirectX according to this post.
- Reset Lr preferences.
- Replicated behavior on 2 computers
    - Win10 laptop - Intel HD 4400 GPU - 1920x1080 built-in display & 2560x1440 external display.
    - Win10 desktop - NVidia GTX 960 GPU - dual 1920x1080 displays
 
Behavior is the same on both computers.  The only difference is the point where the problem occurs varies, depending on Lr window size & monitor resolution.

This is new behavior since upgarding to Lightroom Classic CC.
Photo of Tom Mickow

Tom Mickow

  • 421 Posts
  • 163 Reply Likes

Posted 2 years ago

  • 9
Photo of Venkatesh Penjuri

Venkatesh Penjuri, Official Rep

  • 47 Posts
  • 13 Reply Likes
Official Response
Thanks Tom for reporting. We will look into this issue.
Photo of Michel GERADIN

Michel GERADIN

  • 1 Post
  • 0 Reply Likes
I face the same problem. I cannot even access to the 'masque de gamme' since the the corresponding control remains hidden.
Photo of Alberto Nasti

Alberto Nasti

  • 2 Posts
  • 0 Reply Likes
I am having exact same problem.  Win10 desktop - NVidia GT 610 - 1920x1080 
Photo of Bruce Houstoun

Bruce Houstoun

  • 102 Posts
  • 34 Reply Likes
Same here Win7 ATI Radeon5700 1920x1080
Workarounds I found are: use fullscreen mode, hide histogram or resize filmstrip. (All of these give more screen space back to the adjustment panel to a point where the scroll bar reappears.)

I can also resize the Lightroom window down from full screen to make it slightly shorter or use my 1680x1050 2nd monitor as the main screen, the scroll bar shows there.
Photo of John R. Ellis

John R. Ellis, Champion

  • 4598 Posts
  • 1242 Reply Likes
This reply was created from a merged topic originally titled Lightroom: Develop panel right scroll bar missing with Adjustment Brush.

When I start LR on a 1280 x 1024 display, open a photo in Develop, and select the Adjustment Brush, the scroll bar on the right-side Develop panels is tiny and unusable:



This may happen for some people only after you do Window > Screen Mode > Full Screen.  

When I try to click a couple of times on the scroll bar, first it disappears and then LR crashes.

Tested on LR 7.0 / MacOS 10.13.0.
Photo of JP

JP

  • 2 Posts
  • 0 Reply Likes
I'm having the same issue since recent change to Lightroom Classic CC. When the filmstrip is small enough (which is how i and most people use it) that the whole tool (e.g local adjustment brush) panel will fit into the sidebar, the scroll bar is made tiny and useless just like in John's screenshot above.
If the filmstrip is made tall enough that the whole brush panel doesn't fit into the sidebar any more, it appears as it should, but is extremely laggy to use. 

This is new behaviour since the update. I use Lightroom in fullscreen mode, 1920x1080.
Photo of Alberto Nasti

Alberto Nasti

  • 2 Posts
  • 0 Reply Likes
What is interesting is that the normal operating scrollbar comes back if you make the workings space smaller. For example by increasing the vertical size of the film strip.

It seems Lightroom goes screwy when the working space to total window size ratio reaches a certain threshold. I can consistently recreate this on my Windows 10 system
Photo of Tom Mickow

Tom Mickow

  • 421 Posts
  • 163 Reply Likes
Problem still exists in Lr Classic CC 7.1.
Photo of Chris Hitchcock

Chris Hitchcock

  • 8 Posts
  • 1 Reply Like
This reply was created from a merged topic originally titled Lightroom Classic: Can't see preview, reset or close buttons for the Adjustment B....

Win 10.
With the top and bottom preview panels open and using an adjustment brush, it isn't possible to see the preview, reset or close buttons for the tool. They are off the screen at the bottom and no scroll bar appears to make it possible to get to them.

Desktop composition enabled: Yes
Displays: 1) 2560x1080
Input types: Multitouch: No, Integrated touch: No, Integrated pen: Yes, External touch: No, External pen: Yes, Keyboard: No
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15632 Posts
  • 2368 Reply Likes
According to the bug notes, this issue was fixed in a recent release. Can any of you confirm whether this is still a problem with the current release (7.3.1)? Thanks
Photo of John R. Ellis

John R. Ellis, Champion

  • 4598 Posts
  • 1242 Reply Likes
I'm not able to reproduce the problem following the recipe I posted, on either Macos 10.13.4 or Windows 10 (LR 7.3.1).  Thanks.
Photo of Tom Mickow

Tom Mickow

  • 421 Posts
  • 163 Reply Likes
I have not seen the problem since moving to 7.3.1 on my Win10 machines.
Photo of JP

JP

  • 2 Posts
  • 0 Reply Likes
Can report the same, everything seems OK now.
Photo of Jerry Syder

Jerry Syder

  • 330 Posts
  • 148 Reply Likes
I will say it is still there. Unless the tiny scroll section at the bottom in the screenshot is considered usable: