Lightroom Classic CC v7.5 Crashes on Exporting a Folder or Collection to a Catalog

  • 1
  • Problem
  • Updated 4 days ago
  • In Progress
  • (Edited)
When I attempt to export either a Folder or its related Set of Smart Collections to a catalog, Lightroom Classic CC v7.5 consistently crashes, either immediately, or after running the task for a while.  The Adobe crash reporter application has not opened after any of these crashes.

The options that I am checking in the export dialogue are to Create/Include Smart Previews in the new catalog but not the original RAW negative files.

I have tried the following measures, all without success:
  • Optimizing the parent catalog.
  • Disabling 'Use Graphics Processor' under Preferences/Performance.
  • Updating the driver for my graphics card to the current version.
  • Resetting Lightroom Preferences back to default settings.
  • Uninstalling Lightroom Classic CC using its uninstall command in the Adobe Creative Cloud app, then reinstalling version 7.5.
  • Uninstalling Lightroom Classic CC as above, then installing the previous version of LR, 7.4.
  • Based on suggestions posted in this forum regarding similar problems, I added a config.lua file to Lightroom's settings folder containing these two flags, separately and together, 'Export.disableAdaptiveConcurrentSessions = true' and 'Develop.PreferOpenGL = true'.  (After this step proved ineffective, I removed the LUA file.)
  • Confirming disk space available to LR's cache folder (now using 52MB, with 40GB available).
  • Confirming disk space available to the folder for the parent catalog (now using 12GB, with 40GB available).
  • Confirming disk space available to the folder for the exported catalog (302GB available).
  • Confirming disk space available to Windows 10 Pro on the system partition (109 GB).
  • Confirming that my Windows installation is completely up to date.
The parent catalog is on the larger side, holding the 63K images relating to all of my commercial projects going back to 2016.  The folder that I am trying to extract into a new catalog is the one containing my work on a recent client project, with 664 images.  I want to sync that catalog to Lightroom CC web/mobile, the approach that I find best facilitates the kind of working meeting on the project that I need to have with my client.  (If I have to, I will fall back on the alternative of creating a remote desktop connection to my workstation from my client's office .. but I strongly prefer the other way.)

Can anyone suggest other possible fixes for this problem? 

I have been using Lightroom since version 1.0 and this is the first time that I can recall experiencing such a stubborn roadblock to getting my work done and such chronic instability from LR.  I will be grateful for any insights and guidance.

Below is an extract of the System Info that LR pulls up.

Cheers,

David


Lightroom Classic version: 7.5 [ 1186149 ]
License: Creative Cloud
Language setting: en
Operating system: Windows 10 - Business Edition
Version: 10.0.17134
Application architecture: x64
System architecture: x64
Logical processor count: 12
Processor speed: 3.1 GHz
Built-in memory: 16308.3 MB
Real memory available to Lightroom: 16308.3 MB
Real memory used by Lightroom: 4107.8 MB (25.1%)
Virtual memory used by Lightroom: 4411.3 MB
GDI objects count: 631
USER objects count: 1941
Process handles count: 3050
Memory cache size: 225.7MB
Internal Camera Raw revision: 1001
Maximum thread count used by Camera Raw: 5
Camera Raw SIMD optimization: SSE2,AVX,AVX2
Camera Raw virtual memory: 532MB / 8154MB (6%)
Camera Raw real memory: 534MB / 16308MB (3%)
System DPI setting: 96 DPI
Desktop composition enabled: Yes
Displays: 1) 1920x1080, 2) 1920x1080
Input types: Multitouch: No, Integrated touch: No, Integrated pen: No, External touch: No, External pen: No, Keyboard: No

Graphics Processor Info: 
DirectX: NVIDIA GeForce GTX 1060 3GB (25.21.14.1616)

Application folder: C:\Program Files\Adobe\Adobe Lightroom Classic CC
Library Path: D:\Photography\Lightroom\Commercial\Commercial-CC-2.lrcat
Settings Folder: C:\Users\david\AppData\Roaming\Adobe\Lightroom

Installed Plugins: 
1) AdobeStock
2) Canon Tether Plugin
3) Facebook
4) Flickr
5) Nikon Tether Plugin

Config.lua flags: None

Adapter #1: Vendor : 10de
Device : 1c02
Subsystem : 37241458
Revision : a1
Video Memory : 2988
Adapter #2: Vendor : 1414
Device : 8c
Subsystem : 0
Revision : 0
Video Memory : 0


Photo of David A. Gilmour

David A. Gilmour

  • 6 Posts
  • 1 Reply Like
  • tired, frustrated and anxious.

Posted 5 days ago

  • 1
Photo of David A. Gilmour

David A. Gilmour

  • 6 Posts
  • 1 Reply Like
UPDATE

I used LR Classic CC v7.5 to open another of my large catalogs and then tried exporting a couple of its Folders as new catalogs.  Those tasks completed normally.

So, the culprit may be some defect in the Commercial Projects catalog that I was initially trying to export from.

I am going to try to build a new Commercial Projects catalog.  I will have LR create a fresh catalog, then see if I can import the contents of the old Commercial Projects catalog into it.  If that works, I  will then test exporting from the new catalog the folder that I want to work with as a separate catalog.

I will report back here with the results.

David
Photo of David A. Gilmour

David A. Gilmour

  • 6 Posts
  • 1 Reply Like
UPDATE #2

Sadly my attempt to create a repaired version of my Commercial Projects catalog failed.  LR Classic CC v7.5 crashed while in the midst of importing the old catalog into a freshly created one.

While it would be a stretch to call it the bright side of the story, at least this time the Crash Reporter application did pop up, so I was able to submit the details of the crash.

Any ideas on solving the problem described in my original post?  Or on how to repair or efficiently recreate my apparently damaged Commercial Projects catalog?

David




(Edited)
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 3991 Posts
  • 762 Reply Likes
David, I just checked the Crash Reporter against the email you've used to sign into this forum. I only see one crash there from 8.18.2018

I will check again in a couple of hours and see if this report has shown up. 
Photo of Sunil Bhaskaran

Sunil Bhaskaran, Official Rep

  • 330 Posts
  • 116 Reply Likes
David,
We could get the crash report you sent.
I am sending an e-mail offline to get some more info from you.

Thanks,
Sunil
Photo of David A. Gilmour

David A. Gilmour

  • 6 Posts
  • 1 Reply Like
Thank you, Sunil.  I have received your e-mail msg and have replied by e-mail.
Photo of David A. Gilmour

David A. Gilmour

  • 6 Posts
  • 1 Reply Like
UPDATE #3

Very strange.  Over the past couple of days, I have made about two dozen attempts to export that particular folder and each time Lightroom has crashed.  This morning, when I tried again, the export completed normally

Very little has changed since my last attempt yesterday.  I have not rebooted my PC, logged out of my Windows session or even closed Lightroom since yesterday.

Just about the only thing thing that I did today, prior to the successful export re-attempt, was to clean up the catalog slightly, before providing the additional information requested by Adobe's Sunil in his offline message to me, referenced in his post to this thread today.

Specifically, after noticing that a couple of Folders in the catalog were greyed out because they were pointing to an old, now non-existent, local network location, one tidying step that I took was to fix those Folder links by pointing them to the new correct local network location.  Those two Folders on my NAS are completely unrelated to the Folder on my PC that I have been trying to export as a catalog.  Nevertheless, I get suspicious of a possible association with the crashing problem, just based on my general experience that simple networking issues can sometimes somehow cause strange application instabilities.

Besides those changes to the catalog, I moved some old Collections into a few new or existing Collection Sets.  Finally. I removed a few empty Folder links.

I have to think that one of those little tweaks somehow remediated my LR crashing problem because, as I already noted, very little else has changed or happened here since I posted my UPDATE #2 to this thread.

I will continue to monitor and test this catalog.  I will report back here if I experience any further instances of Lightroom crashing when operating on it, or if Sunil provides me with any insights after his examination of the info that I am providing to him.

David
(Edited)