Lightroom Classic: Unable to Import Photos into new catalog without crash

  • 15
  • Problem
  • Updated 2 months ago
  • Solved
  • (Edited)
Yesterday I "upgraded" to the Lightroom Classic CC version. I began trying to import some photos into my library and each and every time it crashes after a little while and doesn't actually import them.

I thought I would start a new catalog, to see if there was something incompatible or wrong with my previous library, however that too crashes. I can import about 2-3,000 photos and then each and every time I go to import a new folder of images -- bam.  

I've tried importing small batches, also crashes. 

Extremely disappointed!
Photo of Daniël Cronk

Daniël Cronk

  • 5 Posts
  • 0 Reply Likes
  • disappointed

Posted 11 months ago

  • 15
Photo of Melissa Rios

Melissa Rios, Lightroom Support Product Manager

  • 104 Posts
  • 25 Reply Likes
Official Response
Hi all,

This issue should be fixed in today's Lightroom Classic CC 7.2 version*. Please update your application and let us know if you still see this issue!

Lightroom Classic CC 7.2 is now available!


Thanks,
Melissa

Edit: Sorry about that - this issue is fixed for macOS with today's Lightroom Classic CC 7.2. We're still working on fixes for Windows.
(Edited)