Lightroom Classic CC: Solution for Library Ghosting + Map Not Displayed

  • 2
  • Idea
  • Updated 4 months ago
  • (Edited)
Like many others I also suffered from library ghosting and the map not getting displayed at all. And while adding config.lua with "AgView.disableDirect2D = true" helped and solved the problem with library ghosting, I was still getting no map. I guess it has something to do with older NVidia cards (mine is the 540M). 

My original settings in the NVidia Cotrol Panel were to run Lightroom with the NVidia card. When I switched these settings to use the integrated card, voilà, I can see the map. In the Lightoom preferences, I still keep the Use Graphic Processor ticked and the NVidia tray icon shows the GPU is being used. 

My guess is the Lightroom UI (library, maps) now gets displayed thru the integrated card and the application only uses the GPU to perform some operations. When all the UI gets displayed thru an older (officially unsupported) GPU, there are some bugs.

Interestingly, when I don't use the config.lua file (with "AgView.disableDirect2D = true") in my settings, there are still some artifacts although not that bad as the ghosting (only the rating bar below the image thumbnail is grayed out, without any stars visible, until I actually click on the thumbnail).

Finally, forcing Photoshop CC 2018 to be run with the integrated graphics (while keeping use the GPU ticked in the app's preferences) also solved some issues (like blank window in the "New" dialog).
Photo of David Paloch

David Paloch

  • 1 Post
  • 0 Reply Likes

Posted 4 months ago

  • 2
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 3608 Posts
  • 1142 Reply Likes
Thanks for sharing that tip David!