Lightroom Classic: Photomerge not working (macOS)

  • 7
  • Problem
  • Updated 9 months ago
  • (Edited)
I have upgraded to Lightroom Classic CC. It appears to befaster and I am able to edit and export photos, just as in the previousversion. However, I am not able to use Photo Merge to HDR, or Panorama. A previewis generated, but when I click Merge, nothing happens. There is no activity onthe status bar, even after several minutes. I have tried it several times, oncefor over 30 minutes, and have closed LR/Restarted my computer, none of whichhelped.

 

I have a late 2009 iMac, 21.5”, running macOS High Sierra,version 10.13.

 

It is equipped with a 3.06 GHz Intel Core 2 Duo processor,16 GB of 1067 MHz DDR3 RAM, and an ATI Radeon HD 4670, 256 mb Graphics Card. Ihave read that the Graphics Card is not used for photo merges, but for therecord, the graphics card does not support metal, and the Use GraphicsProcessor is checked.

 

My question is, is this a software bug, or is there asetting that needs to be changed, or does my system not meet the minimumrequirements to perform Photo Merges?
Photo of Kent Rowell

Kent Rowell

  • 4 Posts
  • 0 Reply Likes

Posted 10 months ago

  • 7
Photo of Jason Langley

Jason Langley

  • 2 Posts
  • 1 Reply Like
Same problem. Create preview works, but merge just sticks... Tried both with graphics processor enabled and disabled, same result. Uninstalled and reinstalled Lightroom Classic CC, restart, etc., no effect.

My system:
OSX 10.12 Sierra
4.01 GHz Intel Core i7
16 GB 3200 MHz DDR4
NVIDIA GeForce GTX 980 4095 MB

edit: Just checked and HDR merge also does not work, same problem...
(Edited)
Photo of joseph lux

joseph lux

  • 3 Posts
  • 0 Reply Likes
same here; i've lots of HDR merge activity and getting bupkis on this.  Where did this feature go????  Frustrated as well.
Photo of Sunil Bhaskaran

Sunil Bhaskaran, Official Rep

  • 319 Posts
  • 110 Reply Likes
Are you able to create a panorama using the short cut keys (without generating preview) CTR + SHIFT + M?
Which language have you installed Lightroom?
I have sent you a personal e-mail to get some additional logs?

Thanks,
Sunil
Photo of Jason Langley

Jason Langley

  • 2 Posts
  • 1 Reply Like
Hi Sunil, thanks for quick reply!

Unfortunately, that does not work either, same result. Task begins, but progress bar does not move:

Language is English (trial) version.
(Edited)
Photo of Sunil Bhaskaran

Sunil Bhaskaran, Official Rep

  • 319 Posts
  • 110 Reply Likes
Thanks, Jason.
I have sent you a message offline to get some additional logs.
Thanks,
Sunil
Photo of Stephen Newport

Stephen Newport

  • 264 Posts
  • 69 Reply Likes
No issue here:
MacBook Pro Late 2016High Sierra
Photo of Carlos Cardona

Carlos Cardona

  • 272 Posts
  • 50 Reply Likes
And you've tried turning off "Use Graphics Processor"?
Photo of Kent Rowell

Kent Rowell

  • 4 Posts
  • 0 Reply Likes
I have. It doesn't work on, or off.
Photo of Scott Rae

Scott Rae

  • 4 Posts
  • 3 Reply Likes
Same problem here on Windows 10 - panorama previews, but then nothing happens when you click merge, it just seems to hang.  Always worked before.  System is an  i5 3570K, GTX670, 16Gb RAM.  

Should say, Photomerge still works in Photoshop
(Edited)
Photo of Chris Castleberry

Chris Castleberry, Camera Raw Engineer

  • 340 Posts
  • 87 Reply Likes
"Should say, Photomerge still works in Photoshop"

Does merge work in Camera Raw?
Photo of Venkatesh Penjuri

Venkatesh Penjuri, Official Rep

  • 42 Posts
  • 12 Reply Likes
Are your images present in an external Hard disk or network? If so, could you try moving the images to local HD and merge and let me know if this works? 
Photo of Kent Rowell

Kent Rowell

  • 4 Posts
  • 0 Reply Likes
On my system, the images are on a local HD, not an external or network. Also, I have never done HDR in Photoshop, just LR.
Photo of Steve Loop

Steve Loop

  • 2 Posts
  • 0 Reply Likes
Same thing here on my machine,  Merging in pano mode not working,  We need answers Adobe now in this thread.  always worked before,  been buying LR since lightroom2   I have a two weeks worth of vacation pano's I need to finish!
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14098 Posts
  • 1749 Reply Likes
Working for me here, as well. What settings are you using? For mine, I tried several settings with panoramas, I also tried HDR and I have Auto Align and Auto Tone enabled  Deghost is set to none. 
(Edited)
Photo of Kent Rowell

Kent Rowell

  • 4 Posts
  • 0 Reply Likes
I have Auto Align enabled, Auto Tone disabled and Deghost set to medium. There was an update yesterday that I hoped would somehow fix the problem, but it did not. 
Photo of Graham Colling

Graham Colling

  • 3 Posts
  • 2 Reply Likes
This reply was created from a merged topic originally titled photo merge not working in Lightroom Classic CC.

I am trying to use HDR Photo Merge for the first time in Lightroom Classic CC (7.0 release).  I get to the preview screen, click on Merge and the progress bar top left, next to the Lr symbol remains clear.  No progress occurs.  I didn't initially notice this so had started three HDR merges before realising the problem.  The same thing has happened with a panorama I've tried to create.  I have restarted Lightroom just in case and also switched of the graphics processor (just in case that made a difference).  I am on a Mac Desktop (2014), OS Sierra v10.12.6.
Photo of Graham Colling

Graham Colling

  • 3 Posts
  • 2 Reply Likes
I've been carrying out some experimentation of this problem.  I'd noticed that sometimes the merge did complete successfully.  I believe having tried this a few times that if I am in the Library module and use photo merge it does complete.  However, if I choose further files to merge after clicking merge in the preview dialog and BEFORE the progress bar has disappeared, the following merge does not show any progress.  Hope this may help others.
(Edited)
Photo of Paul Booth

Paul Booth

  • 1 Post
  • 0 Reply Likes
I am having the same issue. Trying a 9 image merge and nothing happening. Gets as far as merge and then just stops. I have tried it with varying amounts of images and in Library mode and still nothing. Needs addressing this problem asap.
Photo of Christopher Marsham

Christopher Marsham

  • 1 Post
  • 0 Reply Likes
Same issue - since updating to Classic PM does not work - might merge a couple or so frames but no more.  Works OK in PS .
Photo of Ed Frazier

Ed Frazier

  • 2 Posts
  • 2 Reply Likes
This reply was created from a merged topic originally titled LR HDR Merge background task stalled.

For some reason this feature is no longer working (worked in the past).  In LR Classic CC (7.0.1) I select 3 files from a drone (Mavic Pro) right click select photomerge in HDR.  I get the Photo Merge pop-up window to select the various HDR options.  When I select Merge I get confirmation that "Photo Merge added to tasks" with a status of "Creating HDR" then nothing.  I can still navigate within LR and everything seems to move along fine in all other areas just here nothing.

I've tried rebooting my machine...closing LR opening PS nothing works!  This was never a problem before....not sure what happened.  I haven't changed anything on my iMac so the frustration level is high!
Photo of SatishT

SatishT, Employee

  • 62 Posts
  • 22 Reply Likes
Hi,
Can you follow this steps mentioned in the linked post and let us know if your issue gets resolved? 
https://feedback.photoshop.com/photoshop_family/topics/merge-to-hdr-simply-doesnt-work?&reply[id...


-Satish