Lightroom Classic CC Keyword Bug

  • 2
  • Problem
  • Updated 10 months ago
  • Solved
  • (Edited)
This is the weirdest bug. I created a test catalog (for other reasons) in which I have 4 photos and 4 keywords, and when I click on 2 of the keywords in the Metadata Filter panel, the photos don't show up. Somehow, when Lightroom Classic CC created this catalog, it seems to have buggered the indices (or something), and I can't fix it.

Here is are screenshots showing the problem.
First, all 4 keywords:

Second, a keyword that filters correctly:

Third, a keyword that filters incorrectly:


I created a catalog in Lightroom CC 2015 format that accesses the exact same photos, and it works correctly. The keywords that are assigned to these photos are:
$ exiftool -subject *.jpg
======== seaotter2.jpg
Subject : Tag 2, Tag 4 ======== seaotters.jpg Subject : Tag 2, Tag 3 ======== stopstaring.jpg Subject : Tag 1, Tag 3 ======== suspicious.jpg Subject : Tag 1, Tag 4 4 image files read

I have tried the following, but have not been able to make the keywords work correctly in the CC Classic database
  • Read the metadata from the files
  • Write the metadata to the files
  • Create a new user account, with default Lightroom preferences, and open the catalog from that account
  • Optimize the catalog
My conclusion is that somehow Lightroom Classic CC created a catalog that was "corrupted at birth." This is, as you might imagine, disturbing if this can happen regularly.

The catalogs (in both LR CC 2015 format and LR Classic CC format) can be found at https://www.dropbox.com/sh/mo66xn9rzqrvrma/AABomMT-4aU25fxuVbgqnhjqa?dl=0 if you want to play with them yourselves.

Thanks for any insight anyone can offer.

A

PS -- this is on Macintosh




Photo of Alan Harper

Alan Harper

  • 424 Posts
  • 84 Reply Likes

Posted 10 months ago

  • 2
Photo of John R. Ellis

John R. Ellis, Champion

  • 3690 Posts
  • 963 Reply Likes
I've seen a couple of other reports in the last year or so of apparently screwed up keyword indexes.  

One more thing to try: Select all the photos and do File > Export As Catalog, with none of the options selected.  I believe that exporting as a catalog may end up building a large part of the catalog SQL database from scratch.
Photo of Alan Harper

Alan Harper

  • 424 Posts
  • 84 Reply Likes
So... The export worked, in the sense that the phantom keywords were eliminated. Then reading metadata from the files restored the keywords that were in the JPEG files and the (exported) database seems to have no bugs in it.

Thanks for the solution, John. As I said, this was a test case, but now I know what to do if it happens "In Real Life."

I'll leave the databases at that link for a few days in case anyone from Adobe wants to investigate how the indices might have gotten corrupted. Then I'll remove them from my Dropbox.