Lightroom: Overlapping display of images in Library

  • 3
  • Problem
  • Updated 2 years ago
  • (Edited)
I upgraded to Lightroom Classic CC from Lightroom CC and have a problem.  When I change photos in the Library Module the previous photo can be seen in the background instead of the typical gray/white/chosen background color.  I've attached an image to show what I'm seeing.  This does not happen in the Develop Module and did not happen in the previous version of Lightroom CC. 

I tried disabling the GPU accelerator, optimizing the catalog, and Adobe tech support spent 25 minutes trying to fix it on my computer with no luck.  

My system info: Windows 8.1 64 bit, 4TB SSD drives in Raid 0, 32GB RAM, Intel I7 4910MQ 2.90 GHz Processor, GPU: GeForce GTX 870M.  

Here is what I see in Library Module:



This is what I see in Develop Module:
Photo of Fishweasel

Fishweasel

  • 4 Posts
  • 2 Reply Likes
  • Irritated

Posted 2 years ago

  • 3
Photo of Sunil Bhaskaran

Sunil Bhaskaran, Official Rep

  • 420 Posts
  • 147 Reply Likes
Official Response
Could you please try the following and report back if it solves the issue.

==
Try this workaround to see if it works for you. If not, delete the config.lua file afterwards.

  1. Choose Edit > Preferences.
  2. In the Preferences dialog, go the Presets tab.
  3. In the Presets tab, click the Show Lightroom Presets Folder button. The root preset folder opens in the File Explorer. 
  4. In the File Explorer, navigate into the Lightroom folder.
  5. Go to the link https://adobe.ly/2hUHGYa and download the config.lua file. Copy the downloaded config.lua file into the Lightroom folder mentioned in the previous step.
  6. Relaunch Lightroom Classic CC.
The System Info dialog (Help > System Info) should display the config.lua flags entry as shown below:

Config.lua-Flags:
AgView.disableDirect2D = true
==

Thanks,
Sunil
Photo of Fishweasel

Fishweasel

  • 4 Posts
  • 2 Reply Likes
I'm not sure what happened but I lost almost 200GB of hard drive space with the new catalog in Lightroom Classic with all of the previews that were built.  Is this related to the workaround above?  I tried discarding the full size previews that were built for 100k photos - these alone take up 48 GB, but it doesn't seem to be working
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1573 Posts
  • 514 Reply Likes
Lightroom Classic employs some compression technique on some database tables (such as develop history settings) that results in reduced catalog size. See https://www.lightroomqueen.com/whats-new-lightroom-classic-october-2017-70/.
Photo of kevina9023

kevina9023

  • 2 Posts
  • 1 Reply Like
This was very helpful, thank you.
Photo of Fishweasel

Fishweasel

  • 4 Posts
  • 2 Reply Likes
Hello and thank you for the quick response.  This workaround resolved the issue.  
Photo of Wendy Elphinstone

Wendy Elphinstone

  • 2 Posts
  • 0 Reply Likes
Thank you so much Sunil!  I had the same problem and have searched for hours trying to find an answer. It worked! Thanks again!
Wendy
Photo of Jack Wood

Jack Wood

  • 6 Posts
  • 1 Reply Like
This reply was created from a merged topic originally titled Library Thumbnail Curruption/Overlap.

Hi all,

I had a search but couldn't find anything similar - apologies If I've missed it!

The library previews in LRC (I think since the upgrade, but can't be 100%) have started overlapping each other as I scroll up/down.. I have tried reinstalling LRC and removing the existing previews but am still getting the problem (see images).

Windows is up to date (8.1)

Help appreciated!

Photo of Jack Wood

Jack Wood

  • 6 Posts
  • 1 Reply Like
This solved the problem - many thanks, all!
Photo of Marco Stuewe

Marco Stuewe

  • 2 Posts
  • 0 Reply Likes
Oh my... I was SO happy when I found this post and Simon's config.lua actually did the trick (thanx again Simon!!) - but Alas, since the last update which I installed yesterday, the previously described overlapping is BACK, even though I made sure the config.lua is in place...
So sad :(
Dude, if there is an equally simple solution, point me in the direction, please...

Oh, and YES, according to the System Info dialog ,the AgView.disableDirect2D is set to "true".

(Edited)
Photo of Jack Wood

Jack Wood

  • 6 Posts
  • 1 Reply Like
Hi there, I had the same problem. Disabling the GFX processing fixed it (not ideal but works for now). Can confirm the config file set the above attribute to true also.

Thanks.
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1573 Posts
  • 514 Reply Likes
Hi Marco, 

If you updated to the latest LrClassic 7.2, the recommended way to workaround the issue is to check off the "Use Graphics Processor" in the Lightroom Preference dialog, which now works like a master switch for the GPU acceleration. No more need to play with the config.lua file, which you can remove now.

The updated documentation for Lr Classic 7.1 is at https://helpx.adobe.com/ie/lightroom/kb/library-module-image-rendering-issue.html. If possible, you should follow the documentation to get your graphics card driver updated, that might work without the need for the workaround.
(Edited)
Photo of Marco Stuewe

Marco Stuewe

  • 2 Posts
  • 0 Reply Likes
Jack and Simon, thank you - this worked out fine!
Have a great 2018!