Lightroom Classic: Interface Blurry (macOS)

  • 1
  • Problem
  • Updated 3 months ago
  • (Edited)
My workspace in Lightroom Classic CC is pixelated/blurry. I'm running Mojave on a 15in retina display macbook pro. All other apps are fine but upon upgrading LR it's now blurry (not the photos, the actual interface). When I look at LR system info it says display is 1400x900 but my monitor is 2880 x 1800. Looking for help troubleshooting this one as I'm finding LR unworkable and downgrading is not an option as I need latest version for my camera profile.
Help is appreciated guys!
Photo of Sarah Rocca Vento

Sarah Rocca Vento

  • 5 Posts
  • 0 Reply Likes

Posted 4 months ago

  • 1
Photo of Andrew Rodney

Andrew Rodney

  • 723 Posts
  • 144 Reply Likes
Try disabling GPU support in preferences. 
Photo of Sarah Rocca Vento

Sarah Rocca Vento

  • 5 Posts
  • 0 Reply Likes
Andrew, is that the Use Graphics Processor? I tried that one, rebooted, no dice. Thanks though.
Photo of Sarah Rocca Vento

Sarah Rocca Vento

  • 5 Posts
  • 0 Reply Likes
Alas, that did not work either.
Photo of dmeephd

dmeephd

  • 300 Posts
  • 73 Reply Likes
If you do have to go backwards, simply copy your camera profile and paste it into the older version of LR.  You should be fine.  (You could also get the profile from Camera Raw.  Users have been doing that for years as Camera Raw always seemed to be updated more often than Lightroom.)
Photo of Dan Hartford Photo

Dan Hartford Photo

  • 234 Posts
  • 92 Reply Likes
I'm a PC person so this may not translate to a Mac, but what screen resolution does your operating system think your display is?  1400x900 or 2880x1800?
Photo of Sarah Rocca Vento

Sarah Rocca Vento

  • 5 Posts
  • 0 Reply Likes
Dan, How do I see that? I only know how to look at the display in LR (1400x900) under System Info and what my actual Display is on the Mac under my System report Display (2800x1800) I can scale the display to make fonts smaller but the issue is still there (it seems, kind of too small to see anything or read LOL)
Photo of Dan Hartford Photo

Dan Hartford Photo

  • 234 Posts
  • 92 Reply Likes
On a Mac I'm not sure.  On a PC, right click on a blank area of the desktop and select "Display Settings".  Perhaps a Mac person on this forum can tell you the steps on a Mac.
Photo of Andrew Rodney

Andrew Rodney

  • 723 Posts
  • 144 Reply Likes
You're doing it 'correctly' on the Mac Sarah. 
Photo of Sunil Bhaskaran

Sunil Bhaskaran, Official Rep

  • 404 Posts
  • 144 Reply Likes
Sarah,
I have sent you an e-mail off-list.
Could you please send us a screenshot?

Thanks,
Sunil
Photo of Sarah Rocca Vento

Sarah Rocca Vento

  • 5 Posts
  • 0 Reply Likes
Sunil, I have replied to your email with screenshots. Thank you!