Lightroom Classic CC has completely ceased to function

  • 1
  • Problem
  • Updated 4 months ago
Lightroom Classic has ceased to function entirely -- I can open the app, at which point CPU usage skyrockets to over 250%. I have tried pausing CC sync, address lookup, and facial recognition, none of which solves the issue.

I can view collections, but cannot make any changes to order or contents.

I cannot turn off/on CC sync for each collection.

The import dialog will open but nothing will import.

Optimize catalog hangs and attempting to cancel after over 30 minutes causes the entire application to hang. 

Attempting to QUIT the application causes it to hang. 

I am running the latest version of Lightroom Classic CC on the latest release of Mac OS Mojave. These issues began before the 10 December update and have continued after the update. Get this fixed, yesterday.
Photo of Ian Bowen

Ian Bowen

  • 1 Post
  • 0 Reply Likes
  • angry, frustrated

Posted 4 months ago

  • 1
Photo of Tim McMahon

Tim McMahon

  • 24 Posts
  • 7 Reply Likes
Hi Ian
I too am running the latest release of Lightroom Classic CC on the latest release of Mac OS Mojave. But I have no such issues.    Whatever fix is required is likely to be related to something else about your setup.  It might be useful to the engineers to know what other software you are running that could be interfering, and something about the specs of your machine.
(Edited)
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 4761 Posts
  • 1843 Reply Likes
I'll ask the stupid question - have you tried rebooting?

When did the issues start? And what happened just before they started?

Have you tried uninstalling Lightroom and reinstalling?