Lightroom Classic: Softproofing issue with GPU enabled

  • 2
  • Problem
  • Updated 4 weeks ago
  • Acknowledged
  • (Edited)
I am having an issue with Lightroom Classic CC when 'Use GPU Processor' is selected.

The bug is as follows:

If I turn on the paper gamut warning whilst soft proofing, Lightroom shows out of gamut areas correctly in red but it also changes the picture output as thou turning soft proofing on and off.

Additionally, once the paper out off gamut is selected, changing between relative and perceptual rendering intents has no affect.

Again, this is resolved by turning of the GPU option but I would like to use the GPU option if is helps my machine perform more efficiently.

Windows 10 Pro
CPU: I7 8700K
Ram: 32GB
Photo of mark johnson

mark johnson

  • 3 Posts
  • 0 Reply Likes

Posted 2 months ago

  • 2
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 4482 Posts
  • 886 Reply Likes
I am not able to reproduce what you are seeing, Mark. 

It might be helpful to list your GPU Specs and current driver version.
Photo of mark johnson

mark johnson

  • 3 Posts
  • 0 Reply Likes
Thanks for the reply.

I'm using an MSI GeForce GTX 1060 Gaming X 3GB
Using current driver version: msi NVIDIA driver 391.01

So jusr to clarify, this issue only occurs when using gpu performance ticked. It is a new PC build so I suppose it could be something local to my computer. I'll record a video later on an upload to YouTube.

Regards
Mark
Photo of mark johnson

mark johnson

  • 3 Posts
  • 0 Reply Likes
I have done a video demonstrating the issue. Again, if I turn off GPU then everything is fine.

The first part of the video I am demonstrating then when I click on the gamut warning button for the profile it is highlighting the out of gamut area in red but also changing the appearance of the photo such as in the shadows in the bottom right.

The next part of the demonstration is to show that changing from relative and perceptual works until I check on the gamut warning button and then it does not work. Once i turn off the GPU, switching from relative to perceptual does work.

https://youtu.be/TWqrlPMGnps
Photo of Todd Shaner

Todd Shaner, Champion

  • 1133 Posts
  • 366 Reply Likes
I can confirm this behavior with LR 7.5 on Windows 7 with Nvidia Quadro 600 GPU. In addition checking an Adobe RGB TIFF created using PS CC 2018 'Convert to Profile' shows out of gamut areas in LR Soft Proof. With GPU off some areas are still showing out of gamut in LR, but nothing is showing out of gamut using PS CC 2018 'Proof Colors' with Adobe RGB selected.
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 4482 Posts
  • 886 Reply Likes
We are no longer able to reproduce this. Can anyone on this thread verify that it still happening under Lightroom 8?
Photo of Todd Shaner

Todd Shaner, Champion

  • 1133 Posts
  • 366 Reply Likes
Rikk, both issues remain the same using LR 8.0 as with LR 7.5 on my Windows 7 system. It's possible the amount of out of gamut area showing has been reduced, but It's still wrong.