Lightroom Classic: Curves very slow working compared to Camera Raw - very old problem

  • 2
  • Problem
  • Updated 4 months ago
  • Acknowledged
  • (Edited)
All the time that I worked with Lightroom I saw one annoying problem: curves is very slow. I mean very slow response to my mouse move. If I'm using curve in Photoshop in file of any size time response between my mouse move and image is perfect it's real time. If I'm using curve in Bridge (open file in ACR of any version) time response also perfect. But in Lightroom using curves is much slower like "oh... may be I come back to old days with 486 PC" :)
I'm opening same images in ACR and Lightroom and in same windows size.

Also I should add that size of curve in Lightroom is smaller then in ACR so it's harder to make precise adjustments.
Photo of Stanislav

Stanislav

  • 7 Posts
  • 0 Reply Likes

Posted 5 months ago

  • 2
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 3814 Posts
  • 717 Reply Likes
Stanislav,

You don't say but I am guessing from your '486' comment you are a Windows user? I don't see any lag in the Lightroom Classic CC tone curve movements/screen updates. It works at the same speed as ACR on my system. 

Double check your video driver (if you are on Windows). Go to your video card manufacturer's website and make sure you are using the latest version of their software. (Don't rely on Windows Update for this).

With regard to more precision, you can use the [Alt/Opt] key while dragging the curve (or points on the curve) to restrict the movement to 1/10th of its normal motion. This precision mode will allow you to make incredibly fine movements to your tone curve adjustments. 
Photo of Stanislav

Stanislav

  • 7 Posts
  • 0 Reply Likes
Yes I'm using Windows 8.1 x64.
NVIDIA GeForce GTX TITAN  6Gb
I'm using latest version of video drivers and Windows updates.
And I should say again that this was a year ago, two years ago... and right now too (with any versions of drivers).
And with any settings: use graphic processor or not, use smart previews or not.
For better understanding just look at this video that I made today:
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 3814 Posts
  • 717 Reply Likes
Thanks for the video, Stanislav. I see the behavior difference in Lightroom Classic CC vs ACR that you are experiencing. I don't see that on my system. Both Lightroom Classic CC and ACR behave as good (or maybe even slightly better) than your ACR example.  I am testing in Windows 10 and Mac 10.13.4. 

As a test, if you go to the Lightroom Classic CC Tone Curve and set it to be in Normal (Not Point Curve) mode, and slide the Highlights, Lights, Darks, or Shadows Slider rapidly, does the curve respond as expected?
Photo of eartho

eartho

  • 814 Posts
  • 198 Reply Likes
Looks like he's using a 4K display with a 42mpx Sony raw though... do you all have a similar setup there?
Photo of Stanislav

Stanislav

  • 7 Posts
  • 0 Reply Likes
Your test passed with perfect result.
If I'm using Highlights-Lights-... sliders then everything works smoothly.

And I'm using monitor 2560x1440 px. Files are Sony RAW 42 Mp.
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 3814 Posts
  • 717 Reply Likes
Are you using the same pointing device to move the curve points as you did the slider?  If so, any chance you could shoot a quick cellphone video and attach it here for the engineers to view?
Photo of Stanislav

Stanislav

  • 7 Posts
  • 0 Reply Likes
I'm using Wacom Intuos Pro tablet and mouse. In both cases same result as I told some posts before.
May be you could tell me e-mail or other private address where I can send videos and other information that you need?
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 3814 Posts
  • 717 Reply Likes
You can share a video via Dropbox or similar. Just drop us a link after you do so. 
Photo of Stanislav

Stanislav

  • 7 Posts
  • 0 Reply Likes
I don't want to drop a public link with my work studio :) Hope you are understand.
(Edited)
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 3814 Posts
  • 717 Reply Likes
You can share the link directly to me at f l o h r @ a dobe.com (removed the extra spaces)
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 3814 Posts
  • 717 Reply Likes
I was able to repro on a Win 10 laptop with 4K screen. I have logged a bug for this.