Lightroom Classic: Crop tool image disappears

  • 2
  • Problem
  • Updated 1 year ago
  • Solved
  • (Edited)
The latest current version of Lightroom Classic CC, once I select the crop tool the image I'm currently working on disappears.

Quick look around and this bug seems to be a common issue and the workaround is disabling graphics processor in preference. Yet, in doing this, it makes Lightroom extremely sluggish and barely usable as I'm using a 1440p monitor. Surely there has to be a better fix than this. 

Windows 10 PC:
6600k OC 4.2GHz
GTX 1070 (Latest drivers)
16gb ram DDR4 3000 mhz
Photo of Alastair Harmer

Alastair Harmer

  • 9 Posts
  • 3 Reply Likes

Posted 2 years ago

  • 2
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1727 Posts
  • 600 Reply Likes
Please follow to download and install the latest GPU driver manually. For Nvidia card, it is important to perform the clean installation procedures for your graphics card driver.
Photo of Alastair Harmer

Alastair Harmer

  • 9 Posts
  • 3 Reply Likes
My fix: 

Any programmes that alter clock or fan speed etc of the graphics card seems to be causing this issue.
Photo of paulflewis


  • 1 Post
  • 1 Reply Like
Simon Chen's post solved this for me. I had the same problem. I updated my AMD driver using the AMD auto-detect tool, and it all seems to be working fine now. Disabling the graphics processor is a non-starter for me. Way too slow.