Lightroom Classic CC: Color profile seemingly unapplied

  • 1
  • Problem
  • Updated 7 months ago
  • (Edited)
This problem has occurred for at least several versions of Lightroom Classic CC; Currently experienced with 7.2 [ 1156743 ].

Problem occurs regularly, though not consistently, and not in a way that can be replicated reliably. General process is like so:

- Raw files shot on Canon 5D Mark IV

- Import settings:
  - Copy as DNG
  - Build minimal previews
  - Do not build smart previews
  - No settings applied on import, etc.

- Open photo in develop module:

  - The expected behavior, which is the case with most photos: Switch to the crop tool, and there is no change in the colors of the image on screen. The crop tool simply activates, covering the entire area of the image

  - The problematic behavior, which occurs intermittently: When viewing the photo in the develop module, it appears desaturated. When the crop tool is activated, the color rendering of the image changes notably, seemingly increasing saturation / warmth. As if a color profile was changed / applied. If the crop tool is deactivated without altering the crop, the color reverts to the desaturated / cooler look. But, if one does effect a crop of any kind, the more saturated / warmer look will persist

    Similarly, the "desaturated" issue can be cleared if one changes the Profile under Color Calibration and then changes it back (e.g. flip it from Adobe Standard to Camera Faithful, then back to Adobe Standard -- the desaturated / cool color issue is resolved). It can also be cleared by making any alteration to white balance (e.g. increase temperature by one unit, then decrease)

     Interestingly, if one exports a JPG of the image while it is being rendered in the incorrect "desaturated" way, the exported JPG is actually saturated / warmer in a way that matches the "correct" rendering one gets if they utilize the crop tool, white balance tool, or a color profile change in order to get the correct color rendering to appear on screen.

This bug is very problematic because unless you happen to be adjusting crop, white balance or color profile during editing, an exported JPG will look much more saturated / warmer than what was seen on screen when the user exported. For example, one could adjust contrast and many other settings, without the color balance correcting itself on screen.

Full system details:

Lightroom Classic version: 7.2 [ 1156743 ]
License: Creative Cloud
Language setting: en-US
Operating system: Mac OS 10
Version: 10.12.6 [16G1212]
Application architecture: x64
Logical processor count: 4
Processor speed: 3.4 GHz
Built-in memory: 32,768.0 MB
Real memory available to Lightroom: 32,768.0 MB
Real memory used by Lightroom: 10,457.1 MB (31.9%)
Virtual memory used by Lightroom: 18,123.8 MB
Memory cache size: 2,362.1MB
Internal Camera Raw revision: 894
Maximum thread count used by Camera Raw: 3
Camera Raw SIMD optimization: SSE2,AVX,AVX2
Camera Raw virtual memory: 1886MB / 16383MB (11%)
Camera Raw real memory: 1963MB / 32768MB (5%)
Displays: 1) 2560x1440

Graphics Processor Info: 
Metal: NVIDIA GeForce GTX 775M

Installed Plugins: 
1) AdobeStock
2) Aperture/iPhoto Importer Plug-in
3) Canon Tether Plugin
4) ColorChecker Passport
5) Facebook
6) Flickr
7) Nikon Tether Plugin
Photo of wlodarczyk

wlodarczyk

  • 10 Posts
  • 0 Reply Likes

Posted 7 months ago

  • 1
Photo of John R. Ellis

John R. Ellis, Champion

  • 3724 Posts
  • 974 Reply Likes
Does the problem occur with the GPU disabled?  (Preferences > Performance > Use Graphics Processor unchecked)
Photo of wlodarczyk

wlodarczyk

  • 10 Posts
  • 0 Reply Likes
Yes -- I  can confirm that the bug is not exhibited when the GPU is disabled. This can be seen without even restarting. If one disables the GPU and returns to the image, the bug is not exhibited. As soon as the GPU is re-enabled, the bug immediately returns.
Photo of Todd Shaner

Todd Shaner, Champion

  • 1072 Posts
  • 346 Reply Likes
I can confirm the behavior you are seeing and it's most likely due to using the 'Embedded & Sidecar' preview option on import. The filmstrip thumbnail will have a right and left arrow icon in the upper left-hand corner when using this option. The Library module uses the JPEG embedded in the raw file until you've applied an edit in the Develop module. In the case of Canon CR2 files it's a full-size image with the Picture Style you have set in-camera. The reason it appears desaturated in the Develop module with Adobe Standard default camera profile is because it has lower color saturation and contrast than the Canon picture style you have selected in-camera.

When switching to the Crop tool in the Develop module Adobe appears to revert to the embedded JPEG preview file to improve performance (or perhaps it's a bug?).  The 'Embedded & Sidecar' preview option is useful for first-pass culling of images in the Library module since it speeds up file import significantly. You have two options for correcting what you are seeing.

1) In the Import module 'File Handing' panel change 'Build Previews' to Standard or 1:1.

2) If you prefer the embedded JPEG picture style rendering change you LR default Develop settings to one of the 'Camera' named camera profiles such as Camera Standard. To do this select a 5D MKIV CR2 file and click on the 'Reset' button at the bottom of the Develop settings panels. Next select the desired camera profile, hold down the ALT key, and click on Reset again. All image files imported going forward will be assigned the new camera profile selection. This should reduce the "differences" you are seeing and get you closer to the Canon picture style rendering you have set in-camera.
Photo of wlodarczyk

wlodarczyk

  • 10 Posts
  • 0 Reply Likes
Thanks for the replies.

John -- Regarding disabling the GPU, I haven't tried this, but can give it a shot next time I encounter an image that exhibits the bug. Though it would still be a bug, even if the workaround eliminates the problem.

Todd -- I actually use the "Minimal" preview option when importing, so as to maximize import speed. And the problem occurs only for a smallish subset of all images. I understand the gist of what you're describing though and that does seem like the behavior -- rendering of the camera's JPG preview (I shoot raw with the camera style set to "Faithful") rather than raw with the Lightroom selected profile applied. That said, this is definitely a bug for a few reasons. It doesn't happen consistently, for starters. Just for a small minority of images, with no apparent rhyme or reason. And even if it did function consistently, if "Adobe Standard" is selected as the profile, that's what we should see on screen in the develop module. And only a small number of editing actions cause the selected profile to be applied (crop, white balance, profile). Changing things like contrast or saturation don't result in a render update with respect to the profile.
Photo of Todd Shaner

Todd Shaner, Champion

  • 1061 Posts
  • 341 Reply Likes
that said, this is definitely a bug for a few reasons. It doesn't happen consistently, for starters. Just for a small minority of images, with no apparent rhyme or reason.
It sounds like you may have two issues: 1) GPU Driver compatibility and 2) some of those image files may have been previously imported using 'Embedded & Sidecar' import module preview setting. That would explain varying behavior.
Photo of wlodarczyk

wlodarczyk

  • 10 Posts
  • 0 Reply Likes
I definitely have never imported images using "Embedded & Sidecar" so that's not the issue in my case. That's never been part of my workflow. And I saw the problem just today with images that were shot last night and imported for the first time, into a brand new catalog. Perhaps it is GPU related. It's a bug that should be addressed, just the same.
Photo of Todd Shaner

Todd Shaner, Champion

  • 1061 Posts
  • 341 Reply Likes
GPU issues are usually resolved by updating the graphics driver. Unfortunately graphics drivers on Mac systems can only be updated with an OS update and you have the latest version for Sierra (10.12.6). Are you seeing any significant performance issues with 'Use Graphics Processor' unchecked. If not then you have a good solution.