Lightroom Classic CC: Filmstrip no longer works (disable Direct2D)

  • 1
  • Problem
  • Updated 2 years ago
  • In Progress
  • (Edited)
The filmstrip no longer works, the first time it is used in the Library module: it is visible and you can select images, but it does not show the corresponding image on the second screen, nor on the first screen in the grid view. The only way to get a new image is to click on the grid itself or use the arrow keys.

I did reset my preferences, but that didn't help.

Strangely enough the problem is solved once you switch to the Develop module and back.

When trying to restart Lightroom it crashed upon exit using Ctrl Q. After starting it again the problem was not reproducible.
Photo of Ferdinand Veldmans

Ferdinand Veldmans

  • 2 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of Sunil Bhaskaran

Sunil Bhaskaran, Official Rep

  • 408 Posts
  • 146 Reply Likes
Thanks for reporting.
Could you please let us know your operating system? Please provide the details from Help > System Info.
If it happens again, please attach a screen shot.

Thanks,
Sunil
Photo of D H

D H

  • 10 Posts
  • 4 Reply Likes
Similar problem here with Win 8.1.

Select image in library module. Zoom to 1:1. Move to next image. Filmstrip still shows previous image. Move to next image with arrow symbol - filmstrip still shows first image, i.e doesn't advance. Changing to grid view or develop module and back again doesn't help - problem persists. Very soon, it becomes impossible to know which image you're working on. 

Similar problem - in library module at 1:1, click on next image in filmstrip instead of clicking on arrow symbol; image on main screen doesn't change - it's still the previous image.

Combined, these are major problems, making the library module impossible to work with - too easy to be doing stuff to the wrong image. I've rolled back to the previous version of LR until this problem is fixed.

David.
Photo of Carol

Carol

  • 2 Posts
  • 0 Reply Likes
In Develop mode, the filmstrip is a blank white space.  No images are showing.  Reverting to Library, the photo I've been working on is superimposed on the grid of photos, and truncated.  Only the lower half is visible.  Please get this fixed ASAP!
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1573 Posts
  • 514 Reply Likes
Official Response
Try this workaround to see if it works for you. If not, delete the config.lua file afterwards.

  1. Choose Edit > Preferences.
  2. In the Preferences dialog, go the Presets tab.
  3. In the Presets tab, click the Show Lightroom Presets Folder button. The root preset folder opens in the File Explorer. 
  4. In the File Explorer, navigate into the Lightroom folder.
  5. Go to the link https://adobe.ly/2hUHGYa and download the config.lua file. Copy the downloaded config.lua file into the Lightroom folder mentioned in the previous step.
  6. Relaunch Lightroom Classic CC.
The System Info dialog (Help > System Info) should display the config.lua flags entry as shown below:

Config.lua-Flags:
AgView.disableDirect2D = true
Photo of Carol

Carol

  • 2 Posts
  • 0 Reply Likes
It's OK - I fixed it.  I uninstalled Lightroom and reinstalled it, and it's OK now. Thanks.
Photo of Techie Kev

Techie Kev

  • 3 Posts
  • 0 Reply Likes
That's fixed it!  Thank you so much, Simon Chen