Lightroom Classic CC: Filmstrip no longer works (disable Direct2D)

  • 1
  • Problem
  • Updated 9 months ago
  • In Progress
  • (Edited)
The filmstrip no longer works, the first time it is used in the Library module: it is visible and you can select images, but it does not show the corresponding image on the second screen, nor on the first screen in the grid view. The only way to get a new image is to click on the grid itself or use the arrow keys.

I did reset my preferences, but that didn't help.

Strangely enough the problem is solved once you switch to the Develop module and back.

When trying to restart Lightroom it crashed upon exit using Ctrl Q. After starting it again the problem was not reproducible.
Photo of Ferdinand Veldmans

Ferdinand Veldmans

  • 2 Posts
  • 0 Reply Likes

Posted 9 months ago

  • 1
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1410 Posts
  • 434 Reply Likes
Official Response
Try this workaround to see if it works for you. If not, delete the config.lua file afterwards.

  1. Choose Edit > Preferences.
  2. In the Preferences dialog, go the Presets tab.
  3. In the Presets tab, click the Show Lightroom Presets Folder button. The root preset folder opens in the File Explorer. 
  4. In the File Explorer, navigate into the Lightroom folder.
  5. Go to the link https://adobe.ly/2hUHGYa and download the config.lua file. Copy the downloaded config.lua file into the Lightroom folder mentioned in the previous step.
  6. Relaunch Lightroom Classic CC.
The System Info dialog (Help > System Info) should display the config.lua flags entry as shown below:

Config.lua-Flags:
AgView.disableDirect2D = true