Lightroom Classic CC and Lightroom CC intentionally disable Intel GPU acceleration

  • 1
  • Idea
  • Updated 3 weeks ago

I had been using GPU acceleration on my Microsoft Surface Pro 3 successfully without problem for some time.  Suddenly in late 2017, after installing an Adobe upgrade, it no longer worked.  Every time I restarted Lightroom, it would be off.  This has continued now with Lightroom CC Classic and Lightroom CC.  The Surface Pro 3 has an Intel GPU and still receives updates via the Windows Update mechanism.

I can still enable it on startup of Lightroom CC Classic and it works correctly, but is again off the next time Lightroom CC Classic is relaunched.

In Lightroom CC, the option is grayed out and cannot be turned on.

At the time I assumed it was a bug that would be resolved.  Time passed with no resolution.

In the past couple of weeks, while doing searches to resolve a GPU problem on my desktop machine (since solved), I came across a forum posting by Simon Chen in which he wrote the following:


“The Intel OpenGL Windows driver is known to be problematic for Lightroom and Adobe Camera Raw. Therefore, Windows OpenGL on Intel GPUs are blacklisted by Lightroom and Adobe Camera Raw. On startup, the GPU acceleration is automatically turned off.  Intel GPUs are supported through the DirectX rendering path for Intel Skylake-and-later CPUs on Win 10.”


To me this is problematic - to turn off acceleration out of the blue when it had been working flawlessly for me.  Additionally, I do not recall that this was made public at the time (although perhaps I missed it) - that should never be the case.  Furthermore, it is unreasonable to expect the customer to replace their hardware under these circumstances.

Photoshop CC 2019 is using the Intel GPU without complaint.

I would like to request that a customer with an Intel GPU be given the option to turn on acceleration permanently for both Lightroom Classic CC and Lightroom CC with the understanding that we *might* experience problems.  I can live with that, particularly because I have not encountered any issues. 

GPU acceleration makes a noticeable difference to the performance of the Develop module in Lightroom on my Surface 3 Pro.

Thanks for your consideration,

Selby Shanly

Photo of Selby Shanly

Selby Shanly

  • 12 Posts
  • 4 Reply Likes

Posted 4 weeks ago

  • 1
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1539 Posts
  • 496 Reply Likes
Official Response
Ok. This is very helpful. Then try the following workaround steps to turn off blacklisting of unsupported GPU, if that works for you.
  1. Open Lightroom.
  2. Invoke Lightroom > Preferences... menu command
  3. When the Preferences dialog appears, select the Presets tab.
  4. Click on the button labeled “Show Lightroom Presets Folder...”
  5. Lightroom will reveal the root preset folder in the Finder/Explorer.
  6. Now go to https://adobe.ly/2Bh3QeW and download the config.lua file and copy it into the Lightroom preset folder that Finder/Explorer selected at step 5. 
  7. Relaunch Lr. 
If you follow the above steps correctly, you should see the following entry in Lightroom>Help>System Info...

Config.lua flags: 
Develop.DoNotBlacklistGPU = true