Lightroom Classic CC 7.3: Not saving new presets if they contain special characters

  • 5
  • Problem
  • Updated 7 months ago
  • Solved
  • (Edited)
[Update: If you try to include some special characters in the name of a preset being created or imported via Import Presets, LR 7.3.1 silently fails to create the preset, both on WIndows and Mac. See this post for details: 
https://feedback.photoshop.com/photoshop_family/topics/lightroom-classic-cc-7-3-bug-not-saving-new-p...
-- John R. Ellis]

If I save a new preset and I use a "|" symbol in the name it disappears. I only noticed this because I was making presets using the "|" as a separator. It worked fine before the update. It does not work now. For example, I have a preset I made called "SPLIT | Heavy Blue". The ones I made before the update work fine (thankfully). But now if I make a preset called "SPLIT | Heavy Green" it disappears. I immediately try again, same settings only changing the name to "SPLIT - Heavy Green" and it saves fine. Loads fine. Works fine.

Weird.

I'm not too upset. It's not a big deal. But it took me a couple hours to figure out what was going on and if it's not a big deal to patch it, then I thought someone should know. I use Windows 10.
Photo of Jeremy Ruble

Jeremy Ruble

  • 1 Post
  • 0 Reply Likes

Posted 8 months ago

  • 5
Photo of Scott Graudin

Scott Graudin

  • 3 Posts
  • 1 Reply Like
I can't save a preset for the tone cure or a new preset folder
Photo of sachin tripathi

sachin tripathi, Employee

  • 8 Posts
  • 1 Reply Like
Hi,

When you will save "SPLIT | Heavy Blue",  it will be saved as "SPLIT_Heavy_Blue"
Please check and let me know if you are able to find this. 

Regards,
Sachin T
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1499 Posts
  • 480 Reply Likes
This is a Windows specific issue. Lightroom treats a number of characters as illegal characters as part of the file name. Windows and Mac will have a different set of such illegal characters, which is specified as part of the Lightroom user preferences. Check out such Lightroom file name handling preferences by going to Lightroom>Edit>Preferences>File Handling>File Name Generation.

The actual file name of the presets do not matter. You could also try changing the "Replace illegal file name characters with" setting to Similar Characters, which would get closer at least visually to what you want.
Photo of Renato Richina

Renato Richina

  • 19 Posts
  • 9 Reply Likes
Still not fixed in 7.3.1: when you name a Preset with a | character, it doesn't save the preset. No error message display. This has worked in 7.2 without problems.
Photo of sachin tripathi

sachin tripathi, Employee

  • 7 Posts
  • 1 Reply Like
Thanks Renato!,
Please tell us are You trying to create or rename preset ? What exactly you are putting as string? 
Photo of John R. Ellis

John R. Ellis, Champion

  • 3895 Posts
  • 1035 Reply Likes
If you try to include some special characters in the name of a preset being created or imported via Import Presets, LR 7.3.1 silently fails to create the preset. 

I've tested all the characters on a standard US English keyboard.  Characters that fail on Windows 10:

* \ | : " < > / ?

Characters that fail on Macos 10.13.4:

:

Note that all of these characters are allowed in preset names in Camera Raw. 

To reproduce:

1. Do Develop New Preset.

2. In the Preset Name field, type "a", e.g. "a:".  

3. Click Create.  Observe that the preset doesn't appear in the presets panel.
(Edited)
Photo of Damian Watracz

Damian Watracz

  • 9 Posts
  • 4 Reply Likes
I have the same problem in the new version... there should be a fix, or at least any kind of message that the preset is not created! In older version it was possible to have ":" in the name of the preset. Why suddenly it's not possible anymore?
Photo of amanda del-grosso

amanda del-grosso

  • 5 Posts
  • 0 Reply Likes
Having the same issue as well, super annoying. Had to resort to Adobe forum to figure out the problem that I was having. (Older presets that I had from previous Lightroom software wouldn't import properly into Lightroom Classic CC. I received an error message while other presets didn't have any issues.) Upon discussion on the forum, users found that Lightroom Classic CC doesn't recognize illegal characters. This is pain, especially if you have multiple presets with illegal characters. However, some users found a work around for this, can be found here:https://forums.adobe.com/thread/2495695

Hopefully Adobe finally makes an update for this issue.
(Edited)