Lightroom Classic CC 7.3 (and 7.3.1): Hanging, requires force quit

  • 29
  • Problem
  • Updated 2 years ago
  • Solved
  • (Edited)

There are a few other discussions where this issue is being reported but i believe they have other issues clouding the discussion


Since the update to .3 and subsequently 3.1 Lightroom Classic CC hangs after being idle for a time (i can;t be specific on time as it seem to change). It does not happen necessarily on sleeping from the computer or in one module or another or when changing windows or minimizing or maximizing


It hangs and i am forced to "end task" through Task Manager


I am on a completely up to date (drivers and software and Windows) Win 10 Pro 64 system with 128gb RAM and plenty of horsepower and disk space (NVME and SSD)


My system has no problems with any other programs


please fix this
Photo of Aaron Steele

Aaron Steele

  • 12 Posts
  • 13 Reply Likes

Posted 2 years ago

  • 29
Photo of Chad Zoller

Chad Zoller

  • 2 Posts
  • 2 Reply Likes
I've had the same problem being described ever since the update.  Lightroom hangs and I have to use task manager to close it and then restart the program. It's almost always happening after I've left the program for a bit to respond to an email or do something else.  As soon as I pull lightroom back up it hangs.  I did just have it do it while in the midst of culling photos though.  Restarting the computer doesn't seem to change the likelihood of it recurring.  
Photo of Michael Burke

Michael Burke

  • 129 Posts
  • 13 Reply Likes
This reply was created from a merged topic originally titled Lightroom Classic 7.3.1 hangs when....

... I insert a memory card
... I start it when there's a memory card already inserted
... I select Import (after restarting it again)
... I select Develop.

Windows 10 - it pops in and out of task manager's Apps Processes list
Photo of Mattie André Orsini

Mattie André Orsini

  • 1 Post
  • 0 Reply Likes
My LR is crashing but also having trouble loading the cropping function. It freezes on the main display and does not go to the cropping screen. Also sometimes selecting images will freeze and not load the image, sometimes resulting in a crash.

Aus 1080ti 11GB ROG Strix
Intel i7 4970k
ROG Maximus VII Ranger
16GB Ram

Crash Report

<?xml version="1.0"?>
<!DOCTYPE AdobeCrashReport SYSTEM "AdobeCrashReporter.dtd">
<crashreport serviceVersion="1.6.3" clientVersion="1.6.3" applicationName="Adobe Lightroom Classic" applicationVersion="7.3.1" build="[1167660]">
<time year="2018" month="5" day="10" hour="14" minute="32" second="19"/>
<user guid="e04bb67c-9e18-4998-849f-b94eaedef8bc"/>
<system platform="Windows 10 Pro" osversion="10.0" osbuild="16299" applicationlanguage="en-us" userlanguage="en-US" oslanguage="en-AU" ram="16326" machine="Intel(R) Core(TM) i7-4790K CPU @ 4.00GHz" model="Intel64 Family 6 Model 60 Stepping 3" cpuCount="8" cpuType="8664" cpuFreq="3998 MHz"/>
<crash exception="EXCEPTION_ACCESS_VIOLATION" instruction="0x0000000015598797">
<backtrace crashedThread="0">
<thread index="0">
<stackStatement index="0" address="0x0000000015598797" symbolname="AgPNGProviderWin::GetProviderType"/>
<stackStatement index="1" address="0x000000001553E028" symbolname="AgPNGProviderWin::GetProviderType"/>
<stackStatement index="2" address="0x00000000155199C9" symbolname="AgPNGProviderWin::GetProviderType"/>
<stackStatement index="3" address="0x0000000015800ED5" symbolname="AgTemperatureTint_load"/>
<stackStatement index="4" address="0x000000001553C760" symbolname="AgPNGProviderWin::GetProviderType"/>
<stackStatement index="5" address="0x000000001553E9B9" symbolname="AgPNGProviderWin::GetProviderType"/>
<stackStatement index="6" address="0x000000001553EA6D" symbolname="AgPNGProviderWin::GetProviderType"/>
<stackStatement index="7" address="0x00007FFB0CE1B85D" symbolname="CallWindowProcW"/>
<stackStatement index="8" address="0x00007FFB0CE1B54C" symbolname="CallWindowProcW"/>
<stackStatement index="9" address="0x00007FFB0CE319C3" symbolname="GetTopWindow"/>
<stackStatement index="10" address="0x00007FFB0F953F94" symbolname="KiUserCallbackDispatcher"/>
<stackStatement index="11" address="0x00007FFB0CD614A4" symbolname="NtUserCallHwndLock"/>
<stackStatement index="12" address="0x00007FFAEFAA1CFC" symbolname="AgViewWinPanelHost::setLastPanelSize_L"/>
<stackStatement index="13" address="0x00007FFAFDEA35AC" symbolname="lua_getstack"/>
<stackStatement index="14" address="0x00007FFAFDEC21BA" symbolname="luaopen_table"/>
<stackStatement index="15" address="0x00007FFAFDED5CD2" symbolname="AgThrowProgramError"/>
<stackStatement index="16" address="0x00007FFAFDEA41FA" symbolname="lua_resume"/>
<stackStatement index="17" address="0x00007FFAFDE9794D" symbolname="luaopen_base"/>
<stackStatement index="18" address="0x00007FFAFDE97750" symbolname="luaopen_base"/>
<stackStatement index="19" address="0x00007FFAFDEA35AC" symbolname="lua_getstack"/>
<stackStatement index="20" address="0x00007FFAFDEC2157" symbolname="luaopen_table"/>
<stackStatement index="21" address="0x00007FFAFDEA4361" symbolname="lua_resume"/>
<stackStatement index="22" address="0x00007FFAFDED5CD2" symbolname="AgThrowProgramError"/>
<stackStatement index="23" address="0x00007FFAFDEA440E" symbolname="lua_resume"/>
<stackStatement index="24" address="0x00007FFAFDE93A10" symbolname="lua_pcall"/>
<stackStatement index="25" address="0x00007FFAF6A33BB5" symbolname="private_load_AgEventLoopUtils"/>
<stackStatement index="26" address="0x00007FFAF6A32FB0" symbolname="HandleASAPTasks"/>
<stackStatement index="27" address="0x000000014012555A" symbolname="GetAppInstance"/>
<stackStatement index="28" address="0x00007FFAED4E4E83" symbolname="unknown"/>
<stackStatement index="29" address="0x00007FFAED51AF97" symbolname="unknown"/>
<stackStatement index="30" address="0x000000014011F203" symbolname="AgViewWin32Window::`default constructor closure&#39;"/>
<stackStatement index="31" address="0x00007FFB0E051FE4" symbolname="BaseThreadInitThunk"/>
<stackStatement index="32" address="0x00007FFB0F91F061" symbolname="RtlUserThreadStart"/>
<register name="RAX" value="0x0000000000000000"/>
<register name="RBX" value="0x0000000000000002"/>
<register name="RCX" value="0x0000000041183010"/>
<register name="RDX" value="0x0000000101A89ED0"/>
<register name="RSI" value="0x0000000041183010"/>
<register name="RDI" value="0x00000000643CFD60"/>
<register name="RSP" value="0x000000000014EE50"/>
<register name="RBP" value="0x000000000014EED1"/>
<register name="RIP" value="0x0000000015598797"/>
<register name="EFL" value="0x0000000000010206"/>
<register name="LastExceptionToRip" value="0x0000000000000000"/>
<register name="LastExceptionFromRip" value="0x0000000000000000"/>

<binaryImage start="0x0000000140000000" end="0x00000001413F0000" path="adobe\Lightroom.exe"/>
<binaryImage start="0x00007FFB0F8B0000" end="0x00007FFB0FA90000" path="ntdll.dll"/>
<binaryImage start="0x00007FFB0E040000" end="0x00007FFB0E0EE000" path="kernel32.dll"/>
<binaryImage start="0x00007FFB0BFE0000" end="0x00007FFB0C246000" path="KERNELBASE.dll"/>
<binaryImage start="0x00007FFB0CE10000" end="0x00007FFB0CF9F000" path="user32.dll"/>
<binaryImage start="0x00007FFB0CD60000" end="0x00007FFB0CD80000" path="win32u.dll"/>
<binaryImage start="0x00007FFB02400000" end="0x00007FFB02442000" path="adobe\CRClient.dll"/>
<binaryImage start="0x00007FFB0F7B0000" end="0x00007FFB0F7D8000" path="gdi32.dll"/>
<binaryImage start="0x00007FFB0C9A0000" end="0x00007FFB0CB33000" path="gdi32full.dll"/>
<binaryImage start="0x00007FFB0CBC0000" end="0x00007FFB0CC5B000" path="msvcp_win.dll"/>
<binaryImage start="0x00007FFB0CC60000" end="0x00007FFB0CD56000" path="ucrtbase.dll"/>
<binaryImage start="0x00007FFAFB220000" end="0x00007FFAFB507000" path="adobe\amtlib.dll"/>
<binaryImage start="0x00007FFB0E240000" end="0x00007FFB0E2E1000" path="advapi32.dll"/>
<binaryImage start="0x00007FFB0E370000" end="0x00007FFB0F7A8000" path="shell32.dll"/>
<binaryImage start="0x00007FFB0D880000" end="0x00007FFB0D91D000" path="msvcrt.dll"/>
<binaryImage start="0x00007FFAEFA10000" end="0x00007FFAF00F5000" path="adobe\ui.dll"/>
<binaryImage start="0x00007FFB0CFA0000" end="0x00007FFB0CFFB000" path="sechost.dll"/>
<binaryImage start="0x00007FFB0D9A0000" end="0x00007FFB0DDEE000" path="setupapi.dll"/>
<binaryImage start="0x00007FFB0BEE0000" end="0x00007FFB0BF2A000" path="cfgmgr32.dll"/>
<binaryImage start="0x00007FFB0D060000" end="0x00007FFB0D17F000" path="rpcrt4.dll"/>
<binaryImage start="0x00007FFB0DDF0000" end="0x00007FFB0DE96000" path="SHCore.dll"/>
<binaryImage start="0x00007FFB0D000000" end="0x00007FFB0D051000" path="shlwapi.dll"/>
<binaryImage start="0x00007FFB0D1F0000" end="0x00007FFB0D2FA000" path="comdlg32.dll"/>
<binaryImage start="0x00007FFB0D300000" end="0x00007FFB0D608000" path="combase.dll"/>
<binaryImage start="0x00007FFB0E0F0000" end="0x00007FFB0E239000" path="ole32.dll"/>
<binaryImage start="0x00007FFB0D7A0000" end="0x00007FFB0D865000" path="oleaut32.dll"/>
<binaryImage start="0x00007FFB0CB40000" end="0x00007FFB0CBB2000" path="bcryptPrimitives.dll"/>
<binaryImage start="0x00007FFB0E300000" end="0x00007FFB0E36C000" path="ws2_32.dll"/>
<binaryImage start="0x00007FFB0C250000" end="0x00007FFB0C997000" path=""/>
<binaryImage start="0x00007FFB0BD10000" end="0x00007FFB0BEDE000" path="crypt32.dll"/>
<binaryImage start="0x00007FFB0BC20000" end="0x00007FFB0BC32000" path="msasn1.dll"/>
<binaryImage start="0x00007FFB0BC90000" end="0x00007FFB0BCA1000" path="kernel.appcore.dll"/>
<binaryImage start="0x00007FFAFDE90000" end="0x00007FFAFDF22000" path="adobe\AgKernel.dll"/>
<binaryImage start="0x00007FFB0BC40000" end="0x00007FFB0BC8C000" path="powrprof.dll"/>
<binaryImage start="0x00007FFAF6A10000" end="0x00007FFAF6B69000" path="adobe\substrate.dll"/>
<binaryImage start="0x00007FFB0BC00000" end="0x00007FFB0BC1B000" path="profapi.dll"/>
<binaryImage start="0x00007FFAED240000" end="0x00007FFAED813000" path="adobe\mfc140u.dll"/>
<binaryImage start="0x00007FFB07970000" end="0x00007FFB07B38000" path="dbghelp.dll"/>
<binaryImage start="0x00007FFB0B220000" end="0x00007FFB0B259000" path="IPHLPAPI.DLL"/>
<binaryImage start="0x00007FFB06660000" end="0x00007FFB0673E000" path="winhttp.dll"/>
<binaryImage start="0x00007FFB0CDE0000" end="0x00007FFB0CE0D000" path="imm32.dll"/>
<binaryImage start="0x00007FFB06B20000" end="0x00007FFB06CBC000" path="GdiPlus.dll"/>
<binaryImage start="0x00007FFAF60F0000" end="0x00007FFAF6400000" path="DWrite.dll"/>
<binaryImage start="0x00007FFB09420000" end="0x00007FFB099D8000" path="d2d1.dll"/>
<binaryImage start="0x00007FFB04570000" end="0x00007FFB0457C000" path="secur32.dll"/>
<binaryImage start="0x00007FFAF4A00000" end="0x00007FFAF4C69000" path="comctl32.dll"/>
<binaryImage start="0x00007FFAFBB50000" end="0x00007FFAFBBED000" path="adobe\msvcp140.dll"/>
<binaryImage start="0x00007FFB01210000" end="0x00007FFB013DD000" path="urlmon.dll"/>
<binaryImage start="0x00007FFB08030000" end="0x00007FFB08047000" path="adobe\VCRUNTIME140.dll"/>
<binaryImage start="0x00007FFB0D780000" end="0x00007FFB0D79D000" path="imagehlp.dll"/>
<binaryImage start="0x00007FFAFFE90000" end="0x00007FFB001C4000" path="wininet.dll"/>
<binaryImage start="0x00007FFB0ADF0000" end="0x00007FFB0AE3B000" path="authz.dll"/>
<binaryImage start="0x00007FFB088B0000" end="0x00007FFB088BA000" path="version.dll"/>
<binaryImage start="0x00007FFAF65B0000" end="0x00007FFAF677C000" path="adobe\wichitafoundation.dll"/>
<binaryImage start="0x00007FFAC0780000" end="0x00007FFAC4B19000" path="adobe\libcef.dll"/>
<binaryImage start="0x00007FFB01700000" end="0x00007FFB0174C000" path="pdh.dll"/>
<binaryImage start="0x00007FFB0A310000" end="0x00007FFB0A3A5000" path="uxtheme.dll"/>
<binaryImage start="0x00007FFB0D1E0000" end="0x00007FFB0D1E8000" path="psapi.dll"/>
<binaryImage start="0x00007FFB007C0000" end="0x00007FFB00A59000" path="iertutil.dll"/>
<binaryImage start="0x00007FFB0B670000" end="0x00007FFB0B67B000" path="CRYPTBASE.DLL"/>
<binaryImage start="0x0000000073910000" end="0x0000000073A81000" path="adobe\icuuc58.dll"/>
<binaryImage start="0x0000000073700000" end="0x0000000073902000" path="adobe\icuin58.dll"/>
<binaryImage start="0x00007FFB065B0000" end="0x00007FFB065C9000" path="usp10.dll"/>
<binaryImage start="0x00007FFAF6410000" end="0x00007FFAF65AD000" path="adobe\libeay32.dll"/>
<binaryImage start="0x00007FFB0BB30000" end="0x00007FFB0BB59000" path="userenv.dll"/>
<binaryImage start="0x00007FFB08240000" end="0x00007FFB0825A000" path="dhcpcsvc.dll"/>
<binaryImage start="0x00007FFAFC3F0000" end="0x00007FFAFC476000" path="winspool.drv"/>
<binaryImage start="0x00007FFB0D870000" end="0x00007FFB0D878000" path="nsi.dll"/>
<binaryImage start="0x00007FFB0BB00000" end="0x00007FFB0BB30000" path="sspicli.dll"/>
<binaryImage start="0x00007FFB06D70000" end="0x00007FFB06DDE000" path="oleacc.dll"/>
<binaryImage start="0x00007FFB08A90000" end="0x00007FFB08AA3000" path="wtsapi32.dll"/>
<binaryImage start="0x00007FFB039E0000" end="0x00007FFB03A03000" path="winmm.dll"/>
<binaryImage start="0x000000004AD00000" end="0x000000004C602000" path="adobe\icudt58.dll"/>
<binaryImage start="0x00007FFAF6C80000" end="0x00007FFAF6D6F000" path="adobe\msvcr120.dll"/>
<binaryImage start="0x00007FFB0B760000" end="0x00007FFB0B785000" path="bcrypt.dll"/>
<binaryImage start="0x00007FFB03760000" end="0x00007FFB0378A000" path="WINMMBASE.dll"/>
<binaryImage start="0x0000000075540000" end="0x0000000075559000" path="dnssd.dll"/>
<binaryImage start="0x00007FFB0A3E0000" end="0x00007FFB0A40A000" path="dwmapi.dll"/>
<binaryImage start="0x0000000180000000" end="0x0000000180256000" path="RTSSHooks64.dll"/>
<binaryImage start="0x00007FFB0F7E0000" end="0x00007FFB0F87E000" path="clbcatq.dll"/>
<binaryImage start="0x00007FFAF6960000" end="0x00007FFAF6A09000" path="tiptsf.dll"/>
<binaryImage start="0x00007FFB0D610000" end="0x00007FFB0D777000" path="msctf.dll"/>
<binaryImage start="0x00007FFAEAA40000" end="0x00007FFAEAA59000" path="cldapi.dll"/>
<binaryImage start="0x00007FFAFCE10000" end="0x00007FFAFCE1A000" path="fltLib.dll"/>
<binaryImage start="0x00007FFAFCEB0000" end="0x00007FFAFCEF4000" path="aepic.dll"/>
<binaryImage start="0x00007FFB0AE90000" end="0x00007FFB0AEC1000" path="ntmarta.dll"/>
<binaryImage start="0x00007FFB0B650000" end="0x00007FFB0B667000" path="cryptsp.dll"/>
<binaryImage start="0x00007FFB06E70000" end="0x00007FFB07021000" path="propsys.dll"/>
<binaryImage start="0x0000000010000000" end="0x00000000100CA000" path="adobe\WFCore.dll"/>
<binaryImage start="0x0000000004D40000" end="0x0000000004D80000" path="adobe\WFSQLite.dll"/>
<binaryImage start="0x0000000004D80000" end="0x0000000004D94000" path="adobe\WFWeb.dll"/>
<binaryImage start="0x0000000004DA0000" end="0x0000000004F3F000" path="adobe\WFOzClient.dll"/>
<binaryImage start="0x0000000004530000" end="0x0000000004537000" path="adobe\LightroomModels.dll"/>
<binaryImage start="0x00007FFAEF810000" end="0x00007FFAEFA0E000" path="adobe\IMSLib.dll"/>
<binaryImage start="0x00007FFB023E0000" end="0x00007FFB023F7000" path="adobe\xml_toolkit.dll"/>
<binaryImage start="0x00007FFAFAFF0000" end="0x00007FFAFB19B000" path="WindowsCodecs.dll"/>
<binaryImage start="0x00007FFAEECB0000" end="0x00007FFAEED47000" path="mscms.dll"/>
<binaryImage start="0x00007FFB06560000" end="0x00007FFB065A1000" path="icm32.dll"/>
<binaryImage start="0x000000000DBA0000" end="0x000000000E44A000" path="adobe\Import.lrmodule"/>
<binaryImage start="0x00007FFB05340000" end="0x00007FFB0534F000" path="wbemprox.dll"/>
<binaryImage start="0x00007FFB052B0000" end="0x00007FFB05331000" path="wbemcomn.dll"/>
<binaryImage start="0x00007FFB04C70000" end="0x00007FFB04C84000" path="wbemsvc.dll"/>
<binaryImage start="0x00007FFB04D80000" end="0x00007FFB04E70000" path="fastprox.dll"/>
<binaryImage start="0x00007FFAF5780000" end="0x00007FFAF583E000" path="adobe\updaternotifications.dll"/>
<binaryImage start="0x00007FFB07D00000" end="0x00007FFB07D17000" path="netapi32.dll"/>
<binaryImage start="0x00007FFB0B320000" end="0x00007FFB0B32E000" path="netutils.dll"/>
<binaryImage start="0x00007FFB07BD0000" end="0x00007FFB07BE7000" path="wkscli.dll"/>
<binaryImage start="0x00007FFB07790000" end="0x00007FFB07854000" path="taskschd.dll"/>
<binaryImage start="0x00007FFAFC280000" end="0x00007FFAFC3A3000" path="Windows.StateRepositoryPS.dll"/>
<binaryImage start="0x00007FFB0D920000" end="0x00007FFB0D991000" path="coml2.dll"/>
<binaryImage start="0x00007FFAE9060000" end="0x00007FFAE9088000" path="mssprxy.dll"/>
<binaryImage start="0x00007FFAE8A20000" end="0x00007FFAE8A30000" path="linkinfo.dll"/>
<binaryImage start="0x00007FFAEA200000" end="0x00007FFAEA2D7000" path="ntshrui.dll"/>
<binaryImage start="0x00007FFB049B0000" end="0x00007FFB049D6000" path="srvcli.dll"/>
<binaryImage start="0x00007FFB024D0000" end="0x00007FFB024E2000" path="cscapi.dll"/>
<binaryImage start="0x00000000151E0000" end="0x000000001936D000" path="adobe\CameraRaw.dll"/>
<binaryImage start="0x00007FFAFBB00000" end="0x00007FFAFBB45000" path="adobe\tbb.dll"/>
<binaryImage start="0x00007FFAF7110000" end="0x00007FFAF7154000" path="adobe\tbbmalloc.dll"/>
<binaryImage start="0x00007FFAEEE60000" end="0x00007FFAEEF7E000" path="opengl32.dll"/>
<binaryImage start="0x00007FFAF6C20000" end="0x00007FFAF6C71000" path="adobe\CONCRT140.dll"/>
<binaryImage start="0x00007FFAECD10000" end="0x00007FFAED23D000" path="adobe\libmmd.dll"/>
<binaryImage start="0x00007FFABF280000" end="0x00007FFAC077E000" path="adobe\svml_dispmd.dll"/>
<binaryImage start="0x00007FFAFDB40000" end="0x00007FFAFDB6C000" path="glu32.dll"/>
<binaryImage start="0x00007FFAD8A30000" end="0x00007FFAD8B92000" path="D3D12.dll"/>
<binaryImage start="0x00007FFB08660000" end="0x00007FFB086F0000" path="msvcp110_win.dll"/>
<binaryImage start="0x00007FFB0AA60000" end="0x00007FFB0AB0F000" path="dxgi.dll"/>
<binaryImage start="0x00007FFAF97D0000" end="0x00007FFAF98BB000" path="nvldumdx.dll"/>
<binaryImage start="0x00007FFB0BCB0000" end="0x00007FFB0BD08000" path="wintrust.dll"/>
<binaryImage start="0x00007FFB0B090000" end="0x00007FFB0B0C3000" path="rsaenh.dll"/>
<binaryImage start="0x00007FFACAAD0000" end="0x00007FFACCB6D000" path="nvwgf2umx.dll"/>
<binaryImage start="0x00007FFAD88C0000" end="0x00007FFAD8A0E000" path="dxilconv.dll"/>
<binaryImage start="0x00007FFAF68E0000" end="0x00007FFAF6953000" path="adobe\video_toolkit.dll"/>
<binaryImage start="0x000000000A970000" end="0x000000000A99B000" path="adobe\catalog_converters.dll"/>
<binaryImage start="0x00007FFAE8100000" end="0x00007FFAE814F000" path="dataexchange.dll"/>
<binaryImage start="0x00007FFB09AC0000" end="0x00007FFB09C02000" path="dcomp.dll"/>
<binaryImage start="0x00007FFB09130000" end="0x00007FFB09412000" path="d3d11.dll"/>
<binaryImage start="0x00007FFB0A460000" end="0x00007FFB0A5DB000" path="twinapi.appcore.dll"/>
<binaryImage start="0x00007FFB0A410000" end="0x00007FFB0A430000" path="rmclient.dll"/>
<binaryImage start="0x00007FFAF5730000" end="0x00007FFAF5774000" path="adobe\bridgetalk.dll"/>
<binaryImage start="0x00007FFAFB800000" end="0x00007FFAFB898000" path="TextInputFramework.dll"/>
<binaryImage start="0x00007FFAFB510000" end="0x00007FFAFB7FE000" path="CoreUIComponents.dll"/>
<binaryImage start="0x00007FFB099E0000" end="0x00007FFB09ABC000" path="CoreMessaging.dll"/>
<binaryImage start="0x00007FFB05FB0000" end="0x00007FFB060E6000" path="WinTypes.dll"/>
<binaryImage start="0x000000002EA40000" end="0x000000002EDD7000" path="adobe\MediaCoreIF.DLL"/>
<binaryImage start="0x000000002EDE0000" end="0x000000002EDF9000" path="adobe\boost_date_time.dll"/>
<binaryImage start="0x000000002EE10000" end="0x000000002EE32000" path="adobe\boost_threads.dll"/>
<binaryImage start="0x000000002EE40000" end="0x000000002EE4D000" path="adobe\boost_system.dll"/>
<binaryImage start="0x000000002EE70000" end="0x000000002EEFA000" path="adobe\dvatransport.dll"/>
<binaryImage start="0x000000002EF00000" end="0x000000002EF47000" path="adobe\dvamarshal.dll"/>
<binaryImage start="0x000000002EF50000" end="0x000000002F2D7000" path="adobe\dvacore.dll"/>
<binaryImage start="0x000000002F300000" end="0x000000002F515000" path="adobe\dynamiclink.dll"/>
<binaryImage start="0x000000002F520000" end="0x000000002F583000" path="adobe\dvamediatypes.dll"/>
<binaryImage start="0x000000002F5A0000" end="0x000000002F6BF000" path="adobe\dvaplayer.dll"/>
<binaryImage start="0x000000002F6D0000" end="0x000000002F825000" path="adobe\dvaaudiodevice.dll"/>
<binaryImage start="0x00007FFB0B490000" end="0x00007FFB0B4F6000" path="mswsock.dll"/>
<binaryImage start="0x00007FFB04600000" end="0x00007FFB0461B000" path="mpr.dll"/>
<binaryImage start="0x000000002F860000" end="0x000000002F88E000" path="adobe\dvaunittesting.dll"/>
<binaryImage start="0x000000002F8A0000" end="0x000000002F8C8000" path="adobe\boost_filesystem.dll"/>
<binaryImage start="0x00007FFAEF640000" end="0x00007FFAEF6ED000" path="adobe\cef_toolkit.dll"/>
<binaryImage start="0x00007FFB0BA10000" end="0x00007FFB0BA37000" path="devobj.dll"/>
<binaryImage start="0x00007FFAEDBF0000" end="0x00007FFAEDE24000" path="msxml3.dll"/>
<binaryImage start="0x00007FFB08260000" end="0x00007FFB08276000" path="dhcpcsvc6.DLL"/>
<binaryImage start="0x00007FFB01D00000" end="0x00007FFB01D96000" path="webio.dll"/>
<binaryImage start="0x00007FFB084C0000" end="0x00007FFB084CB000" path="winnsi.dll"/>
<binaryImage start="0x00007FFB0B260000" end="0x00007FFB0B316000" path="dnsapi.dll"/>
<binaryImage start="0x0000000075560000" end="0x0000000075586000" path="mdnsNSP.dll"/>
<binaryImage start="0x00007FFB06380000" end="0x00007FFB0638A000" path="rasadhlp.dll"/>
<binaryImage start="0x00007FFAFB9D0000" end="0x00007FFAFB9FD000" path="adobe\net_client.dll"/>
<binaryImage start="0x00007FFB076B0000" end="0x00007FFB07720000" path="FWPUCLNT.DLL"/>
<binaryImage start="0x00007FFB08AD0000" end="0x00007FFB08B70000" path="PortableDeviceApi.dll"/>
<binaryImage start="0x0000000030150000" end="0x000000003016E000" path="adobe\AppManagerLR.mox"/>
<binaryImage start="0x0000000073630000" end="0x00000000736F9000" path="msvcr80.dll"/>
<binaryImage start="0x0000000073520000" end="0x0000000073629000" path="msvcp80.dll"/>
<binaryImage start="0x00007FFAF96E0000" end="0x00007FFAF9709000" path="adobe\usbmanager.mox"/>
<binaryImage start="0x00007FFAF1890000" end="0x00007FFAF18C8000" path="adobe\wpdmanager.mox"/>
<binaryImage start="0x00007FFAE2500000" end="0x00007FFAE2515000" path="ondemandconnroutehelper.dll"/>
<binaryImage start="0x00007FFB0B0D0000" end="0x00007FFB0B0DA000" path="dpapi.dll"/>
<binaryImage start="0x00007FFAF0460000" end="0x00007FFAF0491000" path="adobe\Help.dll"/>
<binaryImage start="0x00007FFAF0390000" end="0x00007FFAF03BD000" path="adobe\Headlights.dll"/>
<binaryImage start="0x00007FFAEDB70000" end="0x00007FFAEDBED000" path="adobe\AdobePIP.dll"/>
<binaryImage start="0x00007FFADC1A0000" end="0x00007FFADC424000" path="adobe\LogSession.dll"/>
<binaryImage start="0x00007FFAFB200000" end="0x00007FFAFB212000" path="adobe\Vulcan.dll"/>
<binaryImage start="0x00007FFAEDAD0000" end="0x00007FFAEDB61000" path="adobe\VulcanMessage5.dll"/>
<binaryImage start="0x00007FFAF2A50000" end="0x00007FFAF2ABF000" path="msIso.dll"/>
<binaryImage start="0x00007FFAEDA30000" end="0x00007FFAEDACE000" path="adobe\ExtLib.dll"/>
<binaryImage start="0x00007FFAF0310000" end="0x00007FFAF0336000" path="adobe\DiscBurning.dll"/>
<binaryImage start="0x00007FFAF0150000" end="0x00007FFAF0190000" path="adobe\Email.dll"/>
<binaryImage start="0x00007FFAEA640000" end="0x00007FFAEA6ED000" path="adobe\image_analysis.dll"/>
<binaryImage start="0x00007FFAD7A30000" end="0x00007FFAD838D000" path="adobe\mona.dll"/>
<binaryImage start="0x00007FFADBBE0000" end="0x00007FFADBE4C000" path="adobe\opencv_core310.dll"/>
<binaryImage start="0x00007FFADB2C0000" end="0x00007FFADB49D000" path="adobe\opencv_calib3d310.dll"/>
<binaryImage start="0x00007FFADB870000" end="0x00007FFADBBD2000" path="adobe\opencv_imgproc310.dll"/>
<binaryImage start="0x00007FFAEA490000" end="0x00007FFAEA50B000" path="adobe\opencv_video310.dll"/>
<binaryImage start="0x00007FFADF000000" end="0x00007FFADF170000" path="adobe\libiomp5md.dll"/>
<binaryImage start="0x00007FFAE85C0000" end="0x00007FFAE8686000" path="adobe\opencv_features2d310.dll"/>
<binaryImage start="0x00007FFAEA010000" end="0x00007FFAEA097000" path="adobe\opencv_flann310.dll"/>
<binaryImage start="0x0000000033660000" end="0x00000000339F8000" path="adobe\coretech_toolkit.dll"/>
<binaryImage start="0x00007FFAEBC60000" end="0x00007FFAEBCBD000" path="adobe\BIBUtils.dll"/>
<binaryImage start="0x0000000073420000" end="0x0000000073516000" path="adobe\AXEDOMCore.dll"/>
<binaryImage start="0x00007FFAE0A80000" end="0x00007FFAE0B0F000" path="adobe\BIB.dll"/>
<binaryImage start="0x00007FFADAAD0000" end="0x00007FFADAC8D000" path="adobe\ACE.dll"/>
<binaryImage start="0x00007FFACA690000" end="0x00007FFACAACC000" path="adobe\CoolType.dll"/>
<binaryImage start="0x00007FFABEA50000" end="0x00007FFABF27F000" path="adobe\AGM.dll"/>
<binaryImage start="0x000000000B4E0000" end="0x000000000B63A000" path="adobe\WRServices.dll"/>
<binaryImage start="0x0000000075630000" end="0x0000000075702000" path="msvcr100.dll"/>
<binaryImage start="0x0000000075590000" end="0x0000000075628000" path="msvcp100.dll"/>
<binaryImage start="0x00007FFB0AFD0000" end="0x00007FFB0B04A000" path="schannel.dll"/>
<binaryImage start="0x00007FFAFFC40000" end="0x00007FFAFFC54000" path="mskeyprotect.dll"/>
<binaryImage start="0x00007FFB0B730000" end="0x00007FFB0B756000" path="ncrypt.dll"/>
<binaryImage start="0x00007FFB0B6F0000" end="0x00007FFB0B726000" path="ntasn1.dll"/>
<binaryImage start="0x00007FFB024A0000" end="0x00007FFB024CF000" path="cryptnet.dll"/>
<binaryImage start="0x00007FFB00510000" end="0x00007FFB00531000" path="ncryptsslp.dll"/>
<binaryImage start="0x00007FFAEA7F0000" end="0x00007FFAEA855000" path="ninput.dll"/>
<binaryImage start="0x00007FFAEC310000" end="0x00007FFAEC31E000" path="perfos.dll"/>
<binaryImage start="0x00007FFAEF7C0000" end="0x00007FFAEF807000" path="d3dx11_42.dll"/>
<binaryImage start="0x00007FFAD74E0000" end="0x00007FFAD775C000" path="d3dcompiler_42.dll"/>
<binaryImage start="0x00007FFAFF4A0000" end="0x00007FFAFFA94000" path="OneCoreUAPCommonProxyStub.dll"/>
<binaryImage start="0x00007FFAE4390000" end="0x00007FFAE46A4000" path="msftedit.dll"/>
<binaryImage start="0x00007FFAF7050000" end="0x00007FFAF70E5000" path="riched20.dll"/>
<binaryImage start="0x00007FFB080E0000" end="0x00007FFB08118000" path="msls31.dll"/>
<binaryImage start="0x00007FFAF5AB0000" end="0x00007FFAF5C37000" path="Windows.Globalization.dll"/>
<binaryImage start="0x00007FFAFBA00000" end="0x00007FFAFBA6A000" path="Bcp47Langs.dll"/>
<binaryImage start="0x00007FFAE4360000" end="0x00007FFAE4390000" path="globinputhost.dll"/>

Photo of Jeremy Tilford

Jeremy Tilford

  • 6 Posts
  • 5 Reply Likes
Still having problems with usability on my 2017 iMac.  Last night I made some prints, as it was late I just left the app in Print. Sat down this morning to edit some images. LR will not return to Library - just a constant beachball.  Activity Monitor shows LR using 7.3GB of memory and 106 per cent of CPU.  Only had Mail and Safari running on the machine. Eventually had to close the app with Command Q.
It is becoming unusable - luckily my liveliehood does not depend on having LR work. Reluctantly looking at alternatives and exiting Adobe.
Photo of Carmen Ray Anderson

Carmen Ray Anderson

  • 17 Posts
  • 5 Reply Likes
Hi there. What I did a couple of days ago, was uninstall LR 7.3 and revert back to LR 7.2 I am now able to work again! My livelihood does depend on having LR work, and it was impossible to use 7.3 with the volume of crashes and other issues. They are working on fixing the bugs in a new release but they can't give a release date. If I were you, I would hang in there and go back to LR 7.2 until this is sorted out.... my five cents worth.... good luck
Photo of pierorocca


  • 1 Post
  • 0 Reply Likes
This reply was created from a merged topic originally titled App hangs when attached memory device is unexpected and it's trying to auto-impor....

If I have my TomTom watch connected to my PC which has 3GB of memory or some other memory device that Lightroom cannot read or access, it hangs and freezes the application. My hypothesis is that it's trying to auto-import and there's a missing error handler so it just hangs.

Photo of Richard Polhill

Richard Polhill

  • 4 Posts
  • 0 Reply Likes
I can only add my voice as a me-too here. In fact that was the latest advice I've received from Adobe.

I am not auto-importing and the problem is unpredictably intermittent. Lightroom Classic just hangs (Not responding) when I attempt to open the Import module. Doesn't matter about USB drives or number of pictures to import because it appears to be the Import module that hangs on start, so it doesn't even get that far.

Only option is to kill Lightroom, which doesn't actually completely terminate on its own. I can see Lightroom.exe in Task Manager and if I try to terminate it I just get "access is denied". Process Hacker 2 is a little more explicit and says I'm trying to control a process that is being terminated. But it takes about 10 minutes usually to finally clear and I can then re-start Lightroom.

I think it is more reliable if I go and delete any Temporary Import Data related files from the Profile directory but that may be psychosomatic.

I do know that the process dies with a new, clean and empty profile. It can hang on first use and it can hang later with or without going to sleep inbetween.

Problem occurred with the switch to "Lightroom Classic" so seems to be related to one of the changes that were introduced at that time, and appeared to go away for a few weeks until this 7.3.1 update, although the intermittent and not entirely predictable nature of it could explain that.

FWIW, the system info follows:

Lightroom Classic version: 7.3.1 [ 1167660 ]
License: Creative Cloud
Language setting: en
Operating system: Windows 10 - Business Edition
Version: 10.0.16299
Application architecture: x64
System architecture: x64
Logical processor count: 4
Processor speed: 2.5 GHz
Built-in memory: 8087.6 MB
Real memory available to Lightroom: 8087.6 MB
Real memory used by Lightroom: 491.9 MB (6.0%)
Virtual memory used by Lightroom: 3918.5 MB
GDI objects count: 959
USER objects count: 4229
Process handles count: 2603
Memory cache size: 1.2MB
Internal Camera Raw revision: 933
Maximum thread count used by Camera Raw: 3
Camera Raw SIMD optimization: SSE2,AVX,AVX2
Camera Raw virtual memory: 1158MB / 4043MB (28%)
Camera Raw real memory: 1170MB / 8087MB (14%)
System DPI setting: 96 DPI
Desktop composition enabled: Yes
Displays: 1) 1280x1024, 2) 1280x1024
Input types: Multitouch: No, Integrated touch: No, Integrated pen: Yes, External touch: No, External pen: Yes, Keyboard: No

Graphics Processor Info: 
DirectX: Intel(R) HD Graphics 530 (

Application folder: C:\Program Files\Adobe\Adobe Lightroom Classic CC
Library Path: C:\Users\rpolhill\Pictures\Lightroom\Lightroom Catalog-2.lrcat
Settings Folder: C:\Users\rpolhill\AppData\Roaming\Adobe\Lightroom

Installed Plugins: 
1) AdobeStock
2) Flickr

Config.lua flags: None

Adapter #1: Vendor : 8086
Device : 191b
Subsystem : 6de1028
Revision : 6
Video Memory : 128
Adapter #2: Vendor : 1414
Device : 8c
Subsystem : 0
Revision : 0
Video Memory : 0
AudioDeviceIOBlockSize: 1024
AudioDeviceName: Speakers (USB Sound Device        )
AudioDeviceNumberOfChannels: 2
AudioDeviceSampleRate: 48000
Build: 10.0x7
Direct2DEnabled: false
GL_RENDERER: Intel(R) HD Graphics 530
GL_VERSION: 4.5.0 - Build
GPUDeviceEnabled: false
OGLEnabled: true
GL_EXTENSIONS: GL_3DFX_texture_compression_FXT1 GL_AMD_depth_clamp_separate GL_AMD_vertex_shader_layer GL_AMD_vertex_shader_viewport_index GL_ARB_ES2_compatibility GL_ARB_ES3_1_compatibility GL_ARB_ES3_compatibility GL_ARB_arrays_of_arrays GL_ARB_base_instance GL_ARB_blend_func_extended GL_ARB_buffer_storage GL_ARB_cl_event GL_ARB_clear_buffer_object GL_ARB_clear_texture GL_ARB_clip_control GL_ARB_color_buffer_float GL_ARB_compatibility GL_ARB_compressed_texture_pixel_storage GL_ARB_compute_shader GL_ARB_conditional_render_inverted GL_ARB_conservative_depth GL_ARB_copy_buffer GL_ARB_copy_image GL_ARB_cull_distance GL_ARB_debug_output GL_ARB_depth_buffer_float GL_ARB_depth_clamp GL_ARB_depth_texture GL_ARB_derivative_control GL_ARB_direct_state_access GL_ARB_draw_buffers GL_ARB_draw_buffers_blend GL_ARB_draw_elements_base_vertex GL_ARB_draw_indirect GL_ARB_draw_instanced GL_ARB_enhanced_layouts GL_ARB_explicit_attrib_location GL_ARB_explicit_uniform_location GL_ARB_fragment_coord_conventions GL_ARB_fragment_layer_viewport GL_ARB_fragment_program GL_ARB_fragment_program_shadow GL_ARB_fragment_shader GL_ARB_fragment_shader_interlock GL_ARB_framebuffer_no_attachments GL_ARB_framebuffer_object GL_ARB_framebuffer_sRGB GL_ARB_geometry_shader4 GL_ARB_get_program_binary GL_ARB_get_texture_sub_image GL_ARB_gpu_shader5 GL_ARB_gpu_shader_fp64 GL_ARB_half_float_pixel GL_ARB_half_float_vertex GL_ARB_indirect_parameters GL_ARB_instanced_arrays GL_ARB_internalformat_query GL_ARB_internalformat_query2 GL_ARB_invalidate_subdata GL_ARB_map_buffer_alignment GL_ARB_map_buffer_range GL_ARB_multi_bind GL_ARB_multi_draw_indirect GL_ARB_multisample GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_occlusion_query2 GL_ARB_pixel_buffer_object GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_polygon_offset_clamp GL_ARB_post_depth_coverage GL_ARB_program_interface_query GL_ARB_provoking_vertex GL_ARB_query_buffer_object GL_ARB_robust_buffer_access_behavior GL_ARB_robustness GL_ARB_robustness_isolation GL_ARB_sample_shading GL_ARB_sampler_objects GL_ARB_seamless_cube_map GL_ARB_seamless_cubemap_per_texture GL_ARB_separate_shader_objects GL_ARB_shader_atomic_counters GL_ARB_shader_bit_encoding GL_ARB_shader_draw_parameters GL_ARB_shader_image_load_store GL_ARB_shader_image_size GL_ARB_shader_objects GL_ARB_shader_precision GL_ARB_shader_stencil_export GL_ARB_shader_storage_buffer_object GL_ARB_shader_subroutine GL_ARB_shader_texture_image_samples GL_ARB_shading_language_100 GL_ARB_shading_language_420pack GL_ARB_shading_language_packing GL_ARB_shadow GL_ARB_stencil_texturing GL_ARB_sync GL_ARB_tessellation_shader GL_ARB_texture_barrier GL_ARB_texture_border_clamp GL_ARB_texture_buffer_object GL_ARB_texture_buffer_object_rgb32 GL_ARB_texture_buffer_range GL_ARB_texture_compression GL_ARB_texture_compression_bptc GL_ARB_texture_compression_rgtc GL_ARB_texture_cube_map GL_ARB_texture_cube_map_array GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_float GL_ARB_texture_gather GL_ARB_texture_mirror_clamp_to_edge GL_ARB_texture_mirrored_repeat GL_ARB_texture_multisample GL_ARB_texture_non_power_of_two GL_ARB_texture_query_levels GL_ARB_texture_query_lod GL_ARB_texture_rectangle GL_ARB_texture_rg GL_ARB_texture_rgb10_a2ui GL_ARB_texture_stencil8 GL_ARB_texture_storage GL_ARB_texture_storage_multisample GL_ARB_texture_swizzle GL_ARB_texture_view GL_ARB_timer_query GL_ARB_transform_feedback2 GL_ARB_transform_feedback3 GL_ARB_transform_feedback_instanced GL_ARB_transpose_matrix GL_ARB_uniform_buffer_object GL_ARB_vertex_array_bgra GL_ARB_vertex_array_object GL_ARB_vertex_attrib_64bit GL_ARB_vertex_attrib_binding GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_vertex_type_10f_11f_11f_rev GL_ARB_vertex_type_2_10_10_10_rev GL_ARB_viewport_array GL_ARB_window_pos GL_ATI_separate_stencil GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_clip_volume_hint GL_EXT_compiled_vertex_array GL_EXT_direct_state_access GL_EXT_draw_buffers2 GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXT_framebuffer_object GL_EXT_geometry_shader4 GL_EXT_gpu_program_parameters GL_EXT_gpu_shader4 GL_EXT_multi_draw_arrays GL_EXT_packed_depth_stencil GL_EXT_packed_float GL_EXT_packed_pixels GL_EXT_polygon_offset_clamp GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shader_framebuffer_fetch GL_EXT_shader_integer_mix GL_EXT_shadow_funcs GL_EXT_stencil_two_side GL_EXT_stencil_wrap GL_EXT_texture3D GL_EXT_texture_array GL_EXT_texture_compression_s3tc GL_EXT_texture_edge_clamp GL_EXT_texture_env_add GL_EXT_texture_env_combine GL_EXT_texture_filter_anisotropic GL_EXT_texture_integer GL_EXT_texture_lod_bias GL_EXT_texture_rectangle GL_EXT_texture_sRGB GL_EXT_texture_sRGB_decode GL_EXT_texture_shared_exponent GL_EXT_texture_snorm GL_EXT_texture_storage GL_EXT_texture_swizzle GL_EXT_timer_query GL_EXT_transform_feedback GL_IBM_texture_mirrored_repeat GL_INTEL_conservative_rasterization GL_INTEL_fragment_shader_ordering GL_INTEL_framebuffer_CMAA GL_INTEL_map_texture GL_INTEL_multi_rate_fragment_shader GL_INTEL_performance_query GL_KHR_blend_equation_advanced GL_KHR_blend_equation_advanced_coherent GL_KHR_context_flush_control GL_KHR_debug GL_KHR_texture_compression_astc_ldr GL_NV_blend_square GL_NV_conditional_render GL_NV_primitive_restart GL_NV_texgen_reflection GL_SGIS_generate_mipmap GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod GL_SUN_multi_draw_arrays GL_WIN_swap_hint WGL_EXT_swap_control
Photo of Renato Richina

Renato Richina

  • 15 Posts
  • 2 Reply Likes
Is there any statement from Adobe, if they could reproduce the problems an working on a fix and when we could expect it? Since weeks LR is crashing/freezing during work an i loss a lot of time. It's simply unacceptable to pay for this piece of software on a monthly base. Meanwhile, I am really thinking to use the time lost with LR's poor performance and crashes and beginning from scratch by switching to Capture One....
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 7535 Posts
  • 1725 Reply Likes
Greetings Renato,

At the top of this thread you can see that the post is marked as "In Progress" This means the developers have identified the issue and a fix is underway. There is no ETA at this point. 
Photo of Richard Sweeney

Richard Sweeney

  • 1 Post
  • 1 Reply Like
And yet I am still paying for a program I can not use ... 
Photo of Jeremiah Frederick

Jeremiah Frederick

  • 35 Posts
  • 4 Reply Likes
yeah, how about i give adobe no ETA for paying my subscription fee?... i'll bet that wouldn't be acceptable on their end...
Photo of Jim Garrison

Jim Garrison

  • 18 Posts
  • 1 Reply Like
This reply was created from a merged topic originally titled Lightroom hangs for long periods on import after latest update to 7.3.1.

After the most recent update to 7.3.1 the import process is painfully slow, as in taking tens of minutes to populate the import dialog with images.  This used to take a minute or two for a card containing several hundred raw images.  Now, it takes 10-20 minutes for the same card, and the LR UI is unresponsive, as in going gray if you click on it.  The "Cancel" button is still responsive but the process of populating the images takes forever.

There has been no change to my hardware configuration.

Asus Z97, Intel i7-4790K, 32GB memory,

This is completely unacceptable.
Photo of Jim Garrison

Jim Garrison

  • 18 Posts
  • 1 Reply Like
My issue got merged into this thread but it appears it should not have been merged as my symptoms were different.

In my case, it appears I might have a hardware problem.  After several hours of troubleshooting, including a couple of "soft" reboots, I decided to do a complete "hard" reboot, i.e. complete power off and restart.  This fixed the issue, so I suspect the USB hardware got itself into a strange state, possibly locked to USB 1 transfer speeds.

If the problem recurs I'll add to this thread with more detailed symptoms.
Photo of David Brown

David Brown

  • 8 Posts
  • 8 Reply Likes
Has any of you tried calling tech support?  Thinking of doing that.  I have to say it's getting a bit ridiculous at this point.
Photo of Dave Griffin

Dave Griffin

  • 1 Post
  • 2 Reply Likes
I had started a thread with the same locking up while lightroom is idle, and sometimes while importing after going to 7.3, I went back to 7.2 and all was fine, then I tried 7.3.1 and it seemed better, but still have the locking while idle, and when importing!  
Photo of Scott Kantrowitz

Scott Kantrowitz

  • 1 Post
  • 0 Reply Likes
This reply was created from a merged topic originally titled Lightroom hangs; Shadow process in Windows Taskbar.

Lightroom hangs at seemingly random times; Shadow process in Windows Taskbar. Same problem on last two PCs configured similarly, and all Lightroom versions over last two years. Happens regardless of module being used.
Dell 64-bit Windows 10 PC with Samsung 1 TB SSD for system volume (including Adobe installs and catalog); single Western Digital Green or Gold 4, 5, and 6 TB drives for RAW files (new drives for capacity over time).
I assume the big drive is going to sleep, but there's no clear sign of that and changes to Intel Drive mgmt to prevent condition make no difference; Power profile for PC is High Performance, never Sleep/ never Hibernate. Upon Lightroom restart, folder that was being viewed during last start is again selected, not folder being at time of crash/hang.
Photo of Jim Garrison

Jim Garrison

  • 18 Posts
  • 1 Reply Like
Same issue here with 7.3.1

Based on what I see in ProcessExplorer, the thread named

    Lightroom.exe!AgViewWin32Window::"default constructor closure"+0xd2d48
Is stuck in an infinite loop using 100% of 1 CPU.  The stack looks like this:

Lightroom.exe!AgViewWin32Window::`default constructor closure'+0xd2cf3
Photo of boris melinand

boris melinand

  • 1 Post
  • 0 Reply Likes
Hello everybody,
just to testify that it is the same for me since 7.3.1. On my W10, core i7 with 24 Gb Ram Laptop Lightroom is freezing a lot. When idle (several times a day) and sometimes when importing (the task seem frozen the import sometime continue in the background but in the end I still get to kill the Lightroom task to get the control back).  In fact my Lightroom is crashing 2-3 times a day wich is...a lot.

I just reached the Adobe customer service about the problem. After a chat with screen share the tech give me this link encouaraging me to follow the steps.  Ensuring that my Lr wont crash no more. He did not answer to my questions about a global problem with 7.3.1..
Photo of Susana Milnes

Susana Milnes

  • 1 Post
  • 1 Reply Like
Mine crashing whenever leaving lightroom to work on other windows  for an undetermined amount of time (such as the browser or Office). Real pain, as since xmas it takes forever to restart.
Photo of JC


  • 130 Posts
  • 35 Reply Likes
I am writing to add weight to the issues the Adobe User Community is seeing since the most recent updates of Lightroom Classic CC (7.3 & 7.3.1). I have experienced the following:

1. Hung LR application after importing photos from CF, SD, and USB memories. I have found if I quit LR after an import, eject the memory device, and then restart, LR does not hang. This might be a workaround for some users.

2. The LR application becomes sluggish with extended use. Yesterday I imported 130 photos and developing twenty of them over 3 or 4 hours. LR became slower and slower until it was unuseable. I thought a restart would resolve the problem but it did not seem to. That batch of photos in the catalog process much more slowly than others that were processed in the catalog with earlier versions of LR.

3. There are many more issues reported in this forum including outright crashes since the 7.3/7.3.1 updates with many of them verified by Adobe spokespersons.

I am a serious photo hobbyist and luckily do not depend on Adobe LR for my livelihood. I can only imagine how impactful these issues are for those who do. I have also been a booster for Adobe LR Classic CC and Photoshop CC for a number of years.

During that time I've appreciated and been impressed with the continuous improvements and feature updates to the products. Unfortunately, I've also noticed a decline in quality control with regards to updates. The issues with the 7.1/7.3.1 updates may have set a new low. Maybe it's time for Adobe to consider reducing  the frequency of updates to allow more time for better quality control or put more resources into the QC process.
Photo of Jeremiah Frederick

Jeremiah Frederick

  • 35 Posts
  • 4 Reply Likes
i don't think they really care about classic too much anymore.  just my opinion
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 5645 Posts
  • 2255 Reply Likes
> i don't think they really care about classic too much anymore

It's not that they don't care, but huge companies have so many different departments involved in releasing an update, it's like turning the Titanic. They're not as nimble as we'd like them to be.
Photo of Jeremiah Frederick

Jeremiah Frederick

  • 35 Posts
  • 4 Reply Likes
I disagree. I think they put their focus on mobile. I’ve used classic since the beginning and I remember when it was great. Bugs got squashed very quickly. They were very nimble. Now they are busy with other things: subscription, clouds, mobile, etc.... Short hand: they don’t really care as much about classic. And the fact that they are huge is no excuse. In fact, just the opposite. I stand by my statement.
Photo of JC


  • 130 Posts
  • 35 Reply Likes
I think we may be a bit guilty of missing the forest for the tree. The many new and interesting features added to LR CC since the introduction of LR Mobile indicates to me that there is still great corporate interest in LR CC. Granted the bugs have been distracting and are concerning. It's like finding a fly buried in your chocolate fudge sundae after you've taken a few bites. It can really detract from the original intent.

I bet LR Mobile has had its share of bugs since its introduction too; I don't know for sure since I'm not a user of that tool. In any event,software of this complexity is complicated stuff. Hopefully Adobe will reflect on all the negative feedback and invest in or reconsider the way they are evaluating new releases going forward to reduce the glitches we seen of late. If not, their net promoter score will surely take a hit in spite of all the new product and update investments.
Photo of Jeremiah Frederick

Jeremiah Frederick

  • 35 Posts
  • 4 Reply Likes
I'm not talking about forests, trees, or chocolate fudge sundaes.  I'm talking about a computer program that used to work well but now has a bunch of new feature that are fine except that they are all unusable because the basic stability and usability of the program has been compromised--hard to use those "great" new features with the program just hangs, hangs, hangs, and hangs again when trying to do basic tasks--it simply does not work as it should.  Yes, mobile has had (and still has) plenty of bugs.  That certainly doesn't help my feelings about anything as I use it too.  Everyone from Adobe (including their shills) can go on and on about all the new stuff.  They have to to keep selling the product.  They sure don't mention how jacked up it all is.  And, again, I've used Classic from the very very beginning.  I remember when it was a great usable program.  
Photo of Rory Hill

Rory Hill

  • 248 Posts
  • 40 Reply Likes
I see this is "in progress".  Does this mean Adobe has been able to replicate the issue?  I sure hope this doesn't fall into the black hole of unresolved issues.
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 7535 Posts
  • 1725 Reply Likes
In progress means we've filed a bug on the issue and the team is working on it. We plan to have a fix in the next update. 
Photo of Renato Richina

Renato Richina

  • 15 Posts
  • 2 Reply Likes
Just wondering, how many weeks we still have to wait for the bugfix release...
Photo of Rory Hill

Rory Hill

  • 248 Posts
  • 40 Reply Likes
Thanks Rikk.  I appreciate the update.
Photo of Geoff Faulkner

Geoff Faulkner

  • 39 Posts
  • 10 Reply Likes
Imported several hundreds of photos from recent graduations, parties, and weddings. Each batch takes multiple attempts to import as Lightroom locks up with a high CPU condition and never recovers. I let it sit all night long only to come back in the morning to the exact same place in the import.

I use this tool personally, and professionally. These lock ups are preventing me from delivering my work in a timely manner. PLEASE make this a priority to correct. 

Can I downgrade back to a version prior? Is this a possibility with cloud-delivered software?
Photo of JC


  • 130 Posts
  • 35 Reply Likes

Yes you can roll back any Creative Cloud application. See this Adobe "How To" app note at:

LR Version 7.2 seemed pretty stable. Hope this helps.
Photo of Jeremiah Frederick

Jeremiah Frederick

  • 35 Posts
  • 4 Reply Likes
same here for me.. hang hang hang.. what am i paying for?....
Photo of Jeremiah Frederick

Jeremiah Frederick

  • 35 Posts
  • 4 Reply Likes
Interesting. I got an email stating as follows: We have a fix for the issue you mentioned.

Would you be interested in a part of our pre-release program?
I would be able to share a build with you in which you can test and let us know if you see this issue

My response:

How much do I get paid to be a beta tester for Adobe? How much of a discount on my subscription fee do I receive for a dysfunctional product? If I treated my customers as such, they wouldn’t be my customers very long.

And when is the ETA for the official release to fix this long-ongoing, very serious problem? Lemme guess, no ETA. How about I give Adobe no ETA for when I’m going to pay my subscription fee? I’ll bet that wouldn’t work on their end.

I am requesting from you (an Adobe agent) a significant discount on my subscription fee until this problem is officially resolved.
Photo of Jeremiah Frederick

Jeremiah Frederick

  • 35 Posts
  • 4 Reply Likes
Hey JC.  I used to work for a company that I cannot name and I can assure you that they do this.  They also have employees that write fake reviews on all sorts of website--under the guise of being a "customer."  It's happens.  And it happens here.
Photo of Jeremiah Frederick

Jeremiah Frederick

  • 35 Posts
  • 4 Reply Likes
Oh, and.... You're Welcome!!!!
Photo of JC


  • 130 Posts
  • 35 Reply Likes
I realise some companies do these sort of things, I'm not naive. But I really doubt reputable companies would allow their representatives to "attack" customers on their forums, it's simply not good business. Losing a poorly handled customer is costly. And the word-of-mouth thereafter has a lasting knock-on impact.
Photo of Jeremiah Frederick

Jeremiah Frederick

  • 35 Posts
  • 4 Reply Likes
"Attack" is too strong.  What they do is when someone raises an issue where the product in question is faulty in some way, they have people get on the forums and argue ad nauseam to try to deflect attention--calling it user error or a problem with your particular computer, etc.  You can notice when someone wants to argue over something that should *clearly* be fixed.  My old boss would have us do this and it was a very big and very very reputable company.  The fact is they all do it.  Especially the largest and most reputable.  I know it for a fact because I have been asked to do it.
Photo of Jeremiah Frederick

Jeremiah Frederick

  • 35 Posts
  • 4 Reply Likes
And remember, these people (the shills) aren't known to be agents of the company so it doesn't reflect on the company.  And it's often in forums where they go on and on about how the company "doesn't even monitor" the forum (of course, they do)... they want that separation so the company is not impacted or responsible.
Photo of Aaron Steele

Aaron Steele

  • 12 Posts
  • 13 Reply Likes
I am upset we havent seen any movement on this too, but them offering you to be a part of the solutio nadn you denying them seems vindictive and unhelpful, and i dont see why you woudlnt want to help remedy the situation.

And let's all be clear here, it isnt like the program doesn't work, only the updates have caused the issue. You can roll back (like i did to 7.2) and everything is fine, i just dont have the new features working, and so what?

We arent paying for NOTHING we are still getting a very robust software that has some bugs in the latest updates, which we can circumvent EASILY by their own software. I dont see how anyone's workflow could have been hampered so much by these bugs in the newest updates, seeing as they didnt offer MUCH that wasnt working well in 7.2

Should we be seeing more action IMO, yes. Should we get more communication, yes.  Should the have rolled out an update with bugs, probably not if they werent going to answer problems quickly.  But that doesn't mean we have to be spoiled brats about not having functionality, and not getting our money out of our subscription fees.  They need to be more careful, yes.

It is annoying, it is kinda disrespectful, but not to the level that we should be vindictive to the point of making the problem last LONGER by not helping out of spite for not getting your money's worth on a program which you can still do 99%+ of what you could do before the update just by rolling back to 7.2 until this gets sorted out.

I was one of the 1st people to post about this issue after the update, and i was ATTACKED by other members of the forum that this wasnt even an issue at all, and it was isolated to me.  And that by even asking about the problem and demanding they do something about it was ridiculous.

Be patient, roll back, and keep an eye on the threads about updates to the situation and fixes. If they ask you for help, help them, it will only help yourself and the community.
Photo of Jeremiah Frederick

Jeremiah Frederick

  • 35 Posts
  • 4 Reply Likes
No, not you, Aaron--you're not shill.  I'm talking about those who, as you said, "attacked" *you* when you simply raised the topic.  That is typical shill behavior.
Photo of Jeremiah Frederick

Jeremiah Frederick

  • 35 Posts
  • 4 Reply Likes
Like I said before Aaron, you can see this behavior in many forums, not just Adobe.  Watch for it.  You can aways notice this when anyone raises an issue and they come out of the woodworks and try to deflect attention from the real issue.
Photo of Jeremiah Frederick

Jeremiah Frederick

  • 35 Posts
  • 4 Reply Likes
It's like Han Solo said: "Must have hit pretty close to the mark to get her all riled up like that, huh, kid?"  Haha.
Photo of Jeremiah Frederick

Jeremiah Frederick

  • 35 Posts
  • 4 Reply Likes
And will clarify:

I used to work for a company that I cannot name and I can assure you that they do this.  They also have employees that write fake reviews on all sorts of website--under the guise of being a "customer."  It happens.  And it happens here. 

But "Attack" is too strong.  What they do is when someone raises an issue where the product in question is faulty in some way, they have people get on the forums and argue ad nauseam to try to deflect attention--calling it user error or a problem with your particular computer, etc.  You can notice when someone wants to argue over a product problem that should *clearly* be fixed.  My old boss would have us do this and it was a very big and very very reputable company.  The fact is they all do it.  Especially the largest and most reputable.  I know it for a fact because I have been asked to do it.

And remember, these people (the shills) aren't known publicly to be agents of the company so it doesn't reflect on the company.  And it's often in forums where they go on and on about how the company "doesn't even monitor" the forum (of course, they do)... they want that separation so the company is not impacted or responsible.

Anyway weren't we talking about how Lightroom hangs, hangs, hangs... and then hangs some more?... haha.
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 5645 Posts
  • 2255 Reply Likes
Aaron, I'm trying to find this attack you mention, because personal attacks are not acceptable here, but all I can see is people trying to get extra information to figure out how to reproduce the problem, so it could be tracked down and fixed. Perhaps you could help me understand what made you feel attacked?
Photo of Giovanni Malausa

Giovanni Malausa

  • 3 Posts
  • 2 Reply Likes
Guys (Adobe), just to remind you... we are *paying* for a service that does not work.
We've been having this problem for more than one month. A lot of people seem to have it!
Please, just fix it quickly. Do not forget about it.
I'm already really considering ending my Adobe CC subscription.
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 5645 Posts
  • 2255 Reply Likes
Oh believe me, if my refusing a complimentary sub would speed up the solution to this bug by even a few minutes, I'd do so in a heartbeat. It's a lot more painful listening to frustrated Lightroom users understandably complaining about a bug for weeks than it is to part with a little cash. 

"Everyone has an incentive" isn't always true though. I was spending hours on the forums as a paying customer, long before I started writing books, and long before Adobe gave me a badge. The same is true of all ACP's. That sub is just a thank you for work we're already doing for free, and I'd still be doing it without the comp sub (but I'd be stupid to refuse it, right?!). 

It's true that I don't get too het up about the bugs present in all of the software I use, paid or free. Incredibly frustrating though some of these bugs are, I focus on what I can control, like helping people find workarounds, getting the right information to the people who can fix it, and since I have a little more freedom of speech than staff, relaying information back too. I'd give myself a coronary otherwise.

Adobe doesn't pre-announce release dates, and anyone who knows anything is pretty limited in what they can say. But what I can do, rather than leaving everyone on this thread talking to themselves and feeling ignored, is gather publicly available information to confirm that they've reproduced the problem, found a solution and the fix is not too far off from release now.
Photo of Jeremiah Frederick

Jeremiah Frederick

  • 35 Posts
  • 4 Reply Likes
That is all well and good.  My point is that you get the product for free--nothing at all wrong with that.  But the fact is, I'd feel a lot different about said product too (and all of it's ongoing problems), if I got it for free.  That's all.  And let us not forget, we're not talking about a minor bug or something small.  We are talking about the extensive and ongoing problem of Lightroom Classic CC completely hanging and requiring a force quit.  And this going on for quite a long time now.  But, yeah, if it was something that I didn't pay for, it wouldn't be as much of a concern for me.
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 5645 Posts
  • 2255 Reply Likes
I think we'll have to agree we have very different views of the world Jeremiah. The cost of a subscription is pennies compared to the number of man hours I spend tracking bugs like these, so I'm as keen for these issues to be fixed as you are. 
Photo of Jeremiah Frederick

Jeremiah Frederick

  • 35 Posts
  • 4 Reply Likes
i'm sure you are keen on it as well.  no doubt.  but i don't think we have different views, at all.  you get a lot more from your relationship with adobe than just the free subscription.  your whole brand is based on your tie to lightroom.  that is your incentive and your relationship with adobe is a linchpin of your brand.  hey, victoria, great for you.  that is awesome and I'm genuinely happy for you but it's important that we know what you incentive for is and why you are always sining the praises of Adobe and going to bat for them.  there is a reason other than just wanting to help people and be a member of this forum community.  
Photo of Jeremiah Frederick

Jeremiah Frederick

  • 35 Posts
  • 4 Reply Likes
and let's not get sidetracked.  Lightroom Classic CC is totally screwed up in it's current build.  it has been for a very long time now.  it would seem that adobe doe not give much priority to correcting it's problems.  it's almost as if they've decided to sunset the program.
Photo of Kerim Suner

Kerim Suner

  • 4 Posts
  • 4 Reply Likes
Adobe (if you are listening) please release this fix ASAP for two reasons:
1) To end our unbearable frustration because of this bug!
2) To bring an end to pointless conversations in this thread!
Photo of Jeremiah Frederick

Jeremiah Frederick

  • 35 Posts
  • 4 Reply Likes
Hear, hear!
Photo of Richard Valenti

Richard Valenti

  • 2 Posts
  • 0 Reply Likes
Totally agree! We need a fix. 
Photo of Richard Valenti

Richard Valenti

  • 2 Posts
  • 0 Reply Likes
Like the rest that have spoken on this tread, my PC encounters problems with LR 7.3.1 hanging up and becoming "Not Responsive". I have rolled back to LR 7.2 which performs fine. I have tried updating my drivers, GPU on / off, increased RAM, etc. Nothing seems to help the LR 7.3.1 hang up problem. Clearly with 7.2 performing perfectly but 7.3.1 crashing, it appears to be a LR version specific software problem. 
Photo of rogéz


  • 10 Posts
  • 4 Reply Likes
The same problem here, crashes about every 10min. Very hard to do a good job like this. I noticed there is a link with inserting/ejecting usb drivers. Every time I connect or disconnect my phone, Lightroom crashes. The same with thumb drives.

Adobe developers can you tell me which module (dll file) is used for importing photo's from usb drives? So I can just delete that file, I never use the import dialogue any ways. I remember some years ago the same bug was there, and deleting that file worked for me as a solution. I just cannot remember which file it was. Please tell me so I can do my job instead of waiting ages for Adobe to come with a solution.
Photo of Andrew Merritt

Andrew Merritt

  • 9 Posts
  • 5 Reply Likes
For now, I would say the best option is to roll back to version 7.2 and wait for a fix to be released.