Lightroom Classic CC 7.2 | High Sierra | Mac Pro 6,1 - Suddenly unable to import. Extremely Slow performance. Unusable.

  • 1
  • Problem
  • Updated 3 months ago
Hi Adobe Team,

Been using Adobe products for almost 20 years now and don't normally have issues but am at a bit of a loss here.

Recently (last week or so), after either High Sierra or LR update, my LR has become unusable.

Importing fails. It's takes an extremely long time for the image selection window to even preview images. As well as the import process itself freezing the app. No photos/file actually import.

Library view renders images with artifacts and takes an extremely long time to load new previews.

Develop tab takes an extremely long time to autosync adjustments and render. It took 5 hours to autosync 52 images adjustments. 

Exporting/Publishing images freezes or takes and extremely long time as well. 


Steps taken to try and fix:
Reset Preferences
Disabled GPU
Disabled all background processes such as Sync/Face/Address
Added Prefer OpenGL config file
Reinstalled Lightroom
Reverted to previous version (7.1)
Repaired disk permissions
Made a new catalog

Unfortunately none seem to work. Would really really love some help resolving this issue. Thank you!! :)

System Info:

Lightroom Classic version: 7.2 [ 1156743 ]
License: Creative Cloud
Language setting: en-US
Operating system: Mac OS 10
Version: 10.13.3 [17D102]
Application architecture: x64
Logical processor count: 16
Processor speed: 3.0 GHz
Built-in memory: 65,536.0 MB
Real memory available to Lightroom: 65,536.0 MB
Real memory used by Lightroom: 545.2 MB (0.8%)
Virtual memory used by Lightroom: 5,632.2 MB
Memory cache size: 0.0MB
Internal Camera Raw revision: 894
Maximum thread count used by Camera Raw: 5
Camera Raw SIMD optimization: SSE2,AVX
Camera Raw virtual memory: 0MB / 32767MB (0%)
Camera Raw real memory: 0MB / 65536MB (0%)
Displays: 1) 2560x1440

Graphics Processor Info: 
Metal: AMD Radeon HD - FirePro D700



Application folder: /Applications/Adobe Lightroom Classic CC
Library Path: /Volumes/G-SPEED Shuttle XL TB3/Lightroom Catalog/2015/2015-2.lrcat
Settings Folder: /Users/cameronrad/Library/Application Support/Adobe/Lightroom

Installed Plugins: 
1) AdobeStock
2) Aperture/iPhoto Importer Plug-in
3) Canon Tether Plugin
4) Facebook
5) Flickr
6) Nikon Tether Plugin
7) Pixieset

Config.lua flags: None

AudioDeviceIOBlockSize: 512
AudioDeviceName: USB AUDIO    DAC
AudioDeviceNumberOfChannels: 2
AudioDeviceSampleRate: 48000
Build: Uninitialized
CoreImage: true
GL_ACCUM_ALPHA_BITS: 0
GL_ACCUM_BLUE_BITS: 0
GL_ACCUM_GREEN_BITS: 0
GL_ACCUM_RED_BITS: 0
GL_ALPHA_BITS: 8
GL_BLUE_BITS: 8
GL_DEPTH_BITS: 24
GL_GREEN_BITS: 8
GL_MAX_3D_TEXTURE_SIZE: 16384
GL_MAX_TEXTURE_SIZE: 16384
GL_MAX_TEXTURE_UNITS: 8
GL_MAX_VIEWPORT_DIMS: 16384,16384
GL_RED_BITS: 8
GL_RENDERER: AMD Radeon HD - FirePro D700 OpenGL Engine
GL_SHADING_LANGUAGE_VERSION: 1.20
GL_STENCIL_BITS: 8
GL_VENDOR: ATI Technologies Inc.
GL_VERSION: 2.1 ATI-1.60.26
OGLEnabled: true
GL_EXTENSIONS: GL_ARB_color_buffer_float GL_ARB_depth_buffer_float GL_ARB_depth_clamp GL_ARB_depth_texture GL_ARB_draw_buffers GL_ARB_draw_elements_base_vertex GL_ARB_draw_instanced GL_ARB_fragment_program GL_ARB_fragment_program_shadow GL_ARB_fragment_shader GL_ARB_framebuffer_object GL_ARB_framebuffer_sRGB GL_ARB_half_float_pixel GL_ARB_half_float_vertex GL_ARB_imaging GL_ARB_instanced_arrays GL_ARB_multisample GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_pixel_buffer_object GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_provoking_vertex GL_ARB_seamless_cube_map GL_ARB_shader_objects GL_ARB_shader_texture_lod GL_ARB_shading_language_100 GL_ARB_shadow GL_ARB_shadow_ambient GL_ARB_sync GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_compression_rgtc GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_float GL_ARB_texture_mirrored_repeat GL_ARB_texture_non_power_of_two GL_ARB_texture_rectangle GL_ARB_texture_rg GL_ARB_transpose_matrix GL_ARB_vertex_array_bgra GL_ARB_vertex_blend GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_window_pos GL_EXT_abgr GL_EXT_bgra GL_EXT_bindable_uniform GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_clip_volume_hint GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_depth_bounds_test GL_EXT_draw_buffers2 GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXT_framebuffer_object GL_EXT_framebuffer_sRGB GL_EXT_geometry_shader4 GL_EXT_gpu_program_parameters GL_EXT_gpu_shader4 GL_EXT_multi_draw_arrays GL_EXT_packed_depth_stencil GL_EXT_packed_float GL_EXT_provoking_vertex GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_stencil_two_side GL_EXT_stencil_wrap GL_EXT_texture_array GL_EXT_texture_compression_dxt1 GL_EXT_texture_compression_s3tc GL_EXT_texture_env_add GL_EXT_texture_filter_anisotropic GL_EXT_texture_integer GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_rectangle GL_EXT_texture_shared_exponent GL_EXT_texture_sRGB GL_EXT_texture_sRGB_decode GL_EXT_timer_query GL_EXT_transform_feedback GL_EXT_vertex_array_bgra GL_APPLE_aux_depth_stencil GL_APPLE_client_storage GL_APPLE_element_array GL_APPLE_fence GL_APPLE_float_pixels GL_APPLE_flush_buffer_range GL_APPLE_flush_render GL_APPLE_object_purgeable GL_APPLE_packed_pixels GL_APPLE_pixel_buffer GL_APPLE_rgb_422 GL_APPLE_row_bytes GL_APPLE_specular_vector GL_APPLE_texture_range GL_APPLE_transform_hint GL_APPLE_vertex_array_object GL_APPLE_vertex_array_range GL_APPLE_vertex_point_size GL_APPLE_vertex_program_evaluators GL_APPLE_ycbcr_422 GL_ATI_blend_equation_separate GL_ATI_blend_weighted_minmax GL_ATI_separate_stencil GL_ATI_texture_compression_3dc GL_ATI_texture_env_combine3 GL_ATI_texture_float GL_ATI_texture_mirror_once GL_IBM_rasterpos_clip GL_NV_blend_square GL_NV_conditional_render GL_NV_depth_clamp GL_NV_fog_distance GL_NV_light_max_exponent GL_NV_texgen_reflection GL_NV_texture_barrier GL_SGI_color_matrix GL_SGIS_generate_mipmap GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod   
Photo of Cameron Rad

Cameron Rad

  • 53 Posts
  • 6 Reply Likes
  • frustrated :( :( :(

Posted 3 months ago

  • 1
Photo of Jao van de Lagemaat

Jao van de Lagemaat

  • 174 Posts
  • 44 Reply Likes
This sounds like you have a major hardware issue with the external thunderbolt disk you are using. Does it behave like this when you have the catalog internal?
Photo of Cameron Rad

Cameron Rad

  • 53 Posts
  • 6 Reply Likes
Ya... :-/ 

Might just try a complete reformat of computer as this is starting to really hinder my work. Hopefully that resolves things. 
Photo of Jao van de Lagemaat

Jao van de Lagemaat

  • 174 Posts
  • 44 Reply Likes
Have you tried running with the GPU acceleration disabled (in Lightroom Preferences->Performance)? A long shot but perhaps worth a test. Most of the issues wit hGPU acceleration should have been fixed by now but you never know.
Photo of Cameron Rad

Cameron Rad

  • 53 Posts
  • 6 Reply Likes
Yea I tried with GPU Acceleration off and with the Prefer OpenGL Config.lua file. It didn't fix the issue. I ended up just reformatting my system and things seem to run smoother now.  Imported 1700 images in less than 1 minute. I'm trying to keep an eye on things I install and if they are possibly the cause for the bottleneck. Such as wacom driver, etc. 
Photo of Jao van de Lagemaat

Jao van de Lagemaat

  • 174 Posts
  • 44 Reply Likes
Wow, that is quite a difference. 1700 in a minute is about right. Historically Wacom drivers have caused bad issues with Lightroom so that's something to look out for indeed.
Photo of Cameron Rad

Cameron Rad

  • 53 Posts
  • 6 Reply Likes
Wacom Driver installed, no issues thus far. One of the biggest differences I see is that in the system info in LR, the previous/slow setup had "Build: Uninitialized" whereas now it's "Build: 10.0x7"