LIghtroom Classic 9.3 UNUSABLE!

  • 2
  • Problem
  • Updated 2 weeks ago
After the new upgrade Lightroom is completely unusable. Running on Mac iOS - Macbook Pro 2019 
Please fic the bugs urgently!
Photo of Roberto De Riccardis

Roberto De Riccardis

  • 3 Posts
  • 0 Reply Likes

Posted 3 weeks ago

  • 2
Photo of Andrew Rodney

Andrew Rodney

  • 1060 Posts
  • 245 Reply Likes
OK, now that you've made a massive assumption about this for all users on MacOS (mine runs fine), and demanded a bug fix, would you rather get help? Start by telling us exactly the issue you have, size and kind of data, where in LR etc. Otherwise we will have to assume your agenda is to rant, not find a fix. The floor is yours IF you need actual help. 
Photo of Bill

Bill

  • 265 Posts
  • 39 Reply Likes
Also works fine on Windows 10.
Photo of Roberto De Riccardis

Roberto De Riccardis

  • 3 Posts
  • 0 Reply Likes
Major issues with brush and clone tools. LR stops working or at least takes a very long time to finish the task. Tried to close and restart but same issue. I’ll try again tomorrow to find out if it works properly. Also the File export seems to be slower
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 7520 Posts
  • 1722 Reply Likes
Slowness of brush and clone tools indicate GPU may be turned on. If you turn off GPU does the brush/clone tool speed improve? 
Photo of Gail Bassett

Gail Bassett

  • 2 Posts
  • 1 Reply Like
First time I tried to use tools in develop, none of the cursors will show up.  stuck on zoom only, no matter what I choose!  I'm unable to work on images!!!  Help, please!


Photo of Andrew Rodney

Andrew Rodney

  • 1060 Posts
  • 245 Reply Likes
First thing to try is disabling GPU I preferences.
Next try resetting the preferences:
https://helpx.adobe.com/lightroom-cla...
Photo of Gail Bassett

Gail Bassett

  • 2 Posts
  • 1 Reply Like
Andrew, So sorry to bother everyone!  I just tried what I should have done before panicking...  Shut down Lightroom, Restart the computer.  All's working now!!!  DUH!  Sorry again! Thanks for the quick response!  I'll keep your email in case I run in to further problems, though!