Lightroom Classic 9.2 Window Sizing Problem

  • 15
  • Problem
  • Updated 3 weeks ago
  • Solved
  • (Edited)
When opening LR Classic 9.2 it maximized its window size to take my entire screen no matter what the window size was when I had closed LR.  I have an iMac with Catalina 10.15.3.  Uninstalled LR 9.2 and installed LR 9.1 to fix the problem.  Its was too much of a PIA to have to resize the apps window every single time I opened LR to justify the upgrade's features.
Photo of James Pintar

James Pintar

  • 3 Posts
  • 0 Reply Likes

Posted 4 months ago

  • 15
Photo of Todd Shaner

Todd Shaner, Champion

  • 1876 Posts
  • 631 Reply Likes
It appears to be a Mac only issue as I'm not seeing this behavior using LR 9.2 on Windows 10 with latest updates.
Photo of John R. Ellis

John R. Ellis, Champion

  • 5048 Posts
  • 1424 Reply Likes
This occurs on my LR 9.2 / Mac OS 10.15.3. Resetting preferences doesn't help.
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 7300 Posts
  • 1661 Reply Likes
I see it too on 10.14.6. Logging a bug with the team for Mac only.
Photo of Tanya Metaksa

Tanya Metaksa

  • 32 Posts
  • 4 Reply Likes
Had not noticed this but I am on OS 10.14.6 with LR 9.2 and it happens on my iMac

Photo of Jorge Fernandez

Jorge Fernandez

  • 2 Posts
  • 1 Reply Like
On the contrary, I noticed it since the moment the app update itself.

My Mac OS is Catalina latest version.

Tried to reset preferences, but did not help.

Photo of James Pintar

James Pintar

  • 3 Posts
  • 0 Reply Likes
It wasn't there in 9.1, so rolling back to that might be an option for you.  That's what I did.
Photo of Carlos Cardona

Carlos Cardona

  • 740 Posts
  • 145 Reply Likes
Question: why would you WANT the window smaller than the size of the screen? I don't understand wanting that. I use 2 monitors, my iMac with the Grid View (as big as possible, but not Full Screen), and the 2nd monitor with "Full Screen, Loupe-Normal". PS-moving a window around to get at what's behind it is completely inefficient, use Command-H to hide it. -former Mac IT Pro.
Photo of Jorge Fernandez

Jorge Fernandez

  • 2 Posts
  • 1 Reply Like
Very simple, it is a bug and its is not the way it should be.

Any way I am used to have many windows filling my screen I have a favorite size for the Lr windows, always 10 photos per row, allway at my favorite size per photo preview.

And I use many plugins that opens their own windows.

I finally I don't have 2 monitors, but in that case my main monitors will be in the same way I always use and the secondary used for preview a single photo. 

Thanks for your suggestions they are simple workarounds for a BUG. 

Regards.
Photo of James Pintar

James Pintar

  • 3 Posts
  • 0 Reply Likes
Different strokes for different folks I guess, Carlos.  While I have LR maximized when in the Develop module, I have lots of reasons to to want it to open full size at every launch.
Photo of anssik

anssik

  • 174 Posts
  • 43 Reply Likes
On my 27" display I use smaller-than-full-screen LR window sometimes to have a narrow gap at the right hand side of the screen, to let my desktop show through even though LR is atop.
Photo of John R. Ellis

John R. Ellis, Champion

  • 5048 Posts
  • 1424 Reply Likes
When I'm annotating photos with metadata or looking up photos in response to email requests, I often have another app open side-by-side with LR, e.g. a Web browser or an email message.
Photo of David Schneider

David Schneider

  • 1 Post
  • 0 Reply Likes
I have the same problem. Mac, OS/X 10.15.3. 

Plus, whenever I view a photo in full screen (by pressing F), the LR window goes to full screen after I close out of full screen via Escape.
Photo of Arleigh Kerr

Arleigh Kerr

  • 1 Post
  • 0 Reply Likes
Exactly same thing happens to me, along with starting up in near full screen mode even though I've previously made the LR window smaller. 
Photo of Denis Page

Denis Page

  • 1 Post
  • 0 Reply Likes
The problem is also on 10.13 High Sierra.
Photo of Josef Kissinger

Josef Kissinger

  • 4 Posts
  • 3 Reply Likes
I have the same problem on Mac OS 10.15.3 and Lightroom 9.2. Its super annoying.
Photo of Ruby k

Ruby k, Employee

  • 25 Posts
  • 17 Reply Likes
Thanks for reporting the issue. We are working on it actively.
Photo of Bill

Bill

  • 189 Posts
  • 21 Reply Likes
Comment from a Windows user: I've had this happen in the past (multiple times) but it was never related to a specific application though it did affect Lightroom. The fix was to update the video card driver. I use a Nvidia Quadro K1200 and occasionally Nvidia adds some bugs to the driver at no extra charge as does AMD. 
 
The solution, though a bit of a pain, is to periodically visit the Nvidia (or AMD) support site and download the latest driver, keeping the past (about) 8 drivers. Then when display issues occur, I update the driver with the latest and going backwards until I find one that works. To the bad ones, I append .BAD to the filename. Don't delete them because if you have a problem, you want to check the currently installed one to see if the version matches one of the bad ones. 
 
I don't know about Apple but Microsoft releases updated Nvidia drivers with Windows general maintenance. 
 
And to be fair to Nvidia, sometimes the problem is with a Windows update resulting in an incompatibility between the latest Windows update (think "patch tuesday") and the driver they choose to supply, Microsoft gets them out of sync. Hasn't happened in about a year but best to be prepared.
  
 
Photo of vinsolo

vinsolo

  • 24 Posts
  • 11 Reply Likes
This reply was created from a merged topic originally titled full screen in lightroom 9.2.

Siddenly my LR classic opens in FULL SCREEN MODE. This is a problem to me and my image flow. I have tried the display icon at the extreme bottom left of the display and this does not work. Any ideas?

use 2015 imac with mojave.

 

thanks vince
Photo of Michael Anderes

Michael Anderes

  • 6 Posts
  • 1 Reply Like
Same problem here on macos 10.14.6 and LR 9.2. Very annoying.
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 7300 Posts
  • 1661 Reply Likes
Updates to Lightroom Classic were released last night that address this issue. Please download the latest update via your Creative Cloud app and install. Please let us know if you continue seeing the issue after updating to 9.2.1. Thank you for your patience!
Photo of Angus Milner Brown

Angus Milner Brown

  • 3 Posts
  • 0 Reply Likes
Seems my version of 9.2.1 may not sadly comply. On restarting Lightroom each day it is reverting to full width on the screen (LG 38in) I reset to half the screen so I can work between two or three windows. Is there a preference setting I am missing perhaps?
(Edited)
Photo of Johan Elzenga

Johan Elzenga, Champion

  • 2842 Posts
  • 1217 Reply Likes
Go to 'Help - System Info' and check that you do really use the latest version (9.2.1).
Photo of Angus Milner Brown

Angus Milner Brown

  • 3 Posts
  • 0 Reply Likes
Think this qualifies...
Photo of Johan Elzenga

Johan Elzenga, Champion

  • 2842 Posts
  • 1217 Reply Likes
In that case it may be an idea to reset your preferences: https://www.lightroomqueen.com/how-do-i-reset-lightrooms-preferences/
Photo of Angus Milner Brown

Angus Milner Brown

  • 3 Posts
  • 0 Reply Likes
OK...done....second reboot of Lightroom appears to now stay in sized window. I'll double check tomorrow, but looks like this fixed it. Thanks for your help. -Angus
Photo of John R. Ellis

John R. Ellis, Champion

  • 5048 Posts
  • 1424 Reply Likes
Yay! My Mac LR 9.2.1 remembers its window size and position again.
Photo of John Lund

John Lund

  • 14 Posts
  • 2 Reply Likes
Yes, back to normal here again, also. Thanks for fixing this!