Lightroom Classic 9.1 gets very slow after 2 min.

  • 1
  • Problem
  • Updated 5 months ago
  • Solved
  • (Edited)
Hi there!

I got a quite big problem:

Every time I start LR-Classic an work for some minutes it starts to slow down significantly...

I can't figure out what bottlenecks the system...


Short stats:

CPU around 15-25 % (with some peaks at 40%) on all 8 cores.

GPU is utilized only by a fraction (around 5 %) BUT

GPU-Memory is loades clos to the brim afer just a view minutes

Working on 16 GB of Ram (will be upgraded shortly...though)

File-location: Samsung M.2 NVMe SSD 970 EVO

I include two graphs I think ar usefull (maybe?)


For the Graphs: at 160 sec I started LR,  at around 170 sec i started working with luminecens-work... and thats the point when everythings goes down...






From  LR-Info

Lightroom Classic-Version: 9.1 
Spracheinstellung: de
Betriebssystem: Windows 10 
Version: 10.0.18362
Anwendungsarchitektur: x64
Systemarchitektur: x64
Anzahl logischer Prozessoren: 16 (<--- 8 "real" ones)
Prozessorgeschwindigkeit: 3,9 GHz
Integrierter Speicher: 16310,4 MB
Für Lightroom verfügbarer phys. Speicher: 16310,4 MB
Von Lightroom verwendeter phys. Speicher: 3439,1 MB (21,0%)
Von Lightroom verwendeter virtueller Speicher: 9996,5 MB
Anzahl GDI-Objekte: 734
Anzahl BENUTZER-Objekte: 2208
Anzahl Prozess-Handles: 1941
Cache-Speichergröße: 0,0MB
Interne Camera Raw-Version: 12.1 [ 351 ]
Maximale Anzahl Threads, die Camera Raw verwendet: 5
Camera Raw SIMD-Optimierung: SSE2,AVX,AVX2
Virtueller Speicher in Camera Raw: 1432MB / 8155MB (17%)
Physischer Speicher in Camera Raw: 1460MB / 16310MB (8%)
DPI-Einstellung des Systems: 192 DPI (High-DPI-Modus)
Desktop-Komposition aktiviert: Ja
Monitore/Anzeigegeräte: 1) 3840x2160, 2) 3840x2160
Eingabetypen: Multitouch: Nein, integrierte Toucheingabe: Nein, integrierter Stift: Nein, externe Toucheingabe: Nein, externer Stift: Nein, Tastatur: Nein

Informationen zum Grafikprozessor:
DirectX: NVIDIA GeForce RTX 2080 (26.21.14.4166)

Installierte Zusatzmodule:
1) AdobeStock
2) Facebook
3) Flickr
4) Nikon Tether-Zusatzmodul
5) The Fader

Config.lua-Flags: None

Adapter Nr. 1: Anbieter : 10de
Gerät : 1e87
Subsystem : 1e8710de
Version : a1
Grafikspeicher : 8010
Adapter Nr. 2: Anbieter : 1414
Gerät : 8c
Subsystem : 0
Version : 0
Grafikspeicher : 0
AudioDeviceIOBlockSize: 1024
AudioDeviceName: Lautsprecher (Realtek(R) Audio)
AudioDeviceNumberOfChannels: 2
AudioDeviceSampleRate: 48000
Build: 12.1x4
Direct2DEnabled: false

 

 

Would be grand If You could help 

 

Cheers!

 

Mel
Photo of Melanie Weiß

Melanie Weiß

  • 9 Posts
  • 0 Reply Likes
  • frustrated

Posted 6 months ago

  • 1
Photo of Todd Shaner

Todd Shaner, Champion

  • 1966 Posts
  • 665 Reply Likes
Are you using LR with dual display (i.e. secondary)? If so see the below post for an explanation. If not please explain exactly what you are doing in LR that slows down.

https://community.adobe.com/t5/lightroom-classic/lr-slow-with-dual-monitors-on-mac/td-p/8971869



Photo of Melanie Weiß

Melanie Weiß

  • 9 Posts
  • 0 Reply Likes
Hey Todd,

thx for the quick reply!

My System currently has 3 Monitors: Monitor 1 and 2 are 4K-OLED.
Monitor 3 is just a split from mon. 1 via Pass true (shouldn't be the problem)
I'm working on Monitor 1 wich is set as my primary Monitor.
Mon. 2 is for browsing and convenient LR-Tutorials ;-)

It get's really slow whenever I go into develop and star using the brush and even worse when working with the sliders for noise reduction.

The thing I can't get my head around is, that none of my Computer-monitoring-graphs show me any kind of bottleneck or (Not Ram, CPU, GPU-video /encoding, kerneltimes, BUS-Usage, etc.) except VRam... therefore I thought that's the issue.

Thx for helping, hopefully we get this sorted ^^








Photo of Volker Brecht

Volker Brecht

  • 18 Posts
  • 23 Reply Likes
Hallo Melanie,
es gibt nach wie vor performanceprobleme mit PS und z.T. auch mit Lightroom, wenn gleichzeitig auf dem Rechner Acronis Trueimage installiert ist. Ist das vielleicht das bei dir der Fall?
Photo of Melanie Weiß

Melanie Weiß

  • 9 Posts
  • 0 Reply Likes
Hi Volker!

Nein, ich hab kein Acronis Trueimage ... leider... das hätte Dinge einfacher machen können.

Photo of Todd Shaner

Todd Shaner, Champion

  • 1966 Posts
  • 665 Reply Likes
Make sure all LR background tasks are paused and Preferences Performance tab is set as shown below. What camera make, model, and type of image files are you editing?
Photo of Melanie Weiß

Melanie Weiß

  • 9 Posts
  • 0 Reply Likes
Ok did the first!

Camera: Sony alpha 6000
File-format:  Raw-Format (.ARW-Format)

And the performance-settings are set as mentioned in the Adobe-FAQ (i.e. as you showed in the screenshot)

But, sadly, still no change in performance....
(Edited)
Photo of Todd Shaner

Todd Shaner, Champion

  • 1966 Posts
  • 665 Reply Likes
Two more settings to try.
1) In LR Preferences> Performances> Camera Raw Cache Settings increase the current setting by x2. I have mine set at 100GB and it's currently ~50GB with about 40,000 image files imported into LR. Make sure the Cache folder is located on a fast drive with plenty of spare space.
2) Right-click on the desktop and select 'Nvidia Control Panel. Click on 'Manage 3D Settings' and make the below settings change.
Shut down everything, reboot the system, and try again.
(Edited)
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1739 Posts
  • 601 Reply Likes
In addition to what Todd suggested:

1. Try check off "Use GPU for image processing" option to see if the VRAM usage comes down.
2. Are you actively using other apps like Photoshop while using Lr?
Photo of Melanie Weiß

Melanie Weiß

  • 9 Posts
  • 0 Reply Likes
Hi Simon!

For 1. : I did. VRAM is on constant 2 GB (much likely because of Chrome) and not bothered by LR-usage. My CPU-usage for this scenario looks like this:
 

For 2. :  Mostly Chrome, sometimes PS and regularly Filebrowser .
Active Anti-Virus scan is disabled for LR specifically. 
Photo of Melanie Weiß

Melanie Weiß

  • 9 Posts
  • 0 Reply Likes
got it boss!

File-location is on a NVMe - Disk
Grafics options are already on those settings.

Nothing new so far, performance wise.
zation 
The thing I can't wrap my head around is, that my whole system runs on 20-25% utilization BUT LR behaves as if all is on overpower already...
(Edited)
Photo of Todd Shaner

Todd Shaner, Champion

  • 1882 Posts
  • 634 Reply Likes
I suspect your display configuration may be causing the LR performance issues. Two things to try:

1) Simon suggested try check off "Use GPU for image processing". Is LR performance improved if you change the setting for 'Use Graphics Processor' to OFF completely?

2) Shut your system down and disconnect all displays except the primary display used with LR. Use a DisplayPort connector and cable and not HDMI for this primary display. Try editing in LR with 'Use Graphics Processor' set to a) OFF, b) then try it ON, and c) both ON and 'Use GPU for image processing checked.

How did each of these affect LR's performance?
Photo of Volker Brecht

Volker Brecht

  • 18 Posts
  • 23 Reply Likes
Hi Melanie,

trat das Problem "aus heiterem Himmel" auf, oder nach unmittelbar nach dem update auf LR 9.1 ? Betrifft es sämtliche Dateien wie PSD oder Tiff  oder nur die raw Dateien ?
Photo of Melanie Weiß

Melanie Weiß

  • 9 Posts
  • 0 Reply Likes
Naja "aus heiterem Himmel" schon, aber nur weil ich von LR CC auf LR classic umgestiegen bin... Tiff-Dateien verhalten sich ähnlich, psd-Dateien möchte ich in meinem Use-case gerne erst nach dem Bearbeiten erzeugen (wenn überhaupt), hab ja nicht den ganzen Tag Zeit erstmal alle Raw-Dateien zu konvertieren... ;-))
Photo of Melanie Weiß

Melanie Weiß

  • 9 Posts
  • 0 Reply Likes
Alright Guys thank you so much for all your Help!
Really appreciate it.

I think it's good now, and i'll try to sum it up (at least what did the job for me)
If things starting to look bad again I hope to get back to you :-))


1. My System is: 

AMD Ryzen 7 2700 x ,
DDR4 PC3000 CL 16 Pariot Viper 4 (4 x 8 GB),
Asus TUF B450-Plus,
SSD Samsung SSD 970 EVO M.2 500GB NVMe
Monitor setting:
1st and 2nd: 4K Monitors with DisplayPort-connection, 3rd Montior with HDMI-connection



2. My Problem is/was:

in Lightroom Classic 9.1 
while working with tools like Adjustment Brush with luminescent (or similar), and/or Point corrections applied, LR really slowed down to the point of not working. Plus while using presets, working was annoyingly paused/slowed or stoppt all together.

3. (My)Solution(s) and a small analysis:

- First bit of improvement was to get the right NVIDIA-Settings ( Todds suggestion, see above)
- Reconfiguring displays (having only ONE Monitor connected via DP, or two 4 K ) doesn't affect performance
- Switching the GPU-support off (in LR) doesn't affect anything.
- Pausing  LRs background tasks (again: thx Todd) did bring my CPU usage down a bit. But with 35% Usage in the beginning, that wasn't helping  IN LR itself but my PC over all.

-What did the job (almost completely, i would say 80 %) was to install two more RAM-DIMMs.
Now I've got : 4 x 8 GB Ram instead of 2 x 8 GB.
 

After installing the RAM i tried to stress LR as much as possible with all the questionable knowledge I have and the results are:

With the 32GB of Ram (and some good adjustments) i got a solid experience.
And more interestingly:  
While none of my relevant system-points (%-Usage of CPU, GPU, RAM, BUS, SSD) where at more than 35% with the additional RAM the usage of CPU, BUS and GPU got up around 5-10% on average. 

I have no clue why that is...Usage wise my build should easily be able to run three LRs  (just a bad equation ;-) )

So, for now, all I can do is thank all of you again! Cheers to you!

bb

Mel







Photo of Todd Shaner

Todd Shaner, Champion

  • 1960 Posts
  • 663 Reply Likes
Glad to hear you got the performance issue resolved. There are many people using systems with only 16GB who don't have performance issues. So it begs the question why this appears to be the cause of your issues. Some people have mentioned that LR memory usage climbs even with LR Idle, but in your graph memory usage maxes out at 72%. Anyhow, glad to that resolved the issue. Please keep us posted if LR performance degrades.
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1739 Posts
  • 601 Reply Likes
Good to hear adding more RAM to your system helps. What is the size of your catalog in terms of # of all photographs?
Photo of Melanie Weiß

Melanie Weiß

  • 9 Posts
  • 0 Reply Likes
I know... "Throw money at it" isn't the best thing to do... and in no way a proper Solution or even an explanation... but it worked so what ;-) XD
Photo of KM Purcell

KM Purcell

  • 4 Posts
  • 0 Reply Likes
Interesting.  I have a problem that I cannot figure out.  IF I minimize LR, then bring it back up, the whole LR screen shows white for about 2 - 3 seconds.  Until the photo being shown and all buttons, menus, etc, get to the normal gray or black I set them to.  Such a long pause, in my new system. 

RAM is not a problem.  128 GB, DDR4, ThreadRipper 2950X, using fast NvME drives. Running newest drivers on my eVGA RTX 2080 Super (8 GB)

Any thoughts on this one.  I've tried for a few weeks to troubleshoot.  Been at computers since 1983.  My old AMD CPU with a eVGA 960 card, seems many more times faster.  Very strange.

Photo of Todd Shaner

Todd Shaner, Champion

  • 1960 Posts
  • 663 Reply Likes
Have you tried the latest Nvidia Studio driver x441.66? During install choose 'Custom' and then check 'Clean Install.'

https://www.geforce.com/drivers/results/155648
Photo of KM Purcell

KM Purcell

  • 4 Posts
  • 0 Reply Likes
I did install the newest N.Studio driver, but did not do a clean.  I will.  Good idea.  Thanks Todd.
Photo of KM Purcell

KM Purcell

  • 4 Posts
  • 0 Reply Likes
Well, still trying everything.  Clean install made no difference. Still trying to figure it out.  I am going to swap my new Video card 2080 Super with my son's 1070, and see.  Just had no time yet.