Lightroom Classic 9.0 Print Problem

  • 2
  • Problem
  • Updated 8 months ago
Just upgraded to LR CC 9.0 on a MacBook Pro running Mojave 10.14.6 and now I cannot print. When I click the print button, the Creating Print Job progress bar appears, fills to completion and then nothing happens. Nothing is sent to the print queue for my Epson L360. 

This also happens if I choose a different printer or even if I choose Save as PDF. I have tried restarting LR and also the laptop. Other applications such as Preview will print OK.

If I choose Edit in Photoshop 2020, then I can print the image normally from Photoshop.
Photo of Lawrence Upton

Lawrence Upton

  • 4 Posts
  • 0 Reply Likes
  • Frustrated

Posted 8 months ago

  • 2
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 7545 Posts
  • 1729 Reply Likes
A Preference File will survive a Lightroom uninstall/reinstall. Sometimes weird behavior is corrected/cured by resetting the preferences.
Reset Procedure:
1. Close Lightroom.
2. Hold down [Alt/Opt]+[Shift] while restarting Lightroom.
3. Overwrite the Preferences when prompted by the dialog.
4. Close Lightroom.
5. Restart Lightroom.
Does the print issue continue after resetting the preferences?

If so, then try the Lightroom Clean Install Procedure with the current version:
  • Close Lightroom
  • Restart the computer
  • Use the Adobe Creative Cloud App to uninstall Lightroom Classic
  • Restart the computer
  • Install Lightroom Classic via the Creative Cloud App without launching any other programs.
  • Restart the computer
  • Launch Lightroom
  • Wait 5 minutes
If print issues persist after this procedure and reset of your preference file, then it is likely an issue that needs troubleshooting further.
Photo of Lawrence Upton

Lawrence Upton

  • 4 Posts
  • 0 Reply Likes
Thanks for the suggestions.

I tried resetting the preferences. Still cannot print.
I tried uninstalling and reinstalling and it looks like my issue is here. The install process gets to around 40-50% and then completes suddenly. LR will open but will not print. My internet connection is quite slow so this may be a contributing factor. I have tried multiple times and each time the download completes in the 40-50% range.
Photo of Richard Hix

Richard Hix

  • 32 Posts
  • 6 Reply Likes
If reseting preferences doesn't work, try rolling back to version 8.4.1,  After a couple of hours trying to fix another problem with Catalina and LR 9, the Adobe tech rolled me back and turned off auto update saying there were known problems that Adobe was working on.

(Edited)
Photo of Lawrence Upton

Lawrence Upton

  • 4 Posts
  • 0 Reply Likes
I have now successfully completed a reinstall and still have the same print problem. Is a rollback to an earlier version possible.
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 5655 Posts
  • 2260 Reply Likes
Photo of Lawrence Upton

Lawrence Upton

  • 4 Posts
  • 0 Reply Likes
Thanks for the info.