Lightroom Classic 8 crashing on launch

  • 3
  • Problem
  • Updated 10 months ago
  • Solved
My installation of Lightroom Classic 8 started crashing soon after launch yesterday. It had been working prior to this. I have tried resetting preferences, rebooting my computer, uninstalling Lr, reinstalling Lr, openning a different catalogue, all to no avail. Still crashing just a few seconds after launch. Tried creating a new empty catalogue (ctrl key pressed on launch, Windows 7 Pro), but before I could enter a new catalogue name, Lr crashed.

Somethng is seriously wrong here and it's not the first time. Previous versions of Lr Classic have also done this to me, but I've always found a way to get it working again. Not this time it seems.

I did opt to send a crash report. I've done this before too, but there has not been any follow up or resolution from Adobe.

I'll try a few more things, but for now, my Lr Classic 8 is pretty much dead.
Photo of Anthony Blackett

Anthony Blackett

  • 177 Posts
  • 53 Reply Likes

Posted 11 months ago

  • 3
Photo of dmeephd

dmeephd

  • 300 Posts
  • 77 Reply Likes
Despite what the so-called Champions and pundits will tell you, backup your catalog after every use.  Optimize often...I optimize before shutting down EVERY time.  (One genius stated that you shouldn't have to optimize more than once a month.  That is a lie of the purest swank, aka bullshite.)

You've got a Windoze system, so I can't offer much specific advice there—I abandoned Microsoft in 2014.  Try drive de-fragmentation; Windows does not have very good file system management like Unix or Mac OS, and LR is sensitive to how long it takes to read the catalog and get started before giving up the ghost (so to speak).
Photo of Anthony Blackett

Anthony Blackett

  • 142 Posts
  • 50 Reply Likes
Thanks for your suggestions. I doubt that this is a disk fragmentation issue since I have rebuilt my entire system from scratch on a new ssd drive just a few weeks ago. It also seems to have nothing to do with the catalogue either, since it has crashed while in the open catalogue dialog, before Lr even opened a catalogue.

It is a great shame that what should be a great application for serious photographers, has become such a liability.
Photo of dmeephd

dmeephd

  • 300 Posts
  • 77 Reply Likes
I'll bow to your knowledge of your system, truly.

I do agree with you wholeheartedly that Adobe needs to address the requirements of serious amateurs and professional photographers.  Unfortunately, since 2015 Adobe has  decided that a subscription service targeting the iPhone crowd is their path to huge monetary rewards.

I've yet to figure that one out since Apple gives Photos away for free; perhaps it's the Windoze users Adobe sees as their cash cow?

Frankly, I gave up on Windoze in 2014, and have never looked back.  I know it is not an easy move to make, believe me.  It kept me up for nights in March of that year.  However, since then, I have been kicking myself in the butt for not making the move ten years before.

Unfortunately, the issues with Adobe products have propagated across all their platforms...it just seems like they are less on the Mac (probably because Apple enforces more stringent programming standards for third-party developers.)

Alas, their crap eventually catches up with everybody.
Photo of Anthony Blackett

Anthony Blackett

  • 177 Posts
  • 53 Reply Likes
I have finally resolved my issue with Lr Classic 8 crashing on launch. After trying many things, this is what eventually got it working again (for the time being):

1. Uninstalled Lr Classic.

2. Rebooted my computer (Windows 7 Pro 64).

3. Reinstalled Lr Classic.

Previously I had uninstalled and reinstalled without restarting Windows.

Back in business, until next time.

Glad to get Lr working again because I am currently photographing glass plate negatives that were taken nearly 100 years ago by a photographer who recorded numerous images in the region where I live. So far, I have re-photographed 64 images for the local historical society and these are an invaluable asset and photographic record of the early settlement of the region.

Photo of DeAnna Jones

DeAnna Jones

  • 12 Posts
  • 2 Reply Likes
I have the same issue, but on a Mac.  Sync makes everything extremely slow and when I can finally turn it off it seems to help.  But constantly freezing up.
Photo of Anthony Blackett

Anthony Blackett

  • 177 Posts
  • 53 Reply Likes
Lightroom Classic 8.0 has suddenly started crashing shortly after startup, again! This problem really needs to be fixed. I send in crash reports, but get nothing back. Each time this has happened I've been left to fix it myself. On previous occasions I tried various methods to recover and eventually got Lr going again with no real knowledge of what actually fixed the problem. I just tried what appeared to fix it last time, but it didn't work this time. It would be very nice to hear back from Adobe. It would be great to have Adobe tell me they have identified the problem. It would be even better if Adobe told me they have fixed the problem. Meanwhile, I'm paying for a product that doesn't work! Lr Classic 8.0 is broken and needs fixing. As you can see, Lr hasn't even opened a catalogue before crashing.



Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 5882 Posts
  • 1290 Reply Likes
Crash unrelated to thread where posted

Please reference the new conversation here: Lightroom 8.0 Crashes on Launch