Lightroom Classic 8.4: Hanging on launch (Mac 10.14.6)

  • 23
  • Problem
  • Updated 1 month ago
  • Solved
  • (Edited)
I just upgraded Lightroom Classic from v 8.1.3 to 8.4.  It now hangs. I am on MacOS Mojave version 10.14.6. When reverting to v 8.1.3, Lightroom works fine. Are there compatibility issues with this version of Mojave? Thanks
Photo of Leila Shehab

Leila Shehab

  • 12 Posts
  • 3 Reply Likes

Posted 2 months ago

  • 23
Photo of Kirk Hudson

Kirk Hudson

  • 3 Posts
  • 1 Reply Like
Disabling the Logitech Options plugin (using the Plugin Manager in LR) appears to have cured the problem.  Many thanks to David Golding and MACKIE for the tip!
MACKIE, I am curious why you also removed the LogiOptionsAdobe folder from the Adobe CEP extensiions Common Files subdirectory.

Photo of MACKIE

MACKIE

  • 2 Posts
  • 0 Reply Likes
I wasn't sure if that "check" that happens during the Reading Preferences step was looking to the folder. Also because I was desperately flailing about trying to fix my problem and I read that someone else had done that for a different problem.  
Photo of Kirk Hudson

Kirk Hudson

  • 3 Posts
  • 1 Reply Like
Thanks for the reply.
Desperately flailing trying to fix computer problems seems to be becoming the new default mode with every OS, app and firmware update these days. Brings back painful memories of the bad old days, when every other day was a BSD adventure..
Thinking about the Logitech Options issue further, I wonder if removing the LogiOptionsAdobe folder was the only route open for those folks dealing with a LR installation that permanently froze whenever they tried to open LR.

I am also wondering if the next LogiOptions update will repopulate the CEP extensions directory.

Because I have a basic desktop setup and don't use customized keyboard/mouse settings in LR or PS, I am also wondering whether I would be better off just removing the entire LogiOptions app from my system.
Photo of Bill Allan

Bill Allan

  • 4 Posts
  • 0 Reply Likes
All this is very interesting but why are we all jumping through so many hoops to try and solve a problem which is the responsibility of Adobe. I suspect we are only the tip of an iceberg!
Rikk cannot something not be done about this?
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 5075 Posts
  • 1986 Reply Likes
The problem is figuring out why you're seeing it and others aren't. That takes a bit of detective work.

You don't happen to have that same Logitech plug-in installed, do you? It's been known to cause problems in the past.
Photo of Witold Kramarz

Witold Kramarz

  • 4 Posts
  • 0 Reply Likes
I totally agree. I don't have time for testing... I am working on the latest iMac and latest OS - like millions of other users - so I would expect LRC to be compatible. 
I waisted a few hours on Sunday trying to resolve something that should have been working in first instance. 
Photo of Van Baker

Van Baker

  • 2 Posts
  • 0 Reply Likes
I am having the same exact problem with 10.14.6 and 8.4. I tried to remove the preferences file and that made no difference. So I launched from a simple catalog that I had used in a test a few months ago and then created a new catalog and tried to import my current catalog into the new catalog. It said creating new temporary catalog only to hang. I waited about an hour and then hit the cancel button and Lightroom then said cancelling for about another hour. I eventually did a Force Quit even though the system did not say Lightroom was unresponsive. Reading above I don't have the Logitech plug-in so that is not the issue. Very frustrating.
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 5075 Posts
  • 1986 Reply Likes
You might want to roll back a version until Adobe figures out what’s up. https://www.lightroomqueen.com/roll-b...
Photo of Van Baker

Van Baker

  • 2 Posts
  • 0 Reply Likes
Thanks, I rolled back and that is working for now.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15636 Posts
  • 2370 Reply Likes
Please update macOS. Go to System Preferences > Software Update and install the following update:

macOS Mojave 10.14.6 Supplemental Update   –– Restart Required

This update contains bug fixes that improve the stability, performance, and security of your Mac, and is recommended for all users.

This update:

  • Resolves an issue that may cause certain Mac notebooks to shut down during sleep
  • Fixes an issue that may degrade performance when working with very large files
  • Addresses an issue that may prevent Pages, Keynote, Numbers, iMovie, and GarageBand from updating

For more detailed information about this update, please visit: https://support.apple.com/kb/HT209149

For detailed information about the security content of this update, please visit: https://support.apple.com/kb/HT201222

Photo of Tim McMahon

Tim McMahon

  • 34 Posts
  • 9 Reply Likes
Jeffrey,
People here have been experiencing a coflict between LR 8.4 and macOS 10.14.6.   Most seem to be suggesting the problem lies with LR 8.4, but others of us (me included) have LR8.4 installed and running perfectly with macOS 10.14.5
My feeling is that it is just as likely that something subtle has changed in the OS update that causes the problem.  
Your post implies you are confident that macOS 10.14.6 is OK now.  Yes?
Photo of Leila Shehab

Leila Shehab

  • 12 Posts
  • 3 Reply Likes
Jeffrey,

I installed the OS update, restarted the computer and installed LR 8.4.  I still have the same problem with LR 8.4 hanging at launch.  Here is a screen shot of the activity monitor.  I reverted to LR 8.3.1 one more time for LR to work.  Don't you guys test??  This is really frustrating.
Photo of David Golding

David Golding

  • 94 Posts
  • 10 Reply Likes
What plug-ins do you have?
Photo of Leila Shehab

Leila Shehab

  • 12 Posts
  • 3 Reply Likes
Here are my plug-ins
Photo of David Golding

David Golding

  • 94 Posts
  • 10 Reply Likes
yep, no suspects
Photo of paul walton

paul walton

  • 10 Posts
  • 1 Reply Like
I have also updated the OS and re-tried V8.4 and it still hangs on start up. :(
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15636 Posts
  • 2370 Reply Likes
Official Response
Engineering is working on a fix for this.
Photo of Leila Shehab

Leila Shehab

  • 12 Posts
  • 3 Reply Likes
Hi Jeffrey,
I worked extensively with Apple Support since I am still encountering LR hanging after installing the supplemental update to Mac OS.  The Senior Adviser who was helping me narrowed the issue to the current catalog containing my pictures not opening.  A test (blank) catalog can open fine on LR 8.4.  He is requesting a phone contact so that Apple Support can work directly with the Adobe engineers.  Please send a phone contact so that work can proceed efficiently with Apple.  Thanks
Photo of Leila Shehab

Leila Shehab

  • 12 Posts
  • 3 Reply Likes
This is getting utterly ridiculous.  I am caught between Apple and Adobe trying all kinds of workarounds.  I have reinstalled OS, installed the latest OS supplemental update, worked with Adobe Support and Apple support for 4 hours, created a test catalog, tried to import to that catalog, (it doesn't work).  Reverted many times to 8.3.1 to be able to use LR.
I am unwilling to go any further.  The problem is obviously with the latest LR 8.4 update unable to open a non empty catalog.  Fix it!!
Photo of Andrew Silvers

Andrew Silvers

  • 1 Post
  • 0 Reply Likes
This reply was created from a merged topic originally titled LR Classic Hangs on startup.

I am running mac OS High Sierra. Been great with LR classic 8.4. Then it then will not open my catalogue. Spinning beachball. It will open an empty new catalogue (empty) but unable to import into this empty catalogue.

Eventually, by going back to 8.3 it works with no issues.

What do to?? Future upgrades
Photo of Van Baker

Van Baker

  • 3 Posts
  • 0 Reply Likes
It has been two weeks since you said engineering was working on a fix. It would be nice to get an update as to when the fix can be expected. It would seem that if you are going to charge people every month to have access to the software it should work and any problems should be fixed quickly.
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 6027 Posts
  • 1328 Reply Likes
Lightroom Classic 8.4.1 was released earlier today and has a fix for this issue. Please install the update and let us know if you are still seeing this issue. 

Thank you for your patience!
Photo of paul walton

paul walton

  • 10 Posts
  • 1 Reply Like
Updated now and it opened an empty catalogue just fine, then swapped over to my normal one equally well...

It's looking good! (so far!)
Photo of Leila Shehab

Leila Shehab

  • 3 Posts
  • 0 Reply Likes
When I click on upgrade, I still get version 8.4 with the same issue.  I don't have an option for 8.4.1.  Do you have a link?
Photo of paul walton

paul walton

  • 10 Posts
  • 1 Reply Like
I just did the same... 

Click on the three vertical dots and select check for upgrades and it sorts itself out!
Photo of Leila Shehab

Leila Shehab

  • 3 Posts
  • 0 Reply Likes
Thanks, it now works.