Lightroom Classic 8.3.1: Won't quit on macOS — I have to force quit

  • 1
  • Problem
  • Updated 9 months ago
  • Solved
  • (Edited)
When I user Cmd-Q or invoke Quit from the File menu, Lightroom doesn't do anything. I have to force quit to get it to close. This began with Lightroom 8.3 (though not immediately — I'd say the last week or so, before and after the 8.3.1 release). I'm guessing there's something weird about my configuration because I don't see others reporting this problem. Any suggestions or advice? Force-quit works fine.

— 15" MacBook Pro late 2016, 16GB RAM
— MacOS 10.14.6 beta 3
— Only LR plug-in is Jeffrey Friedl's Export to Flickr (which by the way has been behaving strangely of late)
Photo of Stephen Shankland

Stephen Shankland

  • 107 Posts
  • 23 Reply Likes

Posted 1 year ago

  • 1
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 7535 Posts
  • 1726 Reply Likes
Greetings Stephan,

I'd agree with your assessment that we aren't seeing reports of this.  First stop when that happens is the venerable Preference file reset:

Canned Text:
A Preference File will survive a Lightroom uninstall/reinstall. Sometimes weird behavior is corrected/cured by resetting the preferences. 

Reset Procedure:

1. Close Lightroom.
2. Hold down [Alt/Opt]+[Shift] while restarting Lightroom. 
3. Overwrite the Preferences when prompted by the dialog.
4. Close Lightroom.
5. Restart Lightroom.

Does the behavior continue after resetting the preferences?
Photo of Stephen Shankland

Stephen Shankland

  • 107 Posts
  • 23 Reply Likes
Yep, that did the trick — thank you!
Photo of Donnie Bunn

Donnie Bunn

  • 2 Posts
  • 0 Reply Likes
I was having the same issue.  This worked for me too !  Thanks!
Photo of Carlos Cardona

Carlos Cardona

  • 777 Posts
  • 149 Reply Likes
I was a Mac IT pro for 25 years. Probably a corrupt cache or application state. Please give your Mac the "once over"! Run the free Onyx (https://www.titanium-software.fr/en/o...), reboot. (In Onyx just run almost everything in the Maintenance tab, deselecting things you may not want deleted, like Launch Services . Hit the "Options" button and deselect more stuff like Cookies & Other Site Data, Browser History, Form Values, etc.), then hit Run Tasks. After it's done it will ask for a reboot. 

If that doesn’t fix it run Disk Warrior if you can ($120), (https://www.alsoft.com), reboot. If you can’t do Disk Warrior, at least run First Aid from Disk Utility. Also just doing a "Safe Boot" can clear out caches (restart, hold down shift until you see "Safe Boot" on the screen, then reboot normally. I would try Onyx first!

Photo of threesixty

threesixty

  • 6 Posts
  • 4 Reply Likes
I have had that problem — so you're not alone.As with a number of glitches in Adobe suite software, the preferences overwrite Rikk mentioned worked for me. I've seen similar kinds of issues in Illustrator and Photoshop crop up from time to time over the years.