Lightroom classic 8.2 does not recognise duplicates for sony A6000

  • 1
  • Problem
  • Updated 2 months ago
  • (Edited)
Since I got the camera about a year ago, LR has never once detected duplicates when importing from the SD card from my Sony a6000 using a USB3 card reader. I use the same process to import images from my Canon 5DIII and this works.  The existing imported file, and the file on SD card which is a duplicate but not recognised as such, as identical file name etc. Nothing has changed in any way.  

E.g. I can put in the SD card into the reader, import images. Then open the import window, and it will show all the same files to import, even with "Dont import suspected duplicates" ticked.

What is wrong?

This makes importing very difficult - either I end up with thousands of duplicates, or I i have to manually figure out which files are duplicates by listing out the file names from old imports from this camera.

Note, all my images are raw.
Photo of Simon Hobbs

Simon Hobbs

  • 17 Posts
  • 0 Reply Likes

Posted 2 months ago

  • 1
Photo of Just Shot Me

Just Shot Me

  • 327 Posts
  • 94 Reply Likes
This does not happen to me, Ever. 
Do you have "Don't import Suspected Duplicates" checked in the "File Handling" section in the Import dialog?
Are you using the "Copy" option or the "Copy as DNG" option.

The only things that I can think of that might cause this is possibly a corrupted preferences file and resetting the LR preference might fix it.

Also I suggest that once you get files from the SD card (And Back those Images up to some other drive) you Format the card in the camera to remove the images that are on it. That way there will not be any duplicates to import.
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 5544 Posts
  • 1166 Reply Likes
Do you rename on import?