Lightroom Classic 7.2 frequently crashing - even if just opening the application and doing nothing!

  • 6
  • Problem
  • Updated 6 months ago
Lightroom has crashed many times since the update from 7.1 to 7.2 - I've submitted 4 crash reports (generated by Lightroom itself) in the last 24 hours.

I'm on Windows 10, with plenty of memory etc. to meet the minimum specs.  Lightrooom Classic 7.1 has been perfectly stable.. but now I'm not able to work.

Each time I open Lightroom it goes back to a specific Collection in the Library, it does not open at the Collection or Folder where I was last working.  I can get the "working collection" to change if I open the app, select the collection, then quit before the app has time to crash itself.

After re-opening I can browse the library, then after an action such as printing, the library becomes unresponsive.  For example I can't toggle the synchronise option on a collection, and clicking any image does not bring up the details in the metadata etc. even if the image is on my local hard drive - it just spins its wheels and then crashes.  I can move around the library, but not do any serious editing, keywording, filing etc.  It seems to allow one action, then crashes.

I only have to leave the app open on my desktop and do absolutely nothing and it crashes... which makes me suspect its a problem related to synchronisation.  

Anyway, with the tech support chat option not available now until Monday I'd really like to be able to download v7.1 and go back to how I was... any ideas?
Photo of sean_g

sean_g

  • 4 Posts
  • 2 Reply Likes
  • unhappy

Posted 7 months ago

  • 6
Photo of kitty van gemert

kitty van gemert

  • 19 Posts
  • 2 Reply Likes
Use the CC app to uninstall Lightroom classic (in the cc app, click on the tiny arrow next to the button that says Open and select uninstall from there). When that is done, go to the CC app, choose to install Classic (this will install 7.0 version) when that is done click on that arrow next to that button once again and choose Other versions and choose 7.1 to install that update. 
Photo of sean_g

sean_g

  • 4 Posts
  • 2 Reply Likes
Big thanks for the hint - I'm back with v7.1 and working again.  I actually skipped a step - after the uninstall I noticed that CC app offered me "other versions" and I went direct to 7.1.

I've submitted 2 or 3 more crash reports with v7.2 last night... hopefully Adobe will take note there's a problem with the latest release.  Meanwhile, thanks again for the hint on how to roll back a version.
Photo of David Birdwell

David Birdwell

  • 1 Post
  • 0 Reply Likes
This worked for me too. I did all the things that made it crash before and it hasn't. 7.2 must be particularly buggy
Photo of GordonB

GordonB

  • 1 Post
  • 0 Reply Likes
I'm on a slightly older system: Late 2013 iMac i7, 8GB RAM running MacOS 10.13.3. I was experiencing performance issues under 7.0 - mostly with images in the Library module not loading when the preview was clicked, I just got "Calcualating..." with three dots in the top left-hand corner of the thumbnail. It also ate up all my memory and continued to gobble up whatever I had free, despite not doing anything except opening it. It got progressively worse in 7.1 so I was happy to update to 7.2.

Everything worked fine for about an hour and then LR just quit. I reopened it and it quit again. I restarted the computer and launched LR but didn't touch it. After about 5 seconds it quit. I tried that several times but it wouldn't stay open for more than a few seconds. Now I'm back to 7.0 and it's been working ok for the last 3 hours. Now it's frozen on exporting 3 files.
(Edited)
Photo of Holger Becker

Holger Becker

  • 2 Posts
  • 0 Reply Likes
Hi,
I had to go back to 7.1 as well, with the same Symtoms. Win 10, I7, 8Gig Ram, SSD, Intel 4400 or 4600, Catalog on 123 000 Pics, Catalog optimized, all drivers up to date.
Freezing during move to Edit mode
Freezing when applying ratings to multiple pictures in Comparison view
Freezing when exporting to Photoshop
Photo of Arnold Bartel

Arnold Bartel

  • 178 Posts
  • 40 Reply Likes
The same on my system (Win7): Just leaving LR Classic CC 7.2 open for a while without doing anything and suddenly it crashes and a bug report form opens.

<crashreport serviceVersion="1.6.3" clientVersion="1.6.3" applicationName="Adobe Lightroom Classic" applicationVersion="7.2" build="[1156743]">
<time year="2018" month="2" day="23" hour="17" minute="14" second="32"/>
<user guid="48abd1c0-4dfa-436d-aef7-e28395074e24"/>
<system platform="Windows 7 Ultimate" osversion="6.1" osbuild="7601" applicationlanguage="de-de" userlanguage="de-AT" oslanguage="de-AT" ram="16323" machine="Intel(R) Core(TM) i7-3930K CPU @ 3.20GHz" model="Intel64 Family 6 Model 45 Stepping 7" cpuCount="12" cpuType="8664" cpuFreq="3201 MHz"/>
<crash exception="EXCEPTION_IN_PAGE_ERROR" instruction="0x000007FED10AAE30">
<backtrace crashedThread="0">
<thread index="0">
(Edited)
Photo of sean_g

sean_g

  • 4 Posts
  • 2 Reply Likes
1st Update from me.  I had an on-line chat with an Adobe support rep.  He recommended removing and reinstalling all my Microsoft Visual C++ Redistributables.. (Control Panel, Programs and Features)
That didn't help.
Photo of sean_g

sean_g

  • 4 Posts
  • 2 Reply Likes
2nd Update from me.  Finally all the crash reports I sent in when trying to get 7.2 to work have raised a response from Adobe.  I got an email from a support rep with a parameter to tweak which seems to resolve the issue.  I applied the fix on Friday and Lightroom 7.2 has been running all weekend without trouble (~2.5 days, great considering I'd be lucky to keep the program in memory for more than an hour before hand).

Here's the fix:

  1. Choose Edit > Preferences.
  2. In the Preferences dialog, go the Presets tab.
  3. In the Presets tab, click the Show Lightroom Presets Folder button. The root preset folder opens in the File Explorer. In the File Explorer, navigate into the Lightroom folder.
  4. (Alternatively, press the Windows button in the computer, and then type %appdata%)
  5. In the Explorer, go to the Adobe folder and then move to the Lightroom folder.
  6. Copy the attached config.lua file into the Lightroom folder mentioned above. [details below explain the file - easy to create your own]
  7. Relaunch Lightroom Classic.
  8. After relaunch open ‘Help->System Info’ menu option. The section under config flags should show:
Config.lua flags:
DigestManager.dontCalculateDigest = true


----- Instructions to recreate the file I was sent:
----- Filename is: "config.lua"
----- content of the file is simply the following 1 line of text:
DigestManager.dontCalculateDigest = true
Photo of Arnold Bartel

Arnold Bartel

  • 177 Posts
  • 40 Reply Likes
First evaluation of the DigestManager.dontCalculateDigest - flag is positive!
Until now no crash for an hour.

Can anybody explain what this flag changes in Lightrooms image processing?
Photo of Cathy Dixon Knight

Cathy Dixon Knight

  • 2 Posts
  • 0 Reply Likes
So now I guess you have to be a computer file expert to even use the new updates. Every time LR updates I get these ridiculous problems. And I have a very fast processor and lots of RAM - custom build at work. It's a little crazy that they can't just fix this in a bug fix update. It's been well over a month.