Lightroom Classic 7.0.1: Error switching modules after deleting rejected photos in Develop

  • 1
  • Problem
  • Updated 2 years ago
  • (Edited)
Yes. This problem was fixed in some earlier versions of Lightroom, but appears to have resurfaced in Lightroom Classic. I just reproduced it in Lightroom Classic CC 7.0.1 on MacOS X 10.12.6 (Sierra).

Adobe's support team on Twitter have denied that the problem exists, but I can reproduce it reliably on my system.Note: This conversation was created from a reply on: Lightroom: Deleting rejected photos while in Develop doesn't work.

Lightroom reports "Error changing modules" after rejected photos are deleted while in the Develop. STEPS TO REPRODUCE

1. Launch Lightroom.

2. Switch to Develop.

3. Flag 1 or more photos as Rejected.

4. Choose "Delete Rejected Photos" from "Photo" menu.

5. Switch to Library.

EXPECTED BEHAVIOR

Switch to Library should work correctly.

ACTUAL BEHAVIOR

Lightroom displays a dialog reading "Error changing modules". Thereafter, the app is in an inconsistent state; no photographs are displayed in the Library module, and choosing "Quit" causes the app to exit without the normal prompts to back-up the catalog etc.
Photo of Angus McIntyre

Angus McIntyre

  • 2 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 16406 Posts
  • 2616 Reply Likes
Official Response
I can reproduce and will log a bug for the eng team. Thanks.
Photo of keskasay

keskasay

  • 22 Posts
  • 4 Reply Likes
Just happened  to me.  Current LR Classic CC.
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 5486 Posts
  • 2188 Reply Likes
There's another new Classic bug on error changing modules too, which isn't specific to Delete Rejected Photos, but could be related. https://feedback.photoshop.com/photoshop_family/topics/changing-modules-error