Lightroom Classic: Very slow on High-end PC

  • 18
  • Question
  • Updated 5 hours ago
  • (Edited)
Hi guys,

I'm little bit disappointed and frustrated so i would like to know if somebody have the same problem.

Last week I build new PC for my photo editing ( Lightroom and Photoshop ) and little video in the future ( Premiere pro ). Here is my computer :

Windows 10 Pro
Processor : I7 7700k Kaby Lake OC  4.8 GHZ + Noctua ND-H14
Motherboard : MSI Z270 Gaming Pro Carbon
Graphic Card : Nvidia Gigabyte G1 GTX 1060 6GB
Memory : 64G Corsair Vengeance LPX 2400 MHz ( 4 x 16GB )
Disk 1 ( Windows + programs + Cache ) : Samsung 960 M.2 NVMe 500 GB
Disk 2 ( Working files - Photo and video ) : Samsung 960 M.2 NVMe 500 GB
Disk 3,4,5 ( Backup ) : WD Black 4TB + WD RED 4TB + WD RED 3TB
Power : XFX 750 PRO
Wacom Intous Pro

Monitor 1 : Dell 2007WFP 21"
Monitor 2 : Benq BL3200 32"
Monitor 3 : Dell U2713HM 27"

I was trying to get everything right for fastest workflow in Lightroom and Photoshop. The Samsung 960 disks are one of the fastest on the market. One of the disk is just for Windows + Programs + Catalog + Cache and I have around 400G free space. The other is just for Working files ( photos and video ). 

Disk are working good and everything works fast EXCEPT Lightroom and i am getting desperate. 
1. Crop tool is choppy and slow ( little bit better when GPU acc. is turned off )
2. Switching between photos in Develope mod is very very slow ( 2-3 sec )
3. Radial filters are slow
4. Brushes are slow
5. Synchronizing is slow
The only thing that is ok is EXPORT and IMPORT of the photos.
Everything is so choppy and slow that is driving me crazy. I have newest drivers for everything  and I tried last 3 versions of Lightroom 6 and it's the same.

GPU option is turned on ( it's even slower with it ) , i have 250 GB free for Camera raw cache, I imported 1:1 previews + Smart previews.

When i work the processor and ram usage is around 30-50 %. I know that Lightroom is programmed for 10 years old computers and it's badly optimized but this is awful,

Does anybody have the same problems?

Thanks

Photo of Kanaye Shogun

Kanaye Shogun

  • 14 Posts
  • 3 Reply Likes

Posted 1 year ago

  • 18
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1335 Posts
  • 379 Reply Likes
Official Response
If you are an existing Lr Classic CC customer, and would like to test out a developer preview build that we think fixes this performance issue. Please send me a note and I'll make sure that you are invited to the prerelease program. Thanks.