Lightroom CC: Syncing stuck forever

  • 37
  • Problem
  • Updated 2 months ago
  • In Progress
  • (Edited)
Since I imported all my photos to the cloud with new Lightroom CC, there are 3 photos stuck in sync. Cloud icon still says it's syncing 3 photos for two days now. I can see this only on my computer with source files so I just guess it's something stuck in uploading. But I can't see what pictures and why are they stuck. If I add another photo, it syncs instantly with those 3 still remaining.
Photo of Jaroslav

Jaroslav

  • 68 Posts
  • 20 Reply Likes
  • frustrated

Posted 2 years ago

  • 37
Photo of Morten Mitchell Larød

Morten Mitchell Larød

  • 18 Posts
  • 9 Reply Likes
Mine was stuck at one photo for a long time. Now all is ok :-)
Photo of Jaroslav

Jaroslav

  • 68 Posts
  • 20 Reply Likes
Still stuck here. I did not manage to fix this yet.
(Edited)
Photo of Markus H.

Markus H.

  • 4 Posts
  • 8 Reply Likes
same problem here. stuck with ONE photo...
Photo of David Scheibler

David Scheibler

  • 4 Posts
  • 0 Reply Likes
Same here, stuck with 12 photos not syncing. In LR CC Classic you can at least see which pictures don't sync but in LR CC there isn't such an option anymore. 
Photo of Marcos Duran

Marcos Duran

  • 3 Posts
  • 2 Reply Likes
Same here stuck with 43 photos. Restarting CC does not help. Why isn't there a report bug feature beyond a stupid web form? You could be getting logs from us instead of HTML.
Photo of Matthias Kellermann

Matthias Kellermann

  • 4 Posts
  • 2 Reply Likes
Same here. Stuck with 219 photos (from a total of 36.478). Synching now for 2 days without a break. Is there a log or debug mode to see which photos are causing the problem?
Photo of Hannes Hess

Hannes Hess

  • 28 Posts
  • 3 Reply Likes
Stuck with 33k photos and never before so frustrated with Adobe Lightroom CC is a huge joke. And the worst thing is that I can even not reset all this stupid migration and start over. 
It says that LC CC was built from scratch but apparently no one bothered to check for quality. Just releasing a buggy beta version is a joke
Photo of Pedro Brandão

Pedro Brandão

  • 1 Post
  • 0 Reply Likes
Hey. stuck here with 36K photos mid migration. Have you managed to solve the problem?
Photo of Markus H.

Markus H.

  • 4 Posts
  • 8 Reply Likes
is there anyone from Adobe support active in this forum? it seems that the "community" cannot solve this issue, because it ́s a BUG! selling a costly subscription but not being willing to provide any kind of support is a joke...
Photo of Marquis Murray

Marquis Murray

  • 2 Posts
  • 1 Reply Like
Same here. Stuck at 216. New files sync but take much longer than they should...need a fix ASAP!
Photo of M Schr

M Schr

  • 2 Posts
  • 1 Reply Like
First of all, sorry for my bad englisch!
same here. stuck at 4 Fotos (from 16.500). Found by accident 2 of this 4 fotos.
Information (Sync Status) to this 2 Fotos:
Metadata will sync
Local: Original File (Originaldatei)
Cloud:  pending (Ausstehend)

It seems that the "Metadata" are the cause of this Problem.
Only Adobe support can solve this issue (Tank you)
Photo of Kumar Pallav

Kumar Pallav

  • 2 Posts
  • 1 Reply Like
Same thing here stuck with 106 photos :(
Photo of Benjamin Poiesz

Benjamin Poiesz

  • 7 Posts
  • 3 Reply Likes
Piling on, I'm also stuck indefinitely syncing with no apparent way to understand why. 
Photo of Geoffrey Anderson

Geoffrey Anderson

  • 6 Posts
  • 2 Reply Likes
Same here. I used to have 141 'stuck' photos, but cleaning up the keywords got that down to 1. For the last 6 days, I still have one image that isn't syncing. Maddening to say the least
Photo of Peter Susan

Peter Susan

  • 1 Post
  • 0 Reply Likes
I'm having this issue also... Kind of. I've migrated around 30k pictures into the new Lightroom CC. It stopped syncing after doing 16k of the pictures. For 2 days it has not been able to move forward. Right now, if I exit Lightroom and restart it, it won't even show me my locally stored pictures. If I restart the whole Mac, after a few relaunces of the application, it shows me my albums and picture counts, but the sync still not continues.

On other devices I have, I'ts working, I can browse the 16k synced pictures, but I'm missing the other half and can't get it synced.

Really weird and scary. I generated a full debug report, but I don't know where to send it actually :)
Photo of Baywolf

Baywolf

  • 1 Post
  • 0 Reply Likes
Also stuck with one photo for two days overnight. I don't see any meaningful network activity or disk activity. Logs would be helpful to debug. Or even showing the active photos that are syncing in the UI.
Photo of Markus H.

Markus H.

  • 4 Posts
  • 8 Reply Likes
I have re-posted our problem in the Adobe support forum. please like/follow so we finally might get attention from someone at Adobe support one day..

https://forums.adobe.com/message/9962560#9962560
Photo of Alessandro Castagnini

Alessandro Castagnini

  • 11 Posts
  • 3 Reply Likes
From the software preferences, can you see something in this area?
Photo of Markus H.

Markus H.

  • 4 Posts
  • 8 Reply Likes
are you using cc or classic?
Photo of Benjamin Poiesz

Benjamin Poiesz

  • 7 Posts
  • 3 Reply Likes
This post was for CC (not classic) so the above screenshot isn't really applicable.

Whoever named these needs their head examined...
Photo of Alessandro Castagnini

Alessandro Castagnini

  • 11 Posts
  • 3 Reply Likes
Ops...  sorry ....
yes some confusion on the names...

Than I guess you're talking about this sync window:
(Edited)
Photo of Rick Spaulding

Rick Spaulding, Champion

  • 564 Posts
  • 234 Reply Likes
Official Response
I'm sorry you all are having difficulty syncing. Try these steps and let us know it helps:

  1. In the My Photos area in the left pane, select the All Photos album.
  2. Switch to the Square Grid view (), which displays photos as equal-sized thumbnails along with their flag status, sync status, and rating.
  3. While holding down the Alt key (Win) or Option key (Mac), click the cloud icon (). Lightroom CC now displays only those photos that it's trying to sync.
  4. Press Ctrl+A (Win) or Command+A (Mac) to select all the photos displaying in the grid and then do any of the following:
    1. Delete the selected photos by choosing the Edit > Delete option and then add the photos in Lightroom CC again.
    2. Apply a flag or a star rating to selected photos.

The syncing issue should now be resolved. To check the sync status, click the cloud icon () at the upper-right corner. 

Photo of Daniel Landry

Daniel Landry

  • 3 Posts
  • 2 Reply Likes
I do Steps 1, 2, 3 but no photos are shown after this so I cannot proceed to Step 4.  I have 1 Photo showing in perpetual Sync, but none according to Lightroom as shown after Step 3.
Photo of Robert Brandt

Robert Brandt

  • 3 Posts
  • 1 Reply Like
Rick / Adobe,
Could you please share where the Cloud Icon is in desktop Mac Lightroom Classic CC ? Have you tried to copy images of this icon in your post as they are just blank boxes. I’m not seeing a cloud icon in the latest version of Lightroom on my desktop. I’ve tried all the steps above a few times and still not not syncing, it just sits on the same numbers.

My problem is: I travelled across Europe for six weeks and took 10,000 photos on three SD cards (500GB). Each day I would upload the 500 or so images into Lightroom Mobile on my iPad Pro and make edits. Now back home i’m trying to sync the edits back to my desktop external hard drive and Lightroom classic CC.

Question for Rick/Adobe about Lightroom, can I sync the edits from Lightroom mobile to images copied to my desktop from the SD cards? As i’ve tried syncing through the cloud but as you can imagine moving 500GB of data is laboriously slow and even worse it has stopped syncing after 10 hours. I’ve deleted sync errors and tried all the steps above and still not syncing. I have 5700 ‘All Synced’ into desktop Lightroom classic CC, but stuck on ‘Syncing’ 7400, while my iPad Lightroom mobile is still uploading 10,030 (of the original 10,174). While stuck I even uploaded (pretty quickly I must say!) all the photos directly from the SD cards to my Mac desktop and Lightroom classic CC without the edits. Of those images that have sync across also brought another 40MB ‘copy’ of each RAW photo file. So now I also have 6000 ‘synced duplicates’ in desktop Lightroom classic CC.

While traveling I figured out pretty quick that the 2TB cloud subscription was a waste of time as it takes forever even on the fastest internet service to upload 20, 50 or not to mention the total 500GB of photos.

Many thanks for a reply and solution to this problem.

Photo of Heather Burky

Heather Burky

  • 1 Post
  • 0 Reply Likes
Mine shows no images at all so there is nothing to select. Everything was fine until the power in my house went out while I was importing photos into LR. I can't see any information at all other than the blue circle spinning in the middle of the screen and in the cloud icon. Please help. I really need this resolved asap.
Photo of John Saxon

John Saxon

  • 2 Posts
  • 0 Reply Likes
This suggested solution didn't work. When I click on the cloud and get the little dialog it shows everything to be OK. I still have the perpetual syncing 1 photo in LR Classic. I also tried "Rebuilding Sync Data" in the LR Classic preferences. Didn't work.
(Edited)
Photo of Michelle Holcomb

Michelle Holcomb

  • 4 Posts
  • 0 Reply Likes
I am afraid to delete all the photos because I dont want to lose them!
Photo of Marquis Murray

Marquis Murray

  • 2 Posts
  • 1 Reply Like
FINALLY! Thank you!!!
It worked.
Photo of Rick Spaulding

Rick Spaulding, Champion

  • 564 Posts
  • 232 Reply Likes
Woo hoo!!!
Photo of Matthias Kellermann

Matthias Kellermann

  • 4 Posts
  • 2 Reply Likes
yeay!
Photo of Benjamin Poiesz

Benjamin Poiesz

  • 7 Posts
  • 3 Reply Likes
Yeah! worked too. Thanks.
Photo of Pierre Fortin

Pierre Fortin

  • 10 Posts
  • 2 Reply Likes
Yeeeesssss it worked, I can go to bed now, I din't sleep for many days 

Thanks
Photo of jproudfo

jproudfo

  • 4 Posts
  • 8 Reply Likes
I'm in a similar situation...  I'm trying to sync 88,000+ photos and most of them seemed to upload fine. It's been stuck at 87 remaining for over a week, though.  I've tried the recommendations from the thread, but they don't seem to work.  I've tried to delete the stuck photos, but they never actually get removed from the library.  I've also changed the metadata, but it doesn't seem to help.  I've contacted Abobe support and their best advice was to point me at this thread.  It's a little frustrating.
Photo of Pierre Fortin

Pierre Fortin

  • 10 Posts
  • 2 Reply Likes
It is frustrating, I agree.

I had 877 photos stuck in that sync pending, the thing I do to fix my problem, I take the #2 : with the star. I forgot to explain witch one I use in my answer.

Good luck
Pierre
Photo of Jun Yan Lee

Jun Yan Lee

  • 1 Post
  • 0 Reply Likes
Is there another solution? I tried the above and its still stuck... This is getting frustrating.
Photo of Brent Sinclair

Brent Sinclair

  • 4 Posts
  • 2 Reply Likes
Update: Resetting my network adapter, all IP settings, sockets etc. etc. + adding key words (not stars/flags) worked.  Hardly a controlled experiment, because I tried all of those things simultaneously!
Photo of Geoffrey Anderson

Geoffrey Anderson

  • 6 Posts
  • 2 Reply Likes
Rick,
I tried this before and after the latest update (installed today), and no satisfaction. I still have 1 stuck photo that perpetually is syncing.
Photo of John Saxon

John Saxon

  • 2 Posts
  • 0 Reply Likes
I tried all the suggestions and nothing worked. So I reset all sync data (in LR Classic) which is starting over with the syncing. This finally got rid of the perpetual "syncing 1 photo." Now I will pay attention whenever syncing photos and see if it gets stuck. At least that will narrow down where the problem is.
Photo of Michelle Holcomb

Michelle Holcomb

  • 4 Posts
  • 0 Reply Likes
John - how did you reset all the sync data?
Photo of Michelle Holcomb

Michelle Holcomb

  • 4 Posts
  • 0 Reply Likes
Actually - mine seems to be fixed now and here is what I did - logged into the adobe website and logged out of all open sessions, ALL of them. Then logged BACK in on Lightroom CC, Lightroom Classic, and LR for iPad. Syncing now progressing normally, and file numbers declining in the que. Maybe it is that simple?

https://account.adobe.com/sessions

(Edited)