Lightroom CC: Stuck at 4 photos remaining to sync

  • 1
  • Problem
  • Updated 3 months ago
  • (Edited)
* I migrated ~65000 photos from Lightroom CC Classic. Everything fine expect that 4 photos still shown as syncing. Photos are not shown in the filter (i.e. All Photos -> Filter -> Sync Status =Syncing gives zero results).
* I decided to delete local catalog on MacOS and re-sync from cloud. This helped for a day (sync was complete and only new changes were syncing).

Then after some manipulations with photos I see those 4 unknown photos "in sync" again. Other than that, sync is fine.

Desktop photo count: 65924
Web photo count: 65924 (no sync activity, no sync problems shown)
Android app photo count: 65922 (? - was the same count at some point)

macOS High Sierra 10.13.6
Lightroom CC version 1.4

I use local storage for original photos on NAS and store all smart previews on local HDD.

How do I resolve that 4 photos stuck in sync?
Photo of Alexey Ignatenko

Alexey Ignatenko

  • 9 Posts
  • 2 Reply Likes
  • confused

Posted 3 months ago

  • 1
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 4286 Posts
  • 816 Reply Likes
Alexey, try updating to 1.5, released earlier today and see if your remaining stuck images finally sync. Let us know what you see please. 
Photo of Alexey Ignatenko

Alexey Ignatenko

  • 9 Posts
  • 2 Reply Likes
Dear Rikk!

I've updated to 1.5 and see no changes in this behaviour - still 4 photos in sync, unfortunately :(

BTW, I generated a diagnostic report, noticed it has some interesting lines:

Metadata Sync Down: 53891242f08449a39910d2688c7994b1
Metadata Sync Down: f270b1c513494be08836d593cd1d6363
Metadata Sync Up: 53891242f08449a39910d2688c7994b1
Metadata Sync Up: f270b1c513494be08836d593cd1d6363






Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 4286 Posts
  • 816 Reply Likes
After the 1.5 update, your syncing filter still shows zero results as well?
Photo of Alexey Ignatenko

Alexey Ignatenko

  • 9 Posts
  • 2 Reply Likes
Done. LrDiagnostics.zip has been automatically uploaded to my CC Cloud assets. Size is ~560Mb. How it is better to share a link with you? 
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 4286 Posts
  • 816 Reply Likes
Via the web interface with Creative Cloud storage, you should be able to share a folder with me. Share with 
Photo of Alexey Ignatenko

Alexey Ignatenko

  • 9 Posts
  • 2 Reply Likes
Invited you to the folder. Thanks for the support!
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 4286 Posts
  • 816 Reply Likes
Alexey, 

The engineers have reviewed your log and identified the issue. To get you going while a permanent fix is deployed, they've created a script for your catalog that should clear up the issue. 

With Lightroom CC closed:

1. Go to the Creative Cloud folder where you've previously shared your diagnostic log. 
2. Grab the "Fix Stuck Sync.lua" file I just placed there. 
3. Place a copy of the file into the ~users\user name\Library\Application Support\Adobe\Lightroom CC\Scripts folder (Create the Scripts folder if it doesn't exist already)
4. Launch Lightroom CC - the script should run automatically if it is in the right place. 

Note: This script is custom - for your catalog only and will not work with other catalogs. 
Photo of Alexey Ignatenko

Alexey Ignatenko

  • 9 Posts
  • 2 Reply Likes
Thanks, the script works! Now I'm synced and backed up :)