Lightroom CC: Slideshow Module takes over selected display monitor until LR is closed

  • 3
  • Problem
  • Updated 4 years ago
  • Solved
  • (Edited)
The preview works correctly except that the intro screen is never displayed during preview and occasionally is swapped with the ending screen, however, the main issue happens when you press "Play" and the slideshow appears on the selected monitor, it stays there after any interruption of the show and even upon completion.

Changing modules does not clear the display. Only exiting Lightroom.

Also, if you stop the show, make a change and start it again, there is occasionally a dialog box that is displayed behind LR which requires the program to be stopped through the Windows Task Manager because LR is waiting for the modal dialog to be satisfied.

I am running an ATI Radeon 6800 HD (2GB) PCI-E Display Adapter with the latest drivers on Windows 7 Premium with the latest service packs and all updates on a Quad Core AMD FX PC with 16GB RAM.

This issue did not exist with LR 5.7.

Thanks!
Photo of Mike McCarthy

Mike McCarthy

  • 7 Posts
  • 0 Reply Likes

Posted 4 years ago

  • 3
Photo of Yuhong

Yuhong, Employee

  • 95 Posts
  • 5 Reply Likes
Does that hang problem happen frequently? And, how many photos are you using when you start to play the slideshow?

Would you be able to update the graphic driver from AMT’s website and restart the computer . This will probably solve the hang problem.
Photo of Mike McCarthy

Mike McCarthy

  • 7 Posts
  • 0 Reply Likes
The problem happen *every* time the slideshow runs, with as little at 1 image or as many as 200.

I have the latest driver available - released with the last 2 weeks - and there are no additional beta or test versions for my card.

I have also uninstalled the video driver, reverting back to the standard SVGA defaults, cleaned the driver using an AMD utility, and done a clean install. Still no difference.
Photo of Alexander Kozhekin

Alexander Kozhekin

  • 19 Posts
  • 1 Reply Like
Have similar problem: Screen remains black after playing slideshow.
ATI video-card with latest drivers, Windows 7. I do Ctrl-Alt-Del - task manager - switch back to Lightroom.

Someone also have this problem seems similar:
http://feedback.photoshop.com/photosh...
Photo of Wolfgang Eilers

Wolfgang Eilers

  • 51 Posts
  • 1 Reply Like
Yes this is a similar problem to the one I reported earlier. I have confirmed that playing a full screen slideshow gets "stuck" and can't be quit (unless forcing quit with Ctrl+Alt+Del) on Win7 machines running either Lr CC or Lr 6. It's got nothing to do with graphic drivers since I do not run with the GPU enabled. It might be a Windows only bug. It can happen with only a single image in the slide show.
Photo of john beardsworth

john beardsworth

  • 1211 Posts
  • 308 Reply Likes
If you Ctrl+Alt+Del and then immediately cancel Task Mgr (without killing LR), is LR returned to normal?
Photo of Mike McCarthy

Mike McCarthy

  • 7 Posts
  • 0 Reply Likes
Actually, yes Alexander, this works. I tried the 3-finder salute but never thought to just exit, I always selected task manager, which ended up leaving the screen unavailable. Ctrl-Alt-Delete and then Esc clears the window without having to shut down LR. Good catch!
Photo of Alexander Kozhekin

Alexander Kozhekin

  • 19 Posts
  • 1 Reply Like
Yes
Photo of John Ellis

John Ellis

  • 117 Posts
  • 12 Reply Likes
Does full-screen preview (type "F" in Library mode) also get stuck? If so, your problems might be related to these people's: http://feedback.photoshop.com/photosh...
Photo of Wolfgang Eilers

Wolfgang Eilers

  • 51 Posts
  • 1 Reply Like
I have no problems with full screen preview. I'm wondering if the full screen slideshow "stuck" issue is related to multi-monitors. Both I and a friend have dual monitor set-ups and we both exhibit the slide show issue.
Photo of Mike McCarthy

Mike McCarthy

  • 7 Posts
  • 0 Reply Likes
No, it doesn't. Full screen mode, on it's own, works just fine.
Photo of Yuhong

Yuhong, Employee

  • 95 Posts
  • 5 Reply Likes
Would it be possible that you create a screen-shot if you observe the dialog box is displayed? It will be very helpful. Thank you!
Photo of Alexander Kozhekin

Alexander Kozhekin

  • 19 Posts
  • 1 Reply Like
I do not have any dialog. Slideshow after it ends is stack at black screen (or if stopped in the middle of slideshow ) and does not react to any keyboard keys, except of Ctrl-Alt-Del. After that all returns to normal.
Photo of Mike McCarthy

Mike McCarthy

  • 7 Posts
  • 0 Reply Likes
Unfortunately, no. I've tried. Using Windows' "PrtScrn" displays a blank screen - I suspect because the slideshow uses a different video mode, outside the standard Windows 2D desktop.

I also tried using Screen Hunter, but it will not capture either of my additional displays, only display 1.

As noted above, pressing Ctrl-Alt-Del and then Esc clears the screen and returns operation to normal without shutting down LR.
Photo of Yuhong

Yuhong, Employee

  • 95 Posts
  • 5 Reply Likes
Which graphic card are you using now and what's the driver version?
Photo of Benjamin Warde

Benjamin Warde, Employee

  • 486 Posts
  • 77 Reply Likes
Official Response
This is fixed in Lightroom 6.2 which is available today. (Actually, it was fixed in Lightroom 6.1.1, I apologize for not updating the thread earlier.)

Thanks,
Ben