Lightroom Classic: Sees my cameras, but not the photos on them

  • 2
  • Problem
  • Updated 6 months ago
  • Solved
  • (Edited)
Suddenly my LR CC running on iMac and newest macOS Catalina 10.15.2, refuses to locate photos on my Nikon D850. ( the same goes if I connect my iPhone 11Pro, and want to import photos from that unit).
LR will see the camera, but claims there are no photos. Taking the memorycard into cardreader, there is no problem.
if i start Photoshop instead, camera and photos are found!!!
i have the LR CC version 9.1 and camera raw 12.1
about one week ago it was all fine
suppose its a bug
kind regards
palle jensen
Photo of Palle Jensen

Palle Jensen

  • 7 Posts
  • 1 Reply Like

Posted 8 months ago

  • 2
Photo of Sunil Bhaskaran

Sunil Bhaskaran, Official Rep

  • 490 Posts
  • 179 Reply Likes
This looks like a permission issue happens with MacOS Catalina 10.15.2.
When you install Lightroom Classic 9.1 and open it for the first time, it should ask permission for accessing the Photos app.
Did you see it?
Go to System Preferences > Security & Privacy.
In the Privacy tab, select Security.
Does Lightroom Classic has permission assigned to Photos, Full Disk Access, and Files and Folders?

Downgrading Lightroom Classic will not help.
(Though it may not work,) could you please install Lightroom Classic 9.1 again and see if there is any change?

Thanks,
Sunil
Photo of John Hamill

John Hamill

  • 1 Post
  • 0 Reply Likes
This solved my problem as well.  Many thanks!
Photo of maryanne innes

maryanne innes

  • 1 Post
  • 0 Reply Likes
Going into Catalina's system preferences> Security and Privacy > and giving permission to Lightroom solved my problem go Lightroom not recognizing my SD card in the Apple SD card reader to USB C. I was getting the message that there were no photos but once I gave permission to Lightroom in the Security and Preferences area of System Preferences the photos were recognized. Thank you so much Sunil Bhaskaran for your post above - it solved a complex issue for me.