Lightroom Classic: Photos not Exporting with Watermark

  • 1
  • Problem
  • Updated 1 month ago
  • Solved
  • (Edited)
I have Lightroom CC and Windows 10 on my laptop. I can do everything as normal including creating and editing my watermark. However, when I try to export the photo with the watermark, it will not work.  The phot exports to the designated folder with no watermark.  This is very frustrating. I cannot share my photos on social media until I can watermark them.  Please help!
Photo of Crystal Campbell

Crystal Campbell

  • 4 Posts
  • 0 Reply Likes

Posted 1 year ago

  • 1
Photo of Glenbo

Glenbo

  • 81 Posts
  • 11 Reply Likes
Double check that your water mark is in a compatible format A PNG or JPG, I'd recommend a PNG as it supports transparency!
Photo of Crystal Campbell

Crystal Campbell

  • 4 Posts
  • 0 Reply Likes
I used Lightroom to create the watermark.
Photo of Glenbo

Glenbo

  • 81 Posts
  • 11 Reply Likes
LR offers two variants in the Watermark options Text based or images based (for if you use a logo) it should run fine unless there is a corrupted font or graphic?
Photo of John R. Ellis

John R. Ellis, Champion

  • 3869 Posts
  • 1023 Reply Likes
Which program are you using to view the exported photos?
Photo of Crystal Campbell

Crystal Campbell

  • 4 Posts
  • 0 Reply Likes
I have Windows 10, so whatever viewer comes with that is what I use. It does have the smart ink, so I can draw or write on the image. I'm new to Windows 10, so I'm not that familiar with all the programs it comes with.
(Edited)
Photo of Glenbo

Glenbo

  • 81 Posts
  • 11 Reply Likes
Try opening one of the exported JPEGS in Internet explorer to check that you are not falling foul of the bug below?
Photo of avpman

avpman

  • 96 Posts
  • 63 Reply Likes
Simple, but possibly overlooked, are you sure the watermark box is checked (the sample below is not checked?) It's at the very bottom of the export dialog box:

Photo of John R. Ellis

John R. Ellis, Champion

  • 3869 Posts
  • 1023 Reply Likes
If you've double-checked that the Watermark export option is checked:

If you're using Windows File Explorer to examine the photos, that won't show the watermark.  (Other file browsers may not either.)  This is due to a bug in LR, where the watermarks are not included in the thumbnail JPEGs embedded in the file: https://feedback.photoshop.com/photoshop_family/topics/lightroom-watermark-omitted-from-embedded-thu...

In File Explorer, double-click on the photo to view it at full size to see if the watermark is really there.
Photo of Crystal Campbell

Crystal Campbell

  • 4 Posts
  • 0 Reply Likes
Thank you all for your help. I have Explorer Edge and not the older IE. I've come to the conclusion that LR is simply not compatable with Windows 10 & Explorer Edge as far as the watermark is concerned. However, I solved my issue by making my own watermark in Illustrator, and then uploading it as a PNG image instead of using the LR text watermark. Again, thank you all. =)
(Edited)
Photo of ShaneImages

ShaneImages

  • 31 Posts
  • 3 Reply Likes
I can't check the watermark button in lightroom classic cc...it won't let me add a watermark. It use to work just fine, but I've been using Lightroom CC and havent tried in a few updates.
Photo of Matthew Oakley

Matthew Oakley

  • 1 Post
  • 0 Reply Likes
Yeah, watermark doesnt show up in the windows viewer, IE, or Photoshop for me either. Im running windows 7.
Photo of Robert Cullen

Robert Cullen

  • 157 Posts
  • 44 Reply Likes
I have Windows-10-Home and LR-Classic7.4I have no problems adding a Graphic watermark to an exported JPG file, and it is visible in Windows File Explorer Large Icons, and the Preview pane.I would be interested to know the full procedure that @ShaneImages and @Matthew Oakley are using to Edit their watermarks and how the Export dialog is defined.


Questions like-
What font are you using?
Is your watermark made with Text or a Graphic?
What size have you defined the watermark?
Do you actually save the Watermark as a preset?
Is it visible in the list of available watermark presets in the Export dialog.?
Do the exported files show the watermark when opened with Photoshop, or another editor?
(Edited)
Photo of ShaneImages

ShaneImages

  • 31 Posts
  • 3 Reply Likes
Oh, it works, I think this was an old problem I had....I've been using graphic watermarks for a while. I hope cc gets em soon too!
Photo of Pablo Silva

Pablo Silva

  • 1 Post
  • 0 Reply Likes
I FOUND MY PROBLEM WAS THAT IN THE EXPORT WINDOW FILE SETTINGS WAS SET TO ORIGINAL AND NOT JPEG. ONCE I CHANGED TO JPEG THE WATERMARK BOX WASN'T GRAYED OUT AND I CAN EXPORT WITH MY WATERMARK