Lightroom CC, painfully slow across the board on my system

  • 2
  • Problem
  • Updated 3 years ago
  • (Edited)
First off, let me inform regarding my system specification. I am running on fifth gen i7, 16 GB ram, 1 TB SSD, and ATI Radeon R7 265 as GPU. The screen resolution for my system is UHD or 4K.

I am experiencing extremely slow operations in previewing photo and developing photo. So slow that it has made my productivity suffers greatly. Now, it is painfully slow whether I enabled GPU acceleration or not.

Is this a software glitch and that it's not fully optimized yet or should I expect it to perform like this for the foreseeable future so I can cancel my subscription?
Photo of Chaitee Tandhanskul

Chaitee Tandhanskul

  • 2 Posts
  • 0 Reply Likes
  • frustrated

Posted 3 years ago

  • 2
Photo of James Harper

James Harper

  • 4 Posts
  • 0 Reply Likes
Try reducing the Reduce the Lightroom.exe process priority to "Below Average". I know i sounds counter intuitive but if its the issue it sounds like then should solve the issue.

I just posted this, might help

http://feedback.photoshop.com/photosh...
Photo of Matthias Henze

Matthias Henze

  • 13 Posts
  • 0 Reply Likes
Wow, thanks ... LR CC is nor FAR more rsponsive, nearly as fast as LR5 used to be! Thank you!
Photo of Randall Wade

Randall Wade

  • 1 Post
  • 0 Reply Likes
How do you reduce the "lightroom process" to below priority?
Photo of Matthias Henze

Matthias Henze

  • 13 Posts
  • 0 Reply Likes
Start LR, got to task manager, go to processes, find LR, right mouse click LR, at process priority choose "Below Average". You have to do this after each start up of LR. Or see this post:

http://feedback.photoshop.com/photosh...