Lightroom CC: Now takes 5 mins to load

  • 2
  • Problem
  • Updated 1 year ago
  • (Edited)
I have a fast work PC with CC installed and until recently all CC apps would load immediately. After updating LightRoom CC to version 2.2, the app now takes 5-10 minutes to load. Nothing has changed in the work environment. Any ideas?
Photo of Paul Mills

Paul Mills

  • 3 Posts
  • 0 Reply Likes
  • frustrated

Posted 1 year ago

  • 2
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 7591 Posts
  • 1731 Reply Likes
Do you see any loading messages during the time period? Is the app responsive during the 5-10 minutes or totally frozen?

Does it happen every time you launch or just some of the time?
Photo of Paul Mills

Paul Mills

  • 3 Posts
  • 0 Reply Likes
Hi - no loading messages at all. I simply have an empty screen. So despite the app appearing to be live, I cant import any photos at all. The plus icon (top left) is grayed out and not responsive. Nothing has changed on my computer. Until the update to version 2.2, the photo library was immediately available upon opening the app. Now it takes between 5-10 minutes until the photo library appears and only then can I import new photos. I have read blog posts from earlier versions about changing various options in the performance menu - but in the latest version, most options are no longer available. It is really infuriating!!

Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 7560 Posts
  • 1730 Reply Likes
What version did you have before? Did you update from 2.1 to 2.2 or from an older version to 2.2?
Photo of Paul Mills

Paul Mills

  • 3 Posts
  • 0 Reply Likes
From 2.1
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 7560 Posts
  • 1730 Reply Likes
If you disable internet on your computer does it load more quickly?