Lightroom CC: Map module won't load

  • 1
  • Question
  • Updated 1 year ago
I am still having this problem. It's 2017, and Creative Cloud says my Lightroom version is up to date, and my map is not loading.

Note: This conversation was created from a reply on: Lightroom 6.2: Map Module won't load.
Photo of Dianna McMenamin

Dianna McMenamin

  • 2 Posts
  • 0 Reply Likes

Posted 1 year ago

  • 1
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14049 Posts
  • 1735 Reply Likes
What OS/version are you running Lightroom on? Do you get an error?
Photo of Dianna McMenamin

Dianna McMenamin

  • 2 Posts
  • 0 Reply Likes
I'm on Mac OS 10.12.2, and Lightroom CC 2015.8 release. This has been happening periodically for about a year, across several LR updates, and three computers, the first of which was on, I think, Mac OS 10.9. At first it happened when I was working at a coffee shop, so I initially thought it might have something to do with network speed; but lately it's been happening at home too, where there aren't a million other people competing for bandwidth, so that's not it.

When this happens, sometimes it says "Map module is offline" (or something similar; it's OK at the moment, so I don't see the actual words) and sometimes it doesn't display an error message, but just shows me a blank area where the map should be, or it shows me a nighttime image of the whole earth. Oddly, the navigator panel is often displaying properly when this happens.