Lightroom CC/Camera Raw : Lens Metadata Problem

  • 2
  • Problem
  • Updated 1 year ago
  • (Edited)
Hi, 

I have a problem with lens metadata which I hope somebody can help me fix.

I know there was a bug way back in Lr CC 2015.5 which resulted in 'unknown lens' appearing in the Library module Lens metadata field; and am aware of the fix - but that only brings up the focal length range and max aperture. For example, my Sigma 105mm lens shows up as 105mm f/2.8. Whilst this is accurate it is incomplete and causes confusion with a borrowed Micro-Nikkor 105mm f/2.8 AFS VR which, in the Library module show up exactly the same as the Sigma! I need to be able to view my images by lens used - hence my problem.

Interestingly, in the Develop module, under Lens Corrections, the lenses are identified correctly and appropriate adjustments can be applied.

Similarly, the Nikkor 35mm f/1.8 DX lens, in the Library module is identified only as 35 mm f/1.8. In the Develop module as Nikon AF-S DX Nikkor 35 mm f/1.8.

This holds true with my old D7000 and current D7200 & D750 camera, with Sigma and Nikon lenses. A Tamron 18-270mm I tried for a friend on my D7200 is identified fully in the Library module.

Looking back at the older images in my library (from earlier versions of Lr4) the lenses are fully named. For example, "AF-S DX Zoom-Nikkor 17-55mm f/2.8 IF-ED"

I had previously posted this in a different community as a question, which received only one reply from someone with the same issue, but no fix. Maybe it's a bug? I'm hoping for an official response form Adobe this time round.

BTW, I last imported images using Lr CC 2015.11

Thanks

Steve

Photo of nilo-uk

nilo-uk

  • 6 Posts
  • 0 Reply Likes

Posted 1 year ago

  • 2

Be the first to post a reply!