Lightroom CC got very slow recentely, both on my Windows Lenovo notebook as well as MacBook pro 2015. Now it is unusable.

  • 2
  • Problem
  • Updated 1 week ago
  • (Edited)
My Lightroom CC got very slow recentely, both on my Windows Lenovo notebook as well as MacBook pro 2015. Please Why? I have to wait for more 30 sec. to move forward in editing my photos. It is very slow when using not only the brush and heal brush but also other editing tools. Please I need to fix this as now Lightroom is unusable :-( .... Thank you, Pavel
Photo of Pavel Radkovský

Pavel Radkovský

  • 2 Posts
  • 0 Reply Likes

Posted 1 week ago

  • 2
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 5996 Posts
  • 1321 Reply Likes
What is your installed Lightroom version number on each device (Help>System Info...)
Also please include your OS version number on your Mac and Windows systems. 
Photo of Pavel Radkovský

Pavel Radkovský

  • 2 Posts
  • 0 Reply Likes
Hello Rikk, thanks for your reaction. For the Mac OS it is:

Lightroom version: 2.4.1 MAS [ 20190911-1202-844edb7 ] (Sep 11 2019)NGL Version: 1.10.0.4
Operating system: macOS
OS Version: 10.14 [6]
Application architecture: x64
Computer model: MacBookPro12,1 / Intel(R) Core(TM) i5-5257U CPU @ 2.70GHz
Logical processor count: 4
Processor speed: 2,7 GHz
Built-in memory: 8 192,0 MB
Real memory available to Lightroom: 8 192,0 MB
Real memory used by Lightroom: 1 525,6 MB (18,6%)
Virtual memory used by Lightroom: 5 928,6 MB
Memory cache size: 1 641,5 MB
Internal Camera Raw version: 11.4.1 [ 291 ]
Maximum thread count used by Camera Raw: 3
Camera Raw SIMD optimization: SSE2,AVX,AVX2
Camera Raw virtual memory: 2285MB / 4095MB (55%)
Camera Raw real memory: 2288MB / 8192MB (27%)
Displays: 1) 2880x1800

Graphics Processor Info: Metal: Intel(R) Iris(TM) Graphics 6100

Application folder: /Applications
Settings Folder: /Users/administrator/Library/Containers/com.adobe.mas.lightroomCC/Data/Library/Application Support/Adobe/Lightroom CC
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 5996 Posts
  • 1321 Reply Likes
Have you installed both of the supplemental updates for 10.14.6 from Mac?