Lightroom CC - Error while importing: Unable to create directory. You don't have permission to save the file...

  • 1
  • Problem
  • Updated 8 months ago
Cannot import photos into Lightroom CC 2.1.1 on 2017 iMac with Mojave.  I keep getting an error: "Unable to create directory. You don't have permission to save the file "2018-05-20" in the folder "2018".

I have tried with the Preference "Store a copy of all originals at the specified locaton." set to on and off.  When on, I am choosing a location that has read/write privs for everyone.

I was able to import photos to Lightroom Classic without issue.

I am truly stumped with this one.
Photo of Illyana Billups

Illyana Billups

  • 2 Posts
  • 0 Reply Likes
  • frustrated

Posted 10 months ago

  • 1
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 6027 Posts
  • 1327 Reply Likes
You likely still have a permission issue at the drive or folder level. You will need to use the Mac OS to change the permissions for your User Account for that (and perhaps other) locations. If changing doesn't work you may need to repair your permissions.  

This may be of help for Repair instructions: https://helpx.adobe.com/x-productkb/global/repair-disk-permissions-running-disk.html
Photo of Philippe Devos

Philippe Devos

  • 3 Posts
  • 0 Reply Likes
Hello, I have the same permissions issue. But the help about repairing the permissions does not fit for Mojave. Any other ways to be able importing my photos ins LR CC ?