Lightroom CC creating duplicate presets every time I restart it

  • 1
  • Problem
  • Updated 1 month ago
I'm on macOS 10.14 and Lightroom CC 2.1.1.

I recently deleted a bunch of DVLOP presets because a few of the folders had spontaneously created three or four (or more) duplicates of presets. One folder in particular had ~250 presets instead of 8, which meant about ~240 duplicate presets. Needless to say, it made the app crawl. 

After deleting all of them, I reinstalled three packs of presets, and tried to also import two sets of profiles. 

I got an error importing the profiles, saying they were already imported (even though I had just purchased a few of them and had never imported them before). 

Then I restarted LR and the duplication began. Two of the three packs I had just re-installed had duplicated themselves. 

I deleted them, then restarted LR to make sure they were gone. Two of the three were gone, but one of the folders remained.

I deleted that folder again.

Restarted. 

The folder was back, this time with another duplicate of each of the presets within. 

Some of the other folders that I had deleted are still there on my iOS version (both iPad and iPhone), except in those there are five duplicates of the presets instead of just one. 

Do I need to wipe my entire account and restart from scratch?

I've got almost 1TB of photos in LR CC right now, so if I can avoid wiping it and just wipe out the presets and profiles to start anew with those, it would be ideal. I'm not even sure how I would go about wiping my entire account either...I never thought I would have to do that, otherwise I definitely would not have imported as many photos as I did.

Any advice would be extremely helpful as this is an incredibly frustrating problem since I can't figure out what could possibly be causing it to duplicate only certain presets every time on launch.
Photo of Torbert

Torbert

  • 2 Posts
  • 1 Reply Like
  • frustrated.

Posted 2 months ago

  • 1
Photo of Torbert

Torbert

  • 2 Posts
  • 1 Reply Like
Update:

Finally was able to have Adobe support look at the problem, and I found out that because LR makes a copy of presets when imported, a copy of them was still in

~/Library/Application Support/Adobe/Lightroom CC/Develop Presets

and therefore, even though I had deleted it from within the LR desktop app, there was still a copy in that folder and LR would re-sync it and it would reappear.  
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 4680 Posts
  • 1797 Reply Likes
Odd. I'd have expected that response from Lightroom Classic, but I didn't think CC was supposed to be reading that location since the changeover last April. Thanks for sharing.