Lightroom CC crashes when trying to load a library

  • 1
  • Problem
  • Updated 3 years ago
Hi guys,

I was working on some photos (in Develop module) when Lightroom (6.4.0.10) CC crashed. After that the program did not load fully, but directly showed that the program crashed. I am using window 7 x64 OS. Here is the crash dump:

Problem signature:  Problem Event 
Name: APPCRASH
  Application Name: lightroom.exe
  Application Version: 6.4.0.10
  Application Timestamp: 56a2e8ef
  Fault Module Name: ntdll.dll
  Fault Module Version: 6.1.7601.17725
  Fault Module Timestamp: 4ec4aa8e
  Exception Code: c0000005
  Exception Offset: 0000000000052fc6
  OS Version: 6.1.7601.2.1.0.256.48
  Locale ID: 1033
  Additional Information 1: 888d
  Additional Information 2: 888dc66a722e5551370831378182ab4e
  Additional Information 3: 5925
  Additional Information 4: 59253e2735e4c22bffecb021095fbf4e

I tried renaming the catalog in Explorer to get the "missing catalog" dialog window, then selected to scan for issues, but got the same crash again. The library itself is not something particularly huge - about 35k NEF/JPEG files spread across two drives - HDD and SSD and the library database is stored on another SSD, if it makes any difference.

I tried loading another (much smaller) catalog, but got the same error.
Here is a copy of the smaller one with the temp files generated when loading: https://www.dropbox.com/s/z2j567twdf1hu33/Lightroom.zip?dl=0

Hope you could assist in losslessly resolving this issue.

Thanks,
Dimitar
Photo of Dimitar Tzankov

Dimitar Tzankov

  • 5 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 1
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1486 Posts
  • 469 Reply Likes
So the same Lr installation worked fine for you previously and it started crashing all of a sudden? 

Is there any changes to your Windows 7 machine (like Windows update, or GPU driver update) lately? It says the faulting module is 'ntdll.dll', which is a Windows component.
Photo of Dimitar Tzankov

Dimitar Tzankov

  • 5 Posts
  • 0 Reply Likes
The only change was me adding extra RAM last days, but the rest of the software has been working OK. I haven't updated any software recently.
Photo of Dimitar Tzankov

Dimitar Tzankov

  • 5 Posts
  • 0 Reply Likes
Just to note. After this RAM upgrade the program worked fine at least a few runs, where I edited several photos, totaling a few hours that LR has been up and running, until this crash.
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1486 Posts
  • 469 Reply Likes
Try holding down the Shift+Alt key when launching Lr to reset the Lightroom user preference to see if it helps.
Photo of Dimitar Tzankov

Dimitar Tzankov

  • 5 Posts
  • 0 Reply Likes
The dialogue to reset all setting showed up, but it still crashed afterwards.
Photo of Dimitar Tzankov

Dimitar Tzankov

  • 5 Posts
  • 0 Reply Likes
What fixed it was uninstall through Creative Cloud app and then re-install.

Now the old catalog is working, too... I will only need to make some settings, but that's not a big problem.

Thanks for the quick response, Simon.

The topic may be closed.