Lightroom CC Classic Very slow after update

  • 2
  • Problem
  • Updated 1 month ago
Since the last update, in both Library and Develop, about every 20 seconds Lightroom goes into a Not Responding state.  This lasts for several seconds before working again, but it is very very slow when it works in both modules.  For instance, when reviewing images to Pick or Reject, it takes between 5 and 8 seconds from an X (reject), right arrow to the next image, before it becomes active.  it's really painful.  Can anyone help?  Ive disabled my Graphics Processor, ive increased cache but to no avail.
Photo of Annette Crook

Annette Crook

  • 8 Posts
  • 1 Reply Like
  • very frustrated

Posted 5 months ago

  • 2
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 4262 Posts
  • 813 Reply Likes
Annette, that is not typical behavior. Please go to Help>System Info... and copy your exact installed Lightroom version number and paste it here. 

It would also help us to know if you are Windows or Mac and what your OS version is. 
Photo of Annette Crook

Annette Crook

  • 8 Posts
  • 1 Reply Like
Thank you.

Here is my version, which I believe is the current one.

Lightroom Classic version: 7.3.1 [ 1167660 ]


My OS is Windows 10 Home.

It's been running OK until the last update and now in both Library and Develop I get Not responding and then a several second wait - and then it clears for a minute or so - then the same again.
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 4262 Posts
  • 813 Reply Likes
Annette,

7.4 was released today. Try updating Lightroom Classic CC and let us know if it is still misbehaving afterwards.
Photo of Annette Crook

Annette Crook

  • 8 Posts
  • 1 Reply Like
I ran the update earlier and have only been using it about 10 minutes - but this now looks like it has solved the problem I was having. It's much quicker.  I'll be on it longer tomorrow to give it a full run out.
Photo of Annette Crook

Annette Crook

  • 8 Posts
  • 1 Reply Like
I've been using it now since the update and whilst it's a bit better, I'm still getting the Not Responding status in both Library and Develop.    I'm wondering as the product evolves, could it be my 8Gb RAM isn't quite enough?
Photo of Jerry Syder

Jerry Syder

  • 206 Posts
  • 100 Reply Likes
I don’t think so, or maybe but things are quite laggy - spinning circles, a lot of waiting to do things. Import and launching LR is slow and laggy while loading and getting things ready. Photo previews not rendering in thumbnails(grey squares), you name it. I’m on 32GB, Windows 10 and catalogue running off internal SSD
(Edited)
Photo of Annette Crook

Annette Crook

  • 8 Posts
  • 1 Reply Like
Not my PC then!  That does sound just like the issues I'm having.  It's painful Picking and rejecting images and I've had a load of shoots lately so lots to go through. It's very frustrating.
Photo of Annette Crook

Annette Crook

  • 8 Posts
  • 1 Reply Like
No I've got into things, its painfully slow and still getting the Not Responding.  It's at a point where I don't want to use it at all.  Please can anyone help?
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 4262 Posts
  • 813 Reply Likes
Annette, generally, the behavior you describe is not normal. Even though your system is slightly underpowered it should still function. I normally prescribe a reinstall - but in a precise way. 

1. Restart your system.
2. Uninstall Lightroom via the Creative Cloud App.
3. Restart your system a second time.
4. Wait 5-10 minutes without launching any other programs.
5. Reinstall Lightroom via the Creative Cloud App.
6. Restart your system. Launch Lightroom and wait 5 minutes after launch for all the processes to catch up.

Is your not responding message still coming up?
Photo of roland barthes

roland barthes

  • 1 Post
  • 1 Reply Like
This just began for me a couple of days ago. The import dialog used to function quickly, and previews would appear as the import progressed. I could even begin work on an image while the import was proceeding. Now import takes forever, and sometimes will not complete at all, requiring a restart and another attempt to import the images that were not imported on the first try. I am using this for professional work, and this is completely unsatisfactory. I am on the verge of moving to a different application.



Lightroom Classic version: 7.5 [ 1186149 ]
License: Creative Cloud
Language setting: en
Operating system: Mac OS 10
Version: 10.11.6 [15G22010]
Application architecture: x64
Logical processor count: 8
Processor speed: 4.0 GHz
Built-in memory: 32,768.0 MB
Real memory available to Lightroom: 32,768.0 MB
Real memory used by Lightroom: 2,034.8 MB (6.2%)
Virtual memory used by Lightroom: 1,934.6 MB
Memory cache size: 2.9MB
Internal Camera Raw revision: 1001
Maximum thread count used by Camera Raw: 5
Camera Raw SIMD optimization: SSE2,AVX,AVX2
Camera Raw virtual memory: 521MB / 16383MB (3%)
Camera Raw real memory: 522MB / 32768MB (1%)
Displays: 1) 5120x2880

Graphics Processor Info: 
OpenGL: AMD Radeon R9 M395X OpenGL Engine

Check OpenGL support: Passed
Vendor: ATI Technologies Inc.
Version: 4.1 ATI-1.42.15
Renderer: AMD Radeon R9 M395X OpenGL Engine
LanguageVersion: 4.10
Total Video Memory: 4096 MB


Application folder: /Applications/Adobe Lightroom Classic CC
Library Path: /Users/roberto/Pictures/Lightroom/Lightroom 4 Catalog copy-2-2-2.lrcat
Settings Folder: /Users/roberto/Library/Application Support/Adobe/Lightroom

Installed Plugins: 
1) AdobeStock
2) Aperture/iPhoto Importer Plug-in
3) Canon Tether Plugin
4) DxO FilmPack 3
5) DxO FilmPack 3 (64-bit)
6) DxO OpticsPro 10
7) DxO OpticsPro 10 Importer
8) Facebook
9) Flickr
10) FocalPoint
11) HDR Efex Pro
12) HDR Efex Pro 2
13) Luminar
14) Macphun Creative Kit
15) Nikon Tether Plugin
16) ON1 Effects Standalone 10
17) Perfect B&&W 8
18) Perfect Effects 8
19) Perfect Enhance 8
20) Perfect Photo Suite 8
21) Perfect Portrait 8
22) Perfect Resize 8
23) Tonality CK

Config.lua flags: None

AudioDeviceIOBlockSize: 512
AudioDeviceName: Soundflower (2ch)
AudioDeviceNumberOfChannels: 2
AudioDeviceSampleRate: 44100
Build: 10.0x7
CoreImage: true
GL_ACCUM_ALPHA_BITS: 0
GL_ACCUM_BLUE_BITS: 0
GL_ACCUM_GREEN_BITS: 0
GL_ACCUM_RED_BITS: 0
GL_ALPHA_BITS: 8
GL_BLUE_BITS: 8
GL_DEPTH_BITS: 24
GL_GREEN_BITS: 8
GL_MAX_3D_TEXTURE_SIZE: 16384
GL_MAX_TEXTURE_SIZE: 16384
GL_MAX_TEXTURE_UNITS: 8
GL_MAX_VIEWPORT_DIMS: 16384,16384
GL_RED_BITS: 8
GL_RENDERER: AMD Radeon R9 M395X OpenGL Engine
GL_SHADING_LANGUAGE_VERSION: 1.20
GL_STENCIL_BITS: 8
GL_VENDOR: ATI Technologies Inc.
GL_VERSION: 2.1 ATI-1.42.15
OGLEnabled: true
GL_EXTENSIONS: GL_ARB_color_buffer_float GL_ARB_depth_buffer_float GL_ARB_depth_clamp GL_ARB_depth_texture GL_ARB_draw_buffers GL_ARB_draw_elements_base_vertex GL_ARB_draw_instanced GL_ARB_fragment_program GL_ARB_fragment_program_shadow GL_ARB_fragment_shader GL_ARB_framebuffer_object GL_ARB_framebuffer_sRGB GL_ARB_half_float_pixel GL_ARB_half_float_vertex GL_ARB_imaging GL_ARB_instanced_arrays GL_ARB_multisample GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_pixel_buffer_object GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_provoking_vertex GL_ARB_seamless_cube_map GL_ARB_shader_objects GL_ARB_shader_texture_lod GL_ARB_shading_language_100 GL_ARB_shadow GL_ARB_shadow_ambient GL_ARB_sync GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_compression_rgtc GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_float GL_ARB_texture_mirrored_repeat GL_ARB_texture_non_power_of_two GL_ARB_texture_rectangle GL_ARB_texture_rg GL_ARB_transpose_matrix GL_ARB_vertex_array_bgra GL_ARB_vertex_blend GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_window_pos GL_EXT_abgr GL_EXT_bgra GL_EXT_bindable_uniform GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_clip_volume_hint GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_depth_bounds_test GL_EXT_draw_buffers2 GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXT_framebuffer_object GL_EXT_framebuffer_sRGB GL_EXT_geometry_shader4 GL_EXT_gpu_program_parameters GL_EXT_gpu_shader4 GL_EXT_multi_draw_arrays GL_EXT_packed_depth_stencil GL_EXT_packed_float GL_EXT_provoking_vertex GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_stencil_two_side GL_EXT_stencil_wrap GL_EXT_texture_array GL_EXT_texture_compression_dxt1 GL_EXT_texture_compression_s3tc GL_EXT_texture_env_add GL_EXT_texture_filter_anisotropic GL_EXT_texture_integer GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_rectangle GL_EXT_texture_shared_exponent GL_EXT_texture_sRGB GL_EXT_texture_sRGB_decode GL_EXT_timer_query GL_EXT_transform_feedback GL_EXT_vertex_array_bgra GL_APPLE_aux_depth_stencil GL_APPLE_client_storage GL_APPLE_element_array GL_APPLE_fence GL_APPLE_float_pixels GL_APPLE_flush_buffer_range GL_APPLE_flush_render GL_APPLE_object_purgeable GL_APPLE_packed_pixels GL_APPLE_pixel_buffer GL_APPLE_rgb_422 GL_APPLE_row_bytes GL_APPLE_specular_vector GL_APPLE_texture_range GL_APPLE_transform_hint GL_APPLE_vertex_array_object GL_APPLE_vertex_array_range GL_APPLE_vertex_point_size GL_APPLE_vertex_program




p.p1 {margin: 0.0px 0.0px 0.0px 0.0px; font: 12.0px Helvetica; min-height: 14.0px} p.p2 {margin: 0.0px 0.0px 0.0px 140.5px; text-indent: -140.6px; font: 11.0px 'Helvetica Neue'} span.Apple-tab-span {white-space:pre}


  Model Name: iMac

  Model Identifier: iMac17,1

  Processor Name: Intel Core i7

  Processor Speed: 4 GHz

  Number of Processors: 1

  Total Number of Cores: 4

  L2 Cache (per Core): 256 KB

  L3 Cache: 8 MB

  Memory: 32 GB

  Boot ROM Version: IM171.0157.B00

  SMC Version (system): 2.34f2

  Serial Number (system): D25RP1AWGQ17

  Hardware UUID: 02671EAF-D9BD-55A3-9B12-EFBECD776492



Photo of Lars Erik Nes

Lars Erik Nes

  • 2 Posts
  • 0 Reply Likes
I run the same version and this version is very slow. 7.4 was working fine, but this 7.5 is really sluggish on my setup. (mac mini i7, 2,6 quad)
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 3885 Posts
  • 741 Reply Likes
Did you attempt the reinstall instructions related above?
Photo of Lars Erik Nes

Lars Erik Nes

  • 2 Posts
  • 0 Reply Likes
No, not yet. Will give it a few more days. If still sluggish i will reinstall :-)