Lightroom CC Classic 7.4 Hangs on Import

  • 1
  • Problem
  • Updated 2 months ago
Well, this is quite infuriating. I can't seem to import photos after upgrading to 7.4... I mean, 7.31 was excruciatingly slow, so I read somewhere to upgrade... now it doesn't work at all. After it imports 20 or so photos from a card reader, it simply sits there with the progress bar in the same place. I have tried importing photos several times. No luck. 
Photo of logan

logan

  • 3 Posts
  • 0 Reply Likes
  • frustrated

Posted 2 months ago

  • 1
Photo of James Hess

James Hess

  • 216 Posts
  • 32 Reply Likes
What operating system? How much RAM? Are you using a card reader, or are you connecting your camera?
Photo of logan

logan

  • 3 Posts
  • 0 Reply Likes
8GB RAM, MacOS 10.13.2, using a card reader...
Photo of Carlos Cardona

Carlos Cardona

  • 284 Posts
  • 51 Reply Likes
Please give your Mac the "once over"! Run the free Onyx (https://www.titanium-software.fr/en/o...), reboot. (In Onyx just run everything in the Automation tab). Run Disk Warrior if you can ($120), (https://www.alsoft.com), reboot. If you can’t do Disk Warrior, at least run First Aid from Disk Utility. Also just doing a "Safe Boot" can clear out caches and application states: restart, holding down Shift until you see "Safe Boot" on the screen, then after it finishes loading the Finder, reboot normally and test).

If that doesn’t work try launching Lightroom from your other (admin or test) account, with a new catalog, as a test. Does it run OK? If it doesn't crash it may be a corrupted preference in your Library folder. Check The Lightroom Queen site for instructions on how to reset your preferences (https://www.lightroomqueen.com).
Photo of Sunil Bhaskaran

Sunil Bhaskaran, Official Rep

  • 321 Posts
  • 111 Reply Likes
Logan,
To which location are you importing files?
What is the available storage space?

Thanks,
Sunil
Photo of logan

logan

  • 3 Posts
  • 0 Reply Likes
Onto a 5TB hard rive... about 2TB is available...