Lightroom Classic 7.0.1: Importing Images Slow

  • 7
  • Problem
  • Updated 2 weeks ago
  • (Edited)
Importing in Lightroom Classic CC has serious issues. It seems it may be related to large catalogs. Import is slow and only shows a few thumbnails and files at a time as it's importing into current import. It is slowing down everything else in LR with significant delays.

The reason I think it may be due to large catalogs is one, I had a hell of a time upgrading my catalog initially from Version 6.12 and it took 24 hours to complete that. Others with small catalogs had no issues and it went quickly. So I think LR CC Classic does not like large catalogs (mine has 440,000 images in it and is 12 GB). So I tried something new which was to create a new catalog. I noticed that catalog was speedy at first when I imported a couple folders of images, like really really speedy. Next, I imported the 440,000 images from my older LR CC Classic catalog into the new one I just created thinking I was in the clear (that took 24 hours as well btw) and now I'm back to incredibly sluggish import again with the newly created catalog.

C'mon Adobe I'm happy to pay your subscription fees, but just give us software that's been well tested before releasing without these and all the other issues I'm reading about on the community feedback pages. This is beta bug stuff and should have been squashed well before official release. And while I'm feeling angry, the whole naming convention with Lightroom CC, Lightroom CC Classic, etc is just plain BAD! It adds unnecessary confusion and makes Googling problems that much more difficult to wade through new vs. old versions.
Photo of adventure_photo

adventure_photo

  • 14 Posts
  • 6 Reply Likes
  • Annoyed

Posted 8 months ago

  • 7
Photo of JonathanB

JonathanB

  • 13 Posts
  • 4 Reply Likes
I agree there seems to be an issue with how the new import process works specifically with larger catalogues.  I have posted my experience to a similar thread here:
<https://feedback.photoshop.com/photoshop_family/topics/lr-classic-problem-with-previews-during-impor...>
Photo of Todd Thoenen

Todd Thoenen

  • 22 Posts
  • 7 Reply Likes
I agree completely, it took me over 24 hours but I have multiple HDD and over a million images. (Sports Photographer). I started just copying the files off of my CF cards and then importing them when I had time to wait. Slowing down my system and workflow.
Photo of Ronald Byram

Ronald Byram

  • 81 Posts
  • 11 Reply Likes
Ive noticed with LR Classic 7.01 that when I import the progress bar shows TWO processes happening on import not ONE like it older release. Is this normal? Can anyone confirm?
Photo of adventure_photo

adventure_photo

  • 14 Posts
  • 6 Reply Likes
Ronald, that seems normal in the new version. There is an option in prefs to create previews in parallel, but whether you check or uncheck that box it seems to do it anyway. Wish they would sort this import slowness thing out and release 7.1. Otherwise I'm really enjoying the new version and overall find it snappier except in this one regard.
(Edited)
Photo of Bart Broekhuijsen

Bart Broekhuijsen

  • 4 Posts
  • 5 Reply Likes
Yes agree.
Photo of Bart Broekhuijsen

Bart Broekhuijsen

  • 4 Posts
  • 5 Reply Likes
I have the same issue and the catalogue has 760000 images. Imported from catalogue to new catalog and goes fast but later when importing new images from HD it goes slow even with minimum previews. Tried a lot of things so I will not throw away LR2015.13. One day the solution will come from Adobe and we can use a good version of LR.
Photo of Ian M Butterfield

Ian M Butterfield

  • 20 Posts
  • 34 Reply Likes
I concur.  Catalog with 237,000 it is now really slow to import new images.  Taking 2-3 hours to import 183 images, convert to DNG, smart prevs and 1:1 prevs.   It used to do it about half an hour.  Problem appears to have started with 7.0.1 upgrade.
Photo of Steve Lipofsky

Steve Lipofsky

  • 7 Posts
  • 0 Reply Likes
Same problem.

Question for users with a smaller (say under 10,000 image catalog). Is your import slow?
Photo of Ian M Butterfield

Ian M Butterfield

  • 20 Posts
  • 34 Reply Likes
I just want to add a bit more info about this.  It is difficult to give hard and fast figures but today, I am attempting to import a shoot of 600+ images with nothing else running on the PC 

Lightroom Classic version: 7.0.1 [ 1142117 ]
License: Creative Cloud
Operating system: Windows 10
Version: 10.0
Application architecture: x64
System architecture: x64
Logical processor count: 8
Processor speed: 2.3 GHz
Built-in memory: 16316.0 MB

 I am seeing LR using up to 12Gb of my 16Gb of physical memory, my system disk is 100% active, with the page file having  reads of 0-2,500b/s  with writes of 2,500,00 b/s.  There is a little activity writing/reading to the catalog but NOTHING like the amount of activity on the page file.   

This certainly looks like a major memory issue (Memory leak?) Which ties up with what I am seeing - if I import a small shoot I don't have anywhere near the slowness I see with larger shoots.

I would also question the huge disparity between writes and reads on the pagefile.  Why is there a need to write so much out if it is hardly ever being read back?
Photo of Chris Rakoczy

Chris Rakoczy

  • 1 Post
  • 1 Reply Like
It's not just on very large imports with copying and converting to DNG.:  I'm simply trying to Add anywhere from a couple dozen to a couple thousand images at a time in a personal photo library, many JPG, some RAW / DNG, but all are being Added in place with no conversion or copying and the process is painfully slow / stalled. My system drive is an SSD and the media & catalog are on an external USB 3.0 HDD.

Running on an i7 at 2.4GHz with 16GB physical RAM and Win8 x64.

I would love to know what's going on!
Photo of Hannes Svardal

Hannes Svardal

  • 4 Posts
  • 3 Reply Likes
I also have problems with importing photos being extremely slow after the update. No DNG conversion. Catalog has 60k photos.
Photo of Reetesh Mukul

Reetesh Mukul, Employee

  • 19 Posts
  • 2 Reply Likes
@Hannes Svardalm, @Chris -- which version of Lightroom you are using. Please upgrade to latest one, and look for any speed issues.
Photo of Hannes Svardal

Hannes Svardal

  • 4 Posts
  • 3 Reply Likes
Thanks for your reply @Reetesh Mukul . I am using the lastest 7.2. I upgraded yesterday from Lightroom CC (2015). I am using Win 10 on a Lenovo T420s with Intel i5-2540M @ 2.60 GHz and 8GB of RAM. 

I started to import ~300 12 MPX RAW pictures, and now, 12 hours later the import is not finished. The same happened with imports of pictures from another camera just before that. Importing 10 pictures is reasonably quick. But a slightly larger number seem to take hours and hours. Please help.
Photo of Reetesh Mukul

Reetesh Mukul, Employee

  • 19 Posts
  • 2 Reply Likes
@Hannes Svardal -- we will get in touch with you regarding this issue.
Photo of Matthew Zory

Matthew Zory

  • 52 Posts
  • 3 Reply Likes
Any progress here? Just trying to upload 80 files! Dragging.
Photo of Ian M Butterfield

Ian M Butterfield

  • 20 Posts
  • 34 Reply Likes
Matthew, For me the import slowness went away with v7.2 - are you using the latest version (now 7.4)?  LR still has some horrible memory leaks and I find it is always best to import immediately after it has started or restarted. 

I am sure you know this already but just in case.  It can be slow if you are importing over USB2 - make sure you use a dedicated card reader that is USB3.  Oh, yes, and the speed of the memory card (if you are importing direct from a memory card) can have an effect too.