Lightroom Classic 8.1 >8.2: Missing custom profiles

  • 1
  • Problem
  • Updated 5 months ago
  • (Edited)
Since Lightroom 8.1 / ACR 11.1, .dcp camera profiles installed in ~/Library/Application Support/Adobe/CameraRaw/CameraProfiles aren't available in Lightroom.

I'm a developer who created a set of film emulation presets called Replichrome, and since 2013, our installer has put presets in that location. Everything worked fine for 5 years, until Lightroom 8.1 / ACR 11.1 broke something. AFAIK the VSCO film presets (a competing product that relies on the same basic LR features) are also broken, and I assumed this issue would be taken care of in 8.2, but after testing today, it appears not. The best advice I've been able to find is just to downgrade to an earlier version, but that's obviously not a long-term solution.

To reproduce the issue, download the trial installer (MacWin), run it, and restart LR. Our presets complain about missing profiles, and profiles aren't available in the profile list. Everything worked fine on 8.0.



So,
  1. Are .dcp profiles still supported? Did something change internally that would cause LR to ignore our profiles as of 8.1? Perhaps a change in the .dcp parser (just shooting in the dark here)
  2. Did the location LR expects to find them change?
  3. Does Lightroom log anything that would help me figure out what's happening?
Any insight would be very helpful.
Photo of Doug Boutwell

Doug Boutwell

  • 2 Posts
  • 0 Reply Likes

Posted 5 months ago

  • 1
Photo of Cameron Rad

Cameron Rad

  • 160 Posts
  • 48 Reply Likes
1. DCP are still supported. They can be combined now with Base Settings as well as HSL look tables and RGB 3DLUTs to create an "Enhanced Camera Profile". Check out the SDK at the bottom of this post: https://spark.adobe.com/page/CEUxaoWXrcY1x/
2. I don't believe the location changed. I have my own DCP Profiles in the same location and they are appearing in Lightroom. I also ran the installer and no issue was presented for me. Your profiles show up fine on my end.  

3. Is the missing profile problem you're running into happening for every brand/model camera or is it just specific ones?
(Edited)
Photo of Doug Boutwell

Doug Boutwell

  • 2 Posts
  • 0 Reply Likes
Thanks for the followup, Cameron, and I appreciate you taking the time to try and reproduce the issue. Knowing that the process worked fine for you, but was broken for me, helped point me toward some other ideas.

I poked around a little more, and discovered it was a permissions issue on my system. This doesn't explain why only some of our customers are experiencing the issue, but at least I can build some better logic into the installer now, and hopefully fix the issue.

For future reference, ownership of the CameraProfiles folder was set to root:staff, instead of doug:staff. Even though I'm a member of the staff group, and the presets have group read permission, apparently Lightroom or the OS didn't like something about the permissions.

sudo chown -R doug:staff ~/Library/Application Support/Adobe/CameraRaw/CameraProfiles

seemed to do the trick. Weird.