Lightroom Desktop: Add photo button greyed out. I cant import photo

  • 9
  • Problem
  • Updated 2 days ago
  • Acknowledged
  • (Edited)
lightroom cc 2019 add photo button greyed out. I cant import photo
Photo of emo d the shooters

emo d the shooters

  • 3 Posts
  • 1 Reply Like

Posted 6 months ago

  • 9
Photo of jason


  • 9 Posts
  • 1 Reply Like

I get a 404 not found
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 5505 Posts
  • 1157 Reply Likes
Could you send me a diagnostic log, Jason. 

Preferences>Account and hold down the [Alt/Opt] button to expose the [Diagnostic Log] button. 
Send to:
Photo of Rajesh Bhosale

Rajesh Bhosale

  • 1 Post
  • 0 Reply Likes
I am also facing the Same problem,  LR import photo button is greyed.
Photo of Susan Warner

Susan Warner

  • 2 Posts
  • 0 Reply Likes
Hi Rikk,

I'm having the same problem as well.
I'm also on an enterprise account and am using a mac, I can see the photos at
I get a 404 error at
I tried adding config.lua and it did not work.
Would you like me to send you the logs?

Photo of Susan Warner

Susan Warner

  • 2 Posts
  • 0 Reply Likes
I couldn't comment on this thread with my enterprise login so the email linked to this message is not my adobe id however I've added it as a non-primary email to this account if you need to see the details.
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 5522 Posts
  • 1162 Reply Likes
Susan - send your logs.
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 5596 Posts
  • 1184 Reply Likes
Thanks for the reports. Our engineer would like you to perform another test if possible as we are still seeking to isolate the problem:

Can you please let user try the steps as follow ?

  1. Download the "config.lua" file from the shared url :
  2. Go to the folder, and copy the "config.lua" file to that folder.
    /Users/<username>/Library/Application Support/Adobe/Adobe Lightroom CC Helper/
    C:\Users\<username>\AppData\Roaming\Adobe\Adobe Lightroom CC Helper/
  3. Launch Lightroom and then quit the app.
The log file will be generated to the user's document folder. Can you go to the Document folder and copy all the "*.log" files and send to us? Thank you so much!

Send the file to:

Photo of Erika Finbraaten

Erika Finbraaten

  • 1 Post
  • 0 Reply Likes
I've tried to use Lightroom Web and I can get photos uploaded, but can't get them into my desktop and can't figure out how to pull them into PhotoShop to do the Panorama that I need for my project. I've sent a Diagnostic Log in using my work account, but I had to use my personal email to send this message. I'll add it as an alternate email. Let me know if there's anything you come up with so that I can finish my project by July 2. 
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 5596 Posts
  • 1184 Reply Likes
If you've loaded your images in via Lightroom Web, you just need to allow them to sync down to the Lightroom Desktop client. Once they have synced down, you can then select them, right click and choose PhotoMerge>Panorama Merge. 

Have you allowed your Desktop software to fully sync them down from the cloud?
Photo of Reiner


  • 2 Posts
  • 0 Reply Likes
So I took a look at the log files and figured out that the '+' button is greyed out (in my case) because of the Proxy configuration in Windows.

ERROR registration call failed with message = "Received HTTP code 407 from proxy after CONNECT"

When I start Lightroom CC without Proxy configuration Lightroom allows me to add photos. We use Lightroom in a professional environment where we don't want to disable the Proxy settings for our users. I hope there is a fix in a future update, that will allow our coworkers to add photos to Lightroom with enabled Proxy configuration.
Photo of Yuhong

Yuhong, Employee

  • 95 Posts
  • 5 Reply Likes
Hi Reiner, thanks for the info. Is your test on Windows Or Mac ?

HTTP 407 (Proxy Authentication Required) indicates some authentication problem when talking to proxy server. Does your proxy server require credentials? Is it using Basic as the authenticatin scheme?

Also, during your test with proxy, does Lightroom ever pop up a window asking for proxy server credentials?
Photo of Reiner


  • 2 Posts
  • 0 Reply Likes
Hi, it's a Windows client. Yes, our Proxy uses an Active Directory authentication with the basic authentication scheme.

There is no popup window for the logon credentials.
Photo of Tomas C

Tomas C

  • 2 Posts
  • 0 Reply Likes
I was having the same issue on my corporate account and what helped was to switch from wired connection to our guest wifi (i guess no firewalls), launch it once, and now it works fine on wired too!
Photo of Artem Zateev

Artem Zateev

  • 1 Post
  • 0 Reply Likes
I've successfully solved the issue with "greyed out button" In my case the issue was caused by bad SSL certificates for (it was detected in Windows Events log and confirmed in Internet Explorer 11 while visiting Adobe site) which were replaced by corrupted security software (Kaspersky Endpoint Protection v9) and abother software named Infowatch. Removing both of them allowed to upload new certificates and LR starts working correctly.
Photo of Ricky Nelson Muganda

Ricky Nelson Muganda

  • 1 Post
  • 0 Reply Likes
This reply was created from a merged topic originally titled Import Photos is Greyed Out.

My Data 

Lightroom CC version: 2.0.1 [ 20181010-2058-b947969 ] (Oct 10 2018)
Operating system: Windows 10
OS Version: 10.0 [17763]
Application architecture: x64
System architecture: x64
Logical processor count: 4
Processor speed: 3.3 GHz
Built-in memory: 8079.3 MB
Real memory available to Lightroom CC: 8079.3 MB
Real memory used by Lightroom CC: 163.3 MB (2.0%)
Virtual memory used by Lightroom CC: 135.9 MB
Memory cache size: 0.0 MB
Internal Camera Raw revision: 61
Maximum thread count used by Camera Raw: 3
Camera Raw SIMD optimization: SSE2,AVX
Camera Raw virtual memory: 0MB / 4039MB (0%)
Camera Raw real memory: 0MB / 8079MB (0%)
System DPI setting: 96 DPI
Desktop composition enabled: Yes
Displays: 1) 1600x900, 2) 1366x768
Input types: Multitouch: No, Integrated touch: No, Integrated pen: No, External touch: No, External pen: No, Keyboard: No

Graphics Processor Info: 
Check OpenGL support: Failed
Vendor: Intel
Version: 3.3.0 - Build
Renderer: Intel(R) HD Graphics 2500
LanguageVersion: 3.30 - Build

Application folder: C:\Program Files\Adobe\Adobe Lightroom CC
Settings Folder: C:\Users\Ricky Cinemax\AppData\Roaming\Adobe\Lightroom CC

Adapter #1: Vendor : 8086
Device : 152
Subsystem : 2abf103c
Revision : 9
Video Memory : 32
Adapter #2: Vendor : 1414
Device : 8c
Subsystem : 0
Revision : 0
Video Memory : 0
AudioDeviceIOBlockSize: 1024
AudioDeviceName: Speakers (Realtek High Definition Audio)
AudioDeviceNumberOfChannels: 2
AudioDeviceSampleRate: 48000
Build: 12.1x4
Direct2DEnabled: false
GL_RENDERER: Intel(R) HD Graphics 2500
GL_VERSION: 4.0.0 - Build
GPUDeviceEnabled: false
OGLEnabled: true
GL_EXTENSIONS: GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_blend_color GL_EXT_abgr GL_EXT_texture3D GL_EXT_clip_volume_hint GL_EXT_compiled_vertex_array GL_SGIS_texture_edge_clamp GL_SGIS_generate_mipmap GL_EXT_draw_range_elements GL_SGIS_texture_lod GL_EXT_rescale_normal GL_EXT_packed_pixels GL_EXT_texture_edge_clamp GL_EXT_separate_specular_color GL_ARB_multitexture GL_ARB_map_buffer_alignment GL_ARB_conservative_depth GL_EXT_texture_env_combine GL_EXT_bgra GL_EXT_blend_func_separate GL_EXT_secondary_color GL_EXT_fog_coord GL_EXT_texture_env_add GL_ARB_texture_cube_map GL_ARB_transpose_matrix GL_ARB_internalformat_query GL_ARB_internalformat_query2 GL_ARB_texture_env_add GL_IBM_texture_mirrored_repeat GL_EXT_multi_draw_arrays GL_SUN_multi_draw_arrays GL_NV_blend_square GL_ARB_texture_compression GL_3DFX_texture_compression_FXT1 GL_EXT_texture_filter_anisotropic GL_ARB_texture_border_clamp GL_ARB_point_parameters GL_ARB_texture_env_combine GL_ARB_texture_env_dot3 GL_ARB_texture_env_crossbar GL_EXT_texture_compression_s3tc GL_ARB_shadow GL_ARB_window_pos GL_EXT_shadow_funcs GL_EXT_stencil_wrap GL_ARB_vertex_program GL_EXT_texture_rectangle GL_ARB_fragment_program GL_EXT_stencil_two_side GL_ATI_separate_stencil GL_ARB_vertex_buffer_object GL_EXT_texture_lod_bias GL_ARB_occlusion_query GL_ARB_fragment_shader GL_ARB_shader_objects GL_ARB_shading_language_100 GL_ARB_texture_non_power_of_two GL_ARB_vertex_shader GL_NV_texgen_reflection GL_ARB_point_sprite GL_ARB_fragment_program_shadow GL_EXT_blend_equation_separate GL_ARB_depth_texture GL_ARB_texture_rectangle GL_ARB_draw_buffers GL_ARB_color_buffer_float GL_ARB_half_float_pixel GL_ARB_texture_float GL_ARB_pixel_buffer_object GL_EXT_framebuffer_object GL_ARB_draw_instanced GL_ARB_half_float_vertex GL_ARB_occlusion_query2 GL_EXT_draw_buffers2 GL_WIN_swap_hint GL_EXT_texture_sRGB GL_ARB_multisample GL_EXT_packed_float GL_EXT_texture_shared_exponent GL_ARB_texture_rg GL_ARB_texture_compression_rgtc GL_NV_conditional_render GL_ARB_texture_swizzle GL_EXT_texture_swizzle GL_ARB_texture_gather GL_ARB_sync GL_ARB_framebuffer_sRGB GL_EXT_packed_depth_stencil GL_ARB_depth_buffer_float GL_EXT_transform_feedback GL_ARB_transform_feedback2 GL_ARB_draw_indirect GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_ARB_framebuffer_object GL_ARB_framebuffer_no_attachments GL_EXT_texture_array GL_EXT_texture_integer GL_ARB_map_buffer_range GL_ARB_texture_buffer_range GL_EXT_texture_buffer GL_EXT_texture_snorm GL_ARB_blend_func_extended GL_INTEL_performance_queries GL_INTEL_performance_query GL_ARB_copy_buffer GL_ARB_sampler_objects GL_NV_primitive_restart GL_ARB_seamless_cube_map GL_ARB_uniform_buffer_object GL_ARB_depth_clamp GL_ARB_vertex_array_bgra GL_ARB_shader_bit_encoding GL_ARB_draw_buffers_blend GL_ARB_geometry_shader4 GL_EXT_geometry_shader4 GL_ARB_texture_query_lod GL_ARB_explicit_attrib_location GL_ARB_draw_elements_base_vertex GL_ARB_instanced_arrays GL_ARB_base_instance GL_ARB_fragment_coord_conventions GL_EXT_gpu_program_parameters GL_ARB_texture_buffer_object_rgb32 GL_ARB_compatibility GL_ARB_texture_rgb10_a2ui GL_ARB_texture_multisample GL_ARB_vertex_type_2_10_10_10_rev GL_ARB_timer_query GL_ARB_tessellation_shader GL_ARB_vertex_array_object GL_ARB_provoking_vertex GL_ARB_sample_shading GL_ARB_texture_cube_map_array GL_EXT_gpu_shader4 GL_ARB_gpu_shader5 GL_ARB_gpu_shader_fp64 GL_ARB_shader_subroutine GL_ARB_transform_feedback3 GL_ARB_get_program_binary GL_ARB_separate_shader_objects GL_ARB_shader_precision GL_ARB_vertex_attrib_64bit GL_ARB_viewport_array GL_ARB_transform_feedback_instanced GL_ARB_compressed_texture_pixel_storage GL_ARB_shader_atomic_counters GL_ARB_shading_language_packing GL_ARB_shading_language_420pack GL_ARB_texture_storage GL_EXT_texture_storage GL_ARB_vertex_attrib_binding GL_ARB_multi_draw_indirect GL_ARB_program_interface_query GL_ARB_texture_storage_multisample GL_ARB_buffer_storage GL_ARB_debug_output GL_KHR_debug GL_ARB_arrays_of_arrays GL_INTEL_map_texture GL_ARB_texture_compression_bptc GL_ARB_ES2_compatibility GL_ARB_ES3_compatibility GL_ARB_robustness GL_EXT_texture_sRGB_decode GL_KHR_blend_equation_advanced GL_EXT_shader_integer_mix GL_ARB_stencil_texturing 
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 5596 Posts
  • 1184 Reply Likes
Please update to 2.3 and let us know if you are still experiencing the issue.