Lightroom CC 2015 Loses focus on starting a background thread

  • 1
  • Problem
  • Updated 2 years ago
Issue started with the update that extended use of background threads to allow more multi-tasking.
A side effect is that it appears the new background thread takes the input focus.
That is: the windows internal/hidden messages that carry info on keyboard hits and mouse movements/clicks fail to get to the foreground user interface.
The annoying and irritating consequence is that the user has to actively regain focus in some way e.g. by clicking on the current image.
This happens in many ways and is not generally reliably repeatable, however two examples that I notice are:
A) in the develop module on using sync. The changes happen and the thumbnails update OK but the on trying to step to the next image using the keyboard curser key (right arrow) nothing happens. It is necessary to click with the mouse on the boundary of the image display before the user interface will respond. It looks like the keyboard messages go to the sync thread and do not get to the user interface.
This is not how the interface behaved with previous releases.
B) using the import module. Generally the first step on opening Lightroom is to import new images. Previously the user interface would always display the set of new images. Since the multi-tasking change this does not happen reliably and it is often necessary to go searching for the folder holing the new images. This is annoying and waists time.
Is Adobe aware of this? It looks to me as an ex software engineer as poor quality implementation of the multi threading object.
Photo of Geoffrey Phillips

Geoffrey Phillips

  • 15 Posts
  • 0 Reply Likes
  • irritated

Posted 2 years ago

  • 1

Be the first to post a reply!